Impossible de créer ou répondre à un élément de discussion dans un site de communauté SharePoint Server 2013 importé

IMPORTANT : Cet article est issu d'une traduction automatique réalisée par un logiciel Microsoft et non par un traducteur professionnel. Cette traduction automatique a pu aussi être révisée par la communauté Microsoft grâce à la technologie Community Translation Framework (CTF). Pour en savoir plus sur cette technologie, veuillez consulter la page http://support.microsoft.com/gp/machine-translation-corrections/fr. Microsoft vous propose en effet des articles traduits par des professionnels, des articles issus de traductions automatiques et des articles issus de traductions automatiques révisées par la communauté Microsoft, de manière à ce que vous ayez accès à tous les articles de notre Base de connaissances dans votre langue. Il est important de noter que les articles issus de la traduction automatique, y compris ceux révisés par la communauté Microsoft, peuvent contenir des erreurs de vocabulaire, de syntaxe ou de grammaire. Microsoft ne pourra être tenu responsable des imprécisions, erreurs, ainsi que de tout dommage résultant d’une traduction incorrecte du contenu ou de son utilisation par les clients.

La version anglaise de cet article est la suivante: 3060489
Symptômes
Lorsque vous essayez de créer un élément de discussion ou une réponse à un élément de discussion dans un site de communauté de Microsoft SharePoint Server 2013, le message d'erreur suivant s'affiche :
Désolé, un problème
Impossible de terminer cette action.
Essayez à nouveau.

Ce problème se produit si le site de la Communauté est un sous-site qui est importé à partir d'un site de niveau supérieur.
Résolution
Pour résoudre ce problème, exécutez les applets de commande Windows PowerShell suivante :
$web2 = get-spweb <URL of the nonworking sub site>$l2 = $web2.Lists.TryGetList("Discussions List")$f2 = $l2.Fields.GetField("MemberLookup")$f2.Sealed = $false$f2.Update()$f2.RelationshipDeleteBehavior = 2$f2.Update()
Remarque Ces applets de commande définir la valeur de laRelationshipDeleteBehavior propriété à 2. Cette action a résolu le problème.
Plus d'informations
Vous constatez des erreurs semblables aux suivants dans les journaux du service ULS de SharePoint Server 2013 :
04/15/2015 15:25:34.91 w3wp.exe (0x09B4) 0x1580 LockManager haute f8qz de relations de recherche SharePoint Foundation : verrouillage du Web A auraient dû être prise ici. xxx
04/15/2015 15:25:34.91 w3wp.exe (0x09B4) 0x1580 SharePoint Foundation général 8kh7 élevé ne peut effectuer cette action. Essayez à nouveau. xxx
04/15/2015 15:25:34.91 w3wp.exe (0x09B4) 0x1580 SPRequest.AddOrUpdateItem haute aix9j de SharePoint Foundation général : UserPrincipalName=i:0).w|s-1-5-21-xxx-xxx-xxx-500, AppPrincipalName =, bstrUrl = http://false/, bstrListName = {xxxx}, bajoutez = True, bSystemUpdate = False, bPreserveItemVersion = False, bPreserveItemUIVersion = False, bUpdateNoVersion = False, pbstrNewDocId = 00000000-0000-0000-0000-type "000000000000", bHasNewDocId = False, bstrVersion =<null> , bCheckOut = False, bCheckin = False, bUnRestrictedUpdateInProgress = False, bMigration = False, bPublish = False, bstrNomFichier =<null> xxx</null> </null>

Avertissement : Cet article a été traduit automatiquement.

Propriétés

ID d'article : 3060489 - Dernière mise à jour : 03/10/2016 09:01:00 - Révision : 3.0

Microsoft SharePoint Server 2013, Microsoft SharePoint Server 2013 Service Pack 1

  • kbsurveynew kbexpertiseinter kbexpertisebeginner kbfix kbbug kbtshoot kbmt KB3060489 KbMtfr
Commentaires