Photos de l'utilisateur ne sont pas synchronisées à partir de l'environnement local vers Exchange Online dans un déploiement hybride

IMPORTANT : Cet article est issu d'une traduction automatique réalisée par un logiciel Microsoft et non par un traducteur professionnel. Cette traduction automatique a pu aussi être révisée par la communauté Microsoft grâce à la technologie Community Translation Framework (CTF). Pour en savoir plus sur cette technologie, veuillez consulter la page http://support.microsoft.com/gp/machine-translation-corrections/fr. Microsoft vous propose en effet des articles traduits par des professionnels, des articles issus de traductions automatiques et des articles issus de traductions automatiques révisées par la communauté Microsoft, de manière à ce que vous ayez accès à tous les articles de notre Base de connaissances dans votre langue. Il est important de noter que les articles issus de la traduction automatique, y compris ceux révisés par la communauté Microsoft, peuvent contenir des erreurs de vocabulaire, de syntaxe ou de grammaire. Microsoft ne pourra être tenu responsable des imprécisions, erreurs, ainsi que de tout dommage résultant d’une traduction incorrecte du contenu ou de son utilisation par les clients.

La version anglaise de cet article est la suivante: 3062745
PROBLÈME
Vous avez un déploiement hybride de sur site Microsoft Exchange Server et Microsoft Exchange Online dans Microsoft Office 365. Lorsque vous modifiez les photos d'un utilisateur d'Office 365 en accédant aux informations locales de l'utilisateur, la modification n'est pas synchronisée avec Exchange Online. Par exemple, lorsque l'utilisateur affiche la photo de son dans Outlook, Outlook sur le web (anciennement Outlook Web App) ou Skype pour Business Online, photo de profil Exchange Online précédente de l'utilisateur est toujours affichée.
CAUSE
Bien que l'attribut thumbnailPhoto est synchronisé à partir de l'environnement local vers Azure Active Directory (AD Azure), les éléments suivants peuvent provoquer ce problème.

Remarque L'attribut thumbnailPhoto peut stocker une photo de l'utilisateur aussi grande que 100 kilo-octets (Ko).
  • L'attribut thumbnailPhoto est synchronisée qu'une seule fois entre Azure AD et Exchange Online. Toute modification ultérieure de l'attribut à partir de l'environnement local n'ont pas été synchronisées à la boîte aux lettres Exchange Online.
  • Exchange Online accepte uniquement une photo qui n'est pas supérieure à 10 Ko à partir d'AD Azure.
Solution
Pour modifier la photo de l'utilisateur, utilisez l'applet de commande Set-UserPhoto ou Outlook sur le web. Ces méthodes permettent de charger une photo qui est plus grande que 500 Ko.

Utilisez l'applet de commande Set-UserPhoto (pour les administrateurs)

Pour modifier la photo de l'utilisateur à l'aide de l'applet de commande Set-UserPhoto , procédez comme suit :
  1. Se connecter à Exchange Online à l'aide du PowerShell à distance. Pour ce faire, procédez comme suit :

    Important Pour utiliser l'applet de commande Set-UserPhoto pour ses fonctionnalités de sa taille maximale, vous devez modifier la connexion URI en ajoutant ? proxyMethod = RPS au paramètre ConnectionUri .
    1. $Session = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri https://outlook.office365.com/powershell-liveid/?proxyMethod=RPS -Credential (Get-Credential) -Authentication Basic -AllowRedirection  
    2. Import-PSSession $Session -AllowClobber -WarningAction SilentlyContinue -ErrorAction SilentlyContinue
    Pour plus d'informations, reportez-vous à la section.Se connecter à Exchange Online à l'aide de PowerShell.
  2. Exécutez la commande Set-UserPhoto pour modifier la photo de l'utilisateur. Pour plus d'informations, reportez-vous à la section. Ensemble-UserPhoto.

Utiliser Outlook sur le web

Pour plus d'informations sur la façon de modifier une photo de l'utilisateur dans Outlook sur le web, consultezMise à jour de mes informations de compte et de photo dans Outlook Web App.
Plus d'informations
Administrateurs peuvent utiliser l'applet de commande Set-UserPhoto pour modifier leurs propres photos sans avoir à modifier le paramètre ConnectionUri . Toutefois, pour modifier la photo de l'utilisateur à un autre, administrateurs devez d'abord modifier le paramètre ConnectionUri . Si le paramètre n'est pas modifié, administrateurs de recevoir le message d'erreur suivant lorsqu'ils utilisent l'applet de commande pour modifier la photo de l'utilisateur :
Demande de retour d'erreur avec le message d'erreur suivant :
Le serveur distant a renvoyé une erreur: (413) demande entité trop grand...
+ CategoryInfo : NotSpecified: (:) [Set-UserPhoto], CmdletProxyException
+ FullyQualifiedErrorId : Microsoft.Exchange.Configuration.CmdletProxyException,Microsoft.Exchange.Management.RecipientTasks.SetUserPhoto
+ PSComputerName : outlook.office365.com
RÉFÉRENCES
Pour plus d'informations, consultez l'article suivant de la Base de connaissances Microsoft :
2497721 Photos de contact utilisateur dans Lync ne s'affichent pas correctement
Besoin d'aide ? Accédez à la Communauté Office 365 site Web ou le Exchange sur les Forums TechNet.

Avertissement : Cet article a été traduit automatiquement.

Propriétés

ID d'article : 3062745 - Dernière mise à jour : 03/11/2016 02:58:00 - Révision : 3.0

Microsoft Exchange Online, Microsoft Exchange Server 2013 Enterprise, Microsoft Exchange Server 2013 Standard

  • o365022013 o365 o365e o365m o365a hybrid kbmt KB3062745 KbMtfr
Commentaires