EWS retourne un code de réponse de succès, même si une demande de suppression par lots n'est pas achevée dans Exchange Server 2013

IMPORTANT : Cet article est issu d'une traduction automatique réalisée par un logiciel Microsoft et non par un traducteur professionnel. Cette traduction automatique a pu aussi être révisée par la communauté Microsoft grâce à la technologie Community Translation Framework (CTF). Pour en savoir plus sur cette technologie, veuillez consulter la page http://support.microsoft.com/gp/machine-translation-corrections/fr. Microsoft vous propose en effet des articles traduits par des professionnels, des articles issus de traductions automatiques et des articles issus de traductions automatiques révisées par la communauté Microsoft, de manière à ce que vous ayez accès à tous les articles de notre Base de connaissances dans votre langue. Il est important de noter que les articles issus de la traduction automatique, y compris ceux révisés par la communauté Microsoft, peuvent contenir des erreurs de vocabulaire, de syntaxe ou de grammaire. Microsoft ne pourra être tenu responsable des imprécisions, erreurs, ainsi que de tout dommage résultant d’une traduction incorrecte du contenu ou de son utilisation par les clients.

La version anglaise de cet article est la suivante: 3076257
Symptômes
Lorsque vous émettez une requête de lots à partir des Services Web Exchange pour supprimer des éléments, l'opération de suppression ne peut pas être terminée en une minute dans Microsoft Exchange Server 2013, et vous recevez un code de réponse de succès au lieu d'un code de délai d'attente même si la operationisn't est terminée. Le code de réponse incorrecte indiquant la réussite ressemble à ceci :
<?xml version="1.0" encoding="utf-8"?><s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/">  <s:Header>  <h:ServerVersionInfo MajorVersion="15" MinorVersion="1" MajorBuildNumber="184" MinorBuildNumber="17" Version="V2_43" xmlns:h="http://schemas.microsoft.com/exchange/services/2006/types" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" />  </s:Header>  <s:Body>  <m:DeleteItemResponse xmlns:m="http://schemas.microsoft.com/exchange/services/2006/messages" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:t="http://schemas.microsoft.com/exchange/services/2006/types">  <m:ResponseMessages>  <m:DeleteItemResponseMessage ResponseClass="Success">  <m:ResponseCode>NoError</m:ResponseCode>  </m:DeleteItemResponseMessage>  <m:DeleteItemResponseMessage ResponseClass="Success">  <m:ResponseCode>NoError</m:ResponseCode>  </m:DeleteItemResponseMessage>[...]  <m:DeleteItemResponseMessage ResponseClass="Success">  <m:ResponseCode>NoError</m:ResponseCode>  </m:DeleteItemResponseMessage>  <m:DeleteItemResponseMessage ResponseClass="Success">  <m:ResponseCode>NoError</m:ResponseCode>  </m:DeleteItemResponseMessage>  </m:ResponseMessages>  </m:DeleteItemResponse>  </s:Body></s:Envelope>
Toutefois, le code de réponse attendu doit être comme suit :
<?xml version="1.0" encoding="utf-8"?><s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/">  <s:Header>  <h:ServerVersionInfo MajorVersion="15" MinorVersion="1" MajorBuildNumber="184" MinorBuildNumber="17" Version="V2_43" xmlns:h="http://schemas.microsoft.com/exchange/services/2006/types" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" />  </s:Header>  <s:Body>  <m:DeleteItemResponseMessage ResponseClass="Error">  <m:MessageText>The request timed out.</m:MessageText>  <m:ResponseCode>ErrorTimeoutExpired</m:ResponseCode>  <m:DescriptiveLinkKey>0</m:DescriptiveLinkKey>  </m:DeleteItemResponseMessage>  </s:Body></s:Envelope>
Remarque La durée de l'opération de suppression est calculée à partir de lorsque la demande est envoyée et la réponse est reçue.
Cause
Ce problème se produit en raison d'une régression introduite dans mise à jour cumulative 4 ou mise à jour cumulative 5 pour Exchange Server 2013.
Résolution
Pour résoudre ce problème, installezmise à jour cumulative 10 pour Exchange Server 2013.
Statut
Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Avertissement : Cet article a été traduit automatiquement.

Propriétés

ID d'article : 3076257 - Dernière mise à jour : 09/15/2015 22:42:00 - Révision : 1.0

Microsoft Exchange Server 2013 Enterprise, Microsoft Exchange Server 2013 Standard

  • kbqfe kbsurveynew kbfix kbexpertiseadvanced kbmt KB3076257 KbMtfr
Commentaires