Déploiement de Windows 7 échoue au cours d'une actualisation de l'ordinateur ou le remplacement

IMPORTANT : Cet article est issu d'une traduction automatique réalisée par un logiciel Microsoft et non par un traducteur professionnel. Cette traduction automatique a pu aussi être révisée par la communauté Microsoft grâce à la technologie Community Translation Framework (CTF). Pour en savoir plus sur cette technologie, veuillez consulter la page http://support.microsoft.com/gp/machine-translation-corrections/fr. Microsoft vous propose en effet des articles traduits par des professionnels, des articles issus de traductions automatiques et des articles issus de traductions automatiques révisées par la communauté Microsoft, de manière à ce que vous ayez accès à tous les articles de notre Base de connaissances dans votre langue. Il est important de noter que les articles issus de la traduction automatique, y compris ceux révisés par la communauté Microsoft, peuvent contenir des erreurs de vocabulaire, de syntaxe ou de grammaire. Microsoft ne pourra être tenu responsable des imprécisions, erreurs, ainsi que de tout dommage résultant d’une traduction incorrecte du contenu ou de son utilisation par les clients.

La version anglaise de cet article est la suivante: 3084782
Symptômes
Déploiement de Windows 7 échoue lors de l'actualisation ou remplacement d'un ordinateur. Dans ce cas, le message d'erreur suivant peut s'afficher :

Le programme ne peut pas démarrer car DismApi.DLL est manquant sur votre ordinateur. Essayez de réinstaller le programme pour résoudre ce problème.
Cause
Ce problème se produit en raison de dépendances sur le composant de Loadstate.exe sur des ordinateurs Windows 7 manquantes.
Résolution
Pour résoudre ce problème, appliquez l'une des méthodes suivantes.

Méthode 1

Lorsque vous installez le Kit de déploiement Windows (Windows ADK) et d'évaluation Windows, sélectionnez la fonctionnalité Outils de déploiement en plus de l'outil de Migration Windows utilisateur état (USMT). Ensuite, exécutez Scanstate.exe à partir d'une invite de commande des outils de déploiement.

Méthode 2

Si vous ne pouvez pas installer le Windows ADK sur le système qui exécute Loadstate, installez l'ADK 10 Windows sur un autre système (et assurez-vous que vous installez également le composant Outils de déploiement). Ensuite, procédez comme suit :

  1. Recherchez le dossier de l'architecture appropriée à partir des chemins suivants sur le système qui a l'ADK installé :

    • Pour x 64 ordinateurs

      C:\Program Files (x 86) \Windows Kits\10\Assessment et Tools\amd64\DISM de Kit\Deployment de déploiement

      C:\Program Files (x 86) \Windows Kits\10\Assessment et Tools\x86\DISM de Kit\Deployment de déploiement
    • Pour x 32 ordinateurs

      C:\Program Files\Windows Kits\10\Assessment et Tools\amd64\DISM de Kit\Deployment de déploiement

      C:\Program Files\Windows Kits\10\Assessment et Tools\x86\DISM de Kit\Deployment de déploiement
  2. Copiez les fichiers binaires suivants dans le dossier d'architecture correspondante à l'étape 1 qui contient Loadstate.exe :

    • dismapi.dll
    • API-MS-Win-downlevel-Advapi32-L1-1-1.dll
    • API-MS-Win-downlevel-Kernel32-L1-1-0.dll
    • API-MS-Win-downlevel-Kernel32-L2-1-0.dll
    • API-MS-Win-downlevel-Ole32-L1-1-1.dll
    • API-MS-Win-downlevel-User32-L1-1-1.dll
    • API-MS-Win-downlevel-version-L1-1-0.dll
  3. Si vous utilisez System Center Configuration Manager, mettre à jour le package de l'outil USMT sur les points de distribution qui contient le package de l'outil USMT.
Par exemple, si vous souhaitez mettre à jour le package x 64 déploiements, copiez les fichiers à l'étape 2 dans le dossier suivant :

C:\Program Files (x 86) \Windows Kits\10\Assessment et Setup\amd64\Sources de Kit\Windows de déploiement
Ensuite, collez les fichiers dans le dossier suivant :
C:\Program Files (x 86) \Windows Kits\10\Assessment et MigrationTool\amd64 l'état de déploiement Kit\User

Avertissement : Cet article a été traduit automatiquement.

Propriétés

ID d'article : 3084782 - Dernière mise à jour : 01/11/2016 02:40:00 - Révision : 3.0

Windows 7 Entreprise, Windows 7 Professionnel, Windows 7 Édition Integrale

  • kbexpertiseadvanced kbsurveynew kbtshoot kbmt KB3084782 KbMtfr
Commentaires