Une requête Plug-and-Play universel non valide peut perturber le système d'exploitation

Le support de Windows XP a pris fin

Microsoft a mis fin au support de Windows XP le 8 avril 2014. Cette modification a affecté vos mises à jour logicielles et options de sécurité. Découvrez les implications de ce changement à votre niveau et la marche à suivre pour rester protégé.

Ancien nº de publication de cet article : F309073
Cet article a été archivé. Il est proposé « en l'état » et ne sera plus mis à jour.

Pour plus d'informations sur les implications de ce problème de sécurité pour Windows Millenium Edition, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
311311 Une requête Plug-and-Play universel non valide peut perturber le système d'exploitation
Symptômes
En envoyant un ensemble particulier de commandes à un ordinateur Windows XP affecté, un agresseur pourrait progressivement épuiser les ressources du système jusqu'au point où les performances seraient ralenties ou réduites à néant.

Plusieurs restrictions importantes s'appliquent à ce problème de sécurité :
  • Windows NT 4.0 et Windows 2000 ne sont pas affectés du tout par ce problème.
  • Sous Windows XP, le composant affecté est installé et actif par défaut, mais la fonctionnalité de pare-feu de connexion Internet réduit considérablement la capacité d'un agresseur à localiser l'ordinateur.
  • Si vous installez le service Partage de connexion Internet de Windows XP sur un ordinateur tournant sous Windows 98 ou Windows 98 Deuxième Édition.
Cause
Ce problème de sécurité est dû au fait que le service Plug-and-Play universel (UPnP) qui est livré avec ou qui peut être installé sur Windows XP ne gère pas correctement certaines requêtes. Dans Windows XP, ces requêtes peuvent entraîner une fuite de mémoire qui, si elle est exploitée plusieurs fois de suite, peut épuiser les ressources système au point d'en dégrader les performances.

Le service Plug-and-Play universel (UPnP) sera installé si vous installez le service Partage de connexion Internet de Windows XP sur un ordinateur tournant sous Windows 98 ou Windows 98 Deuxième Édition.
Résolution

Windows XP

Un correctif pris en charge est désormais disponible auprès de Microsoft, mais il est destiné uniquement à résoudre le problème décrit dans cet article et ne doit être appliqué qu'aux systèmes reconnus comme étant vulnérables. Vérifiez l'accessibilité physique de votre ordinateur, la connectivité réseau et Internet, ainsi que d'autres facteurs afin de déterminer le niveau de risque auquel est soumis votre ordinateur. Consultez lebulletin de sécurité Microsoft associé pour vous aider à effectuer cette évaluation. Ce correctif pourra être soumis à des tests ultérieurs afin d'assurer la qualité du produit. Si votre ordinateur est réellement exposé, Microsoft vous recommande d'utiliser ce correctif dès à présent. Sinon, attendez la sortie du prochain Service Pack de Windows XP qui le contiendra.

Pour résoudre ce problème dès à présent, téléchargez ce correctif en suivant les instructions ci-dessous ou procurez-vous le correctif auprès des services de Support technique Microsoft. Pour obtenir une liste complète des services de Support technique Microsoft et leur numéro de téléphone, ainsi que des informations relatives aux frais de support technique, consultez le site Web de Microsoft à l'adresse suivante :

REMARQUE : dans certains cas, les frais généralement encourus en faisant appel au Support technique peuvent être annulés si un technicien du Support technique Microsoft détermine qu'une mise à jour spécifique peut résoudre votre problème. Les tarifs normaux seront appliqués à toute question de support supplémentaire, ainsi qu'aux problèmes qui ne relèvent pas de la mise à jour spécifique en question.

Cette mise à jour est disponible sur le site Web Microsoft Windows Update. Date de publication : 25 octobre 2001

Pour plus d'informations sur le téléchargement des fichiers du Support technique Microsoft, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
119591 Procédure pour obtenir des fichiers de support technique Microsoft auprès des services en ligne
Microsoft a utilisé les logiciels de détection de virus les plus récents disponibles à la date de publication pour détecter la présence de virus dans ce fichier. Une fois publié, le fichier est conservé sur des serveurs sécurisés, empêchant toute modification non autorisée du fichier.

La version anglaise de ce correctif doit avoir les attributs de fichier suivants ou ceux d'une version ultérieure :
   Date         Heure  Version      Taille  Nom de fichier   -------------------------------------------------------   03/10/01     13:17  5.1.2600.15  26 624  Ssdpapi.dll  03/10/01     13:17  5.1.2600.15  40 960  Ssdpsrv.dll

Windows 98 ou Windows 98 Deuxième Édition

Un correctif pris en charge est désormais disponible auprès de Microsoft, mais il est destiné uniquement à résoudre le problème décrit dans cet article et ne doit être appliqué qu'aux systèmes reconnus comme étant vulnérables. Vérifiez l'accessibilité physique de votre ordinateur, la connectivité réseau et Internet, ainsi que d'autres facteurs afin de déterminer le niveau de risque auquel est soumis votre ordinateur. Consultez lebulletin de sécurité Microsoft associé pour vous aider à effectuer cette évaluation. Ce correctif pourra être soumis à des tests ultérieurs afin d'assurer la qualité du produit. Si votre ordinateur est réellement exposé, Microsoft vous recommande d'utiliser ce correctif dès à présent.

Pour résoudre ce problème dès à présent, téléchargez ce correctif en suivant les instructions ci-dessous ou procurez-vous le correctif auprès des services de Support technique Microsoft. Pour obtenir une liste complète des services de Support technique Microsoft et leur numéro de téléphone, ainsi que des informations relatives aux frais de support technique, consultez le site Web de Microsoft à l'adresse suivante :

REMARQUE : dans certains cas, les frais généralement encourus en faisant appel au Support technique peuvent être annulés si un technicien du Support technique Microsoft détermine qu'une mise à jour spécifique peut résoudre votre problème. Les tarifs normaux seront appliqués à toute question de support supplémentaire, ainsi qu'aux problèmes qui ne relèvent pas de la mise à jour spécifique en question.

Date de publication : 29 octobre 2001

Pour plus d'informations sur le téléchargement des fichiers du Support technique Microsoft, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
119591 Procédure pour obtenir des fichiers de support technique Microsoft auprès des services en ligne
Microsoft a utilisé les logiciels de détection de virus les plus récents disponibles à la date de publication pour détecter la présence de virus dans ce fichier. Une fois publié, le fichier est conservé sur des serveurs sécurisés, empêchant toute modification non autorisée du fichier.

La version anglaise de ce correctif doit avoir les attributs de fichier suivants ou ceux d'une version ultérieure :
   Date         Heure  Version      Taille  Nom de fichier   ---------------------------------------------------------   28/09/01      04:52  4.90.3002.0   38 672  Ssdpapi.dll  28/09/01      04:53  4.90.3002.0   56 592  Ssdpsrv.dll  28/09/01      04:53  4.90.3002.0  128 272  Upnp.dll

Statut

Windows XP

Microsoft a confirmé que ce problème pouvait entraîner une certaine vulnérabilité de la sécurité dans Microsoft Windows XP.

Windows 98 ou Windows 98 Deuxième Édition

Microsoft a confirmé que ce problème pouvait entraîner une certaine vulnérabilité de la sécurité dans Windows 98 et Windows 98 Deuxième Édition.
Plus d'informations
Pour plus d'informations sur cette vulnérabilité, consultez le site Web de Microsoft à l'adresse suivante :
denial of service vulnerability DoS security_patch
Propriétés

ID d'article : 309073 - Dernière mise à jour : 01/12/2015 18:59:46 - Révision : 2.7

  • Microsoft Windows XP Édition familiale
  • Microsoft Windows XP Professional
  • Microsoft Windows 98 Deuxième Édition
  • Microsoft Windows 98 Standard Edition
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