Vous ne pouvez pas envoyer des pièces jointes volumineuses en utilisant le client EWS

IMPORTANT : Cet article est issu d'une traduction automatique réalisée par un logiciel Microsoft et non par un traducteur professionnel. Cette traduction automatique a pu aussi être révisée par la communauté Microsoft grâce à la technologie Community Translation Framework (CTF). Pour en savoir plus sur cette technologie, veuillez consulter la page http://support.microsoft.com/gp/machine-translation-corrections/fr. Microsoft vous propose en effet des articles traduits par des professionnels, des articles issus de traductions automatiques et des articles issus de traductions automatiques révisées par la communauté Microsoft, de manière à ce que vous ayez accès à tous les articles de notre Base de connaissances dans votre langue. Il est important de noter que les articles issus de la traduction automatique, y compris ceux révisés par la communauté Microsoft, peuvent contenir des erreurs de vocabulaire, de syntaxe ou de grammaire. Microsoft ne pourra être tenu responsable des imprécisions, erreurs, ainsi que de tout dommage résultant d’une traduction incorrecte du contenu ou de son utilisation par les clients.

La version anglaise de cet article est la suivante: 3107326
Symptômes
Considérez le scénario suivant :
  • Un utilisateur se connecte à sa boîte aux lettres à l'aide d'un client Exchange Web Services (EWS).
  • La boîte aux lettres se trouve sur le Site B.
  • Le client s'est connecté à un serveur Microsoft Exchange sur le Site A.
  • Le serveur Exchange sur les serveurs proxy de Site A la demande à un serveur Exchange sur le Site B.

Dans ce scénario, l'utilisateur ne peut pas envoyer un courrier électronique contenant des pièces jointes volumineuses. Lorsque vous utilisez Outlook pour le client Mac, elle déplace le message dans le dossier Brouillons et renvoie l'erreur suivante :

An unknown error has occurred. Connection to the server failed or was dropped. Outlook cannot send the message, because the message size exceed the maximum limit set on the server


Le EWS ouvre une session pour un Site un diaporama un état HTTP 500 avec une erreur générique qui ressemble au suivant :

ReportException_Message=Exchange Web Services are not currently available for this request because none of the Client Access Servers in the destination site could process the request.;ReportException_StackTrace= at Microsoft.Exchange.Services.Wcf.EWSService.GetServiceAsyncResult[TSoapResponseBody](IAsyncResult result) at Microsoft.Exchange.Services.Wcf.EWSService.CreateSoapResponse[TSoapResponse;TSoapResponseBody](IAsyncResult result; Func`2 createSoapResponseCallback) at AsyncInvokeEndEndCreateItem(Object ; Object[] ; IAsyncResult ) at System.ServiceModel.Dispatcher.AsyncMethodInvoker.InvokeEnd(Object instance; Object[]& outputs; IAsyncResult result) at System.ServiceModel.Dispatcher.DispatchOperationRuntime.InvokeEnd(MessageRpc& rpc) at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage7(MessageRpc& rpc) at System.ServiceModel.Dispatcher.MessageRpc.Process(Boolean isOperationContextSet);

Les journaux de EWS pour le Site B indiquent un état HTTP 500 avec une erreur générique qui ressemble au suivant :

ReportException_Message=The remote host closed the connection. The error code is 0x80070057.;ReportException_StackTrace= at System.ServiceModel.Channels.HttpOutput.HostedRequestHttpOutput.HostedResponseOutputStream.CheckWrapThrow(Exception e) at System.ServiceModel.Channels.HttpOutput.HostedRequestHttpOutput.HostedResponseOutputStream.Write(Byte[] buffer; Int32 offset; Int32 count) at System.IO.BufferedStream.FlushWrite() at System.IO.BufferedStream.Flush() at System.Xml.XmlStreamNodeWriter.Flush() at Microsoft.Exchange.Services.Wcf.SoapWcfResponseRenderer.Render(Message message; Stream stream) at Microsoft.Exchange.Services.Wcf.MessageEncoderWithXmlDeclaration.WriteMessage(Message message; Stream stream) at System.ServiceModel.Channels.HttpOutput.WriteStreamedMessage(TimeSpan timeout) at System.ServiceModel.Channels.HttpOutput.Send(TimeSpan timeout) at System.ServiceModel.Channels.HttpRequestContext.OnReply(Message message; TimeSpan timeout) at System.ServiceModel.Channels.RequestContextBase.Reply(Message message; TimeSpan timeout) at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.Reply(MessageRpc& rpc);

Cause
La connexion entre les serveurs Exchange sur les deux sites pour cette demande est droppedbecause d'un paramètre ProxyTimeout.


Résolution
Pour résoudre ce problème, augmentez la valeur de ProxyTimeout sur le serveur CAS en modifiant le fichier web.config pour EWS. Pour ce faire, procédez comme suit :

  1. Recherchez le fichier web.config et puis ouvrez le fichier dans le bloc-notes ou un autre programme d'édition de texte. L'emplacement par défaut est%ExchangeInstallPath%\ClientAccess\exchweb\ews.
  2. Dans le fichier, faites défiler vers le bas pour trouver l'instruction suivante :<AppSettings></AppSettings>
  3. Ajoutez la ligne suivante dans la section <AppSettings>pour augmenter la valeur du délai d'attente :
    </AppSettings>
    <add key="ProxyTimeout" value="120000" />
  4. Redémarrez le pool d'applications MSExchangeServicesAppPool.

Remarque La valeur par défaut de ProxyTimeoutest la valeur de 59000.This doit être augmenté progressivement jusqu'à ce que le problème est résolu. Par exemple, vous démarrez en augmentant le délai d'expiration à 120000. Si le problème persiste, augmentez la valeur de 210000.
Plus d'informations
Pour plus d'informations, reportez-vous à la section. Démarrer ou arrêter un pool d'applications.
EWS, Outlook pour MAC, pièce jointe volumineuse, ProxyTimeout, Cross-Site Proxy

Avertissement : Cet article a été traduit automatiquement.

Propriétés

ID d'article : 3107326 - Dernière mise à jour : 12/11/2015 01:52:00 - Révision : 1.0

Microsoft Exchange Server 2010 Enterprise, Microsoft Exchange Server 2010 Standard, Microsoft Outlook 2016 for Mac, Microsoft Outlook 2011 for Mac

  • kbsurveynew kbmt KB3107326 KbMtfr
Commentaires