Les demandes de connecteur de CMIS échouent si la Collection de sites est non anglais dans SharePoint 2010

IMPORTANT : Cet article est issu d'une traduction automatique réalisée par un logiciel Microsoft et non par un traducteur professionnel. Cette traduction automatique a pu aussi être révisée par la communauté Microsoft grâce à la technologie Community Translation Framework (CTF). Pour en savoir plus sur cette technologie, veuillez consulter la page http://support.microsoft.com/gp/machine-translation-corrections/fr. Microsoft vous propose en effet des articles traduits par des professionnels, des articles issus de traductions automatiques et des articles issus de traductions automatiques révisées par la communauté Microsoft, de manière à ce que vous ayez accès à tous les articles de notre Base de connaissances dans votre langue. Il est important de noter que les articles issus de la traduction automatique, y compris ceux révisés par la communauté Microsoft, peuvent contenir des erreurs de vocabulaire, de syntaxe ou de grammaire. Microsoft ne pourra être tenu responsable des imprécisions, erreurs, ainsi que de tout dommage résultant d’une traduction incorrecte du contenu ou de son utilisation par les clients.

La version anglaise de cet article est la suivante: 3128130
Symptômes
Considérez le scénario suivant :

  • Vous créez une collection de sites Microsoft SharePoint 2010 dans une langue autre que l'anglais (espagnol, par exemple).
  • Vous déployez le connecteur des Services de l'interopérabilité Content Management (CMIS).
  • Vous ajoutez un document à la bibliothèque de documents partagés du nouveau site.
  • À partir d'une autre session de navigateur, vous exécutez une requête CMIS semblable à la suivante :

    http://server/sites/spanishSC/_vti_bin/cmis/rest/sharedocumentsguidid&getChildren&folderID=-1&includeAllowableActions=true&includeRelationships=none&includePathSegment=true&maxItems=2147483647&skipCount=0
Dans ce scénario, le message d'erreur suivant s'affiche :

Demande incorrecte dans HTTP/1.1 400
Un ou plusieurs paramètres d'entrée pour la méthode de service sont manquant ou non valide.
Toutefois, lorsque vous créez une collection de sites en anglais, les mêmes CMIS la demande s'exécute avec succès.
Cause
Il s'agit d'un problème connu qui affecte le connecteur de CMIS et de SharePoint 2010.
Résolution
Pour résoudre ce problème, déployez le connecteur CMIS dans une collection de sites SharePoint 2010 est configurée en anglais.

Avertissement : Cet article a été traduit automatiquement.

Propriétés

ID d'article : 3128130 - Dernière mise à jour : 01/25/2016 03:18:00 - Révision : 1.0

Microsoft SharePoint Server 2010

  • kbsurveynew kbtshoot kbexpertiseinter kbmt KB3128130 KbMtfr
Commentaires