Pour définir un serveur proxy de l'Agent de Service de récupération de Microsoft Azure défectueux

IMPORTANT : Cet article est issu d'une traduction automatique réalisée par un logiciel Microsoft et non par un traducteur professionnel. Cette traduction automatique a pu aussi être révisée par la communauté Microsoft grâce à la technologie Community Translation Framework (CTF). Pour en savoir plus sur cette technologie, veuillez consulter la page http://support.microsoft.com/gp/machine-translation-corrections/fr. Microsoft vous propose en effet des articles traduits par des professionnels, des articles issus de traductions automatiques et des articles issus de traductions automatiques révisées par la communauté Microsoft, de manière à ce que vous ayez accès à tous les articles de notre Base de connaissances dans votre langue. Il est important de noter que les articles issus de la traduction automatique, y compris ceux révisés par la communauté Microsoft, peuvent contenir des erreurs de vocabulaire, de syntaxe ou de grammaire. Microsoft ne pourra être tenu responsable des imprécisions, erreurs, ainsi que de tout dommage résultant d’une traduction incorrecte du contenu ou de son utilisation par les clients.

La version anglaise de cet article est la suivante: 3132419
Symptômes
Lorsque vous essayez de définir un proxy à l'aide de la commande Inscrire le serveur dans le composant logiciel enfichable sauvegarde de Microsoft Azure, le serveur n'est pas enregistré, et vous recevez le message d'erreur suivant :

Impossible de réactiver les paramètres existants de la sauvegarde planifiées. Le serveur doit être inscrit avec Microsoft Azure Backup avant de pouvoir effectuer cette opération.

Ou bien, le message d'erreur suivant s'affiche lorsque vous définissez un proxy à l'aide de la commande Modifier les propriétés dans le composant logiciel enfichable Microsoft Azure Backup :

Agent des Services de récupération Microsoft Azure n'a pas pu se connecter au serveur proxy. (ID: 280011)
Veuillez vérifier les paramètres du serveur et vérifiez que l'adresse du serveur proxy est correct.
Cause
Ce problème se produit si le paramètre de proxy est manquant dans le fichier CBSettings.xml.
Contournement
Pour contourner ce problème, ajoutez le paramètre de proxy pour CBSettings.xml, puis redémarrez Microsoft Azure récupération Service Agent.

CBSettings.xml est stocké dans le dossier de travail que vous avez spécifié en tant que « Emplacement » lors de l'installation de l'Agent de Service de récupération de Microsoft Azure. Par défaut, le dossier de travail se trouve dans le chemin suivant :

C:\Program Files\Microsoft récupération Azure Services Agent\Scratch
Le chemin d'accès du dossier de travail en cours est stockée dans la sous-clé de Registre suivante :

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Azure Backup\Config\ScratchLocation


Pour définir un serveur proxy, procédez comme suit :

  1. Copier le fichier CBSettings.xml vers un dossier de sauvegarde.
  2. Fermez le composant logiciel enfichable Microsoft Azure Backup si elle est en cours d'exécution.
  3. Ouvrez CBSettings.xml.
  4. Mise à jour de la ligne de <ProxySetting>et puis enregistrez le fichier. Si <ProxySetting>est manquante dans la CBSettings.xml, l'ajouter. Si <ProxySetting>existe déjà, remplacez-le. Par exemple, entrez la ligne suivante dans le contenu de la CBSettings.xml :</ProxySetting> </ProxySetting> </ProxySetting>

    <ProxySetting><Enabled>true</Enabled> <ProxyServer>http://10.10.10.10</ProxyServer> <ProxyPort>80</ProxyPort></ProxySetting>
  5. Ouvrez la console de gestion des Services (Services.msc).
  6. Cliquez sur le service « Agent de Services Microsoft Azure récupération », puis cliquez sur redémarrer.
  7. Démarrer le composant logiciel enfichable Microsoft Azure sauvegarde et vérifiez que le paramètre de proxy est correctement défini à l'aide de laModifier les propriétés commande.
Statut
Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Avertissement : Cet article a été traduit automatiquement.

Propriétés

ID d'article : 3132419 - Dernière mise à jour : 02/09/2016 00:55:00 - Révision : 1.0

Microsoft Azure Recovery Services

  • kbexpertiseadvanced kbsurveynew kbtshoot kbmt KB3132419 KbMtfr
Commentaires