ID d’événement 31128 lorsque RGS ne peut synchroniser l’adresse SIP d’un membre de groupe de l’Agent Microsoft Lync Server 2013

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La version anglaise de cet article est la suivante: 3148256
Symptômes
Supposons qu’un membre d’une liste de distribution est également membre d’un groupe d’agents Response Group service (RGS) dans un environnement Microsoft Lync Server 2013. Lorsque l’adresse du membre SIP est modifiée, toutes les modifications connexes sont bloquées à partir de la synchronisation entre Active Directory et la base de données RGS. En outre, l’ID d’événement 31128 est enregistré comme suit :

Nom du journal : Lync Server
Source: LS Service Response Group
Date : Date/heure
L’ID d’événement : 31128
Catégorie de la tâche: (2001)
Niveau : erreur
Mots clés : classique
Utilisateur : Nom d’utilisateur
Ordinateur : Nom_Ordinateur
Description :
Échec de la synchronisation des données à partir d’Active Directory.

L’exception suivante a été levée pendant le processus de synchronisation :
Exceptions : System.Data.SqlClient.SqlException - Impossible d’insérer une ligne de clé en double dans l’objet ' dbo. Agents' avec un index unique ' IXAgentsUserSid'. La valeur de clé en double est (0x0105000000000005150000009e7c5c00db5d97c850f8f9d046220000).
L’instruction a été interrompue.
Exception interne: ~
La prochaine tentative de synchronisation est de 480 minutes.
Cause : Une exception inconnue.
Résolution :
Vérifiez la connectivité avec le contrôleur de domaine, ou si le schéma a été appliquée correctement Active Directory et tous les attributs de l’utilisateur sont présents.


En outre, les utilisateurs qui ont été récemment ajoutés au groupe d’agent RGS rencontrer les problèmes suivants :
  • Nouveaux utilisateurs ne reçoivent une notification « Vous avez été ajouté en tant qu’agent ».
  • Les appels qui sont apportées au workflow RGS ne sont pas acheminés vers l’agent RGS nouvellement ajouté.
Cause
Ce problème se produit car la modification de l’adresse SIP empêche RGS à partir de la référence à l’agent. Toutefois, le RGS a base de données agents d’index à l’aide de leur adresse SIP.
Résolution
Pour corriger ce problème, appliquez laMise à jour cumulative avril 2016 5.0.8308.956 pour Lync Server 2013, Service Response Group.

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Propriétés

ID d'article : 3148256 - Dernière mise à jour : 05/20/2016 08:07:00 - Révision : 3.0

Microsoft Lync Server 2013

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