L’ordinateur ne démarre pas après avoir modifié la partition active à l’aide de l’outil Gestion des disques

Cet article fournit une solution à un problème où l’ordinateur ne démarre pas une fois que vous avez marqué votre partition principale comme étant active.

S’applique à : Windows Server 2012 R2
Numéro de la base de connaissances d’origine : 315261

Symptômes

Après avoir utilisé l’outil enfichable Gestion des disques Windows pour marquer votre partition principale comme étant active, l’ordinateur risque de ne pas démarrer et le message d’erreur suivant peut s’afficher :

NTLDR est manquant.

Appuyez sur Ctrl+Alt+Suppr pour redémarrer.

Cause

Ce comportement se produit si la partition marquée comme active ne contient pas les fichiers de démarrage Windows ou les fichiers de démarrage d’un autre système d’exploitation. Sur les ordinateurs Intel, la partition système doit être une partition principale qui a été marquée comme active à des fins de démarrage. Cette partition doit se trouver sur le disque auquel l’ordinateur accède au démarrage. Il ne peut y avoir qu’une seule partition système active à la fois. Si vous souhaitez utiliser un autre système d’exploitation, vous devez d’abord marquer sa partition système comme étant active avant de redémarrer l’ordinateur.

Résolution

Importante

Avant d’effectuer les étapes répertoriées ci-dessous, vérifiez que vous disposez d’une bonne sauvegarde de vos fichiers de données critiques.

Pour résoudre ce comportement, utilisez l’une des procédures suivantes :

  • Essayez de modifier la partition active en démarrant sur une disquette, puis en utilisant des utilitaires de disque pour modifier manuellement la partition active :

    1. Démarrez à une invite de commandes à l’aide d’une disquette de démarrage Microsoft Windows 95, Microsoft Windows 98 ou Microsoft Windows Millennium Edition (Me).
    2. À l’invite de commandes, tapez fdisk, puis appuyez sur Entrée.
    3. Lorsque vous êtes invité à activer la prise en charge des disques volumineux, cliquez sur Oui.
    4. Cliquez sur Définir la partition active, appuyez sur le numéro de la partition que vous souhaitez rendre active, puis appuyez sur Entrée.
    5. Appuyez sur Échap.
    6. Retirez la disquette de démarrage, puis redémarrez l’ordinateur.
  • Démarrez l’ordinateur à l’aide d’un disque de démarrage Windows XP. Pour plus d’informations, consultez Créer un disque de réparation système.

  • Si la partition qui a été incorrectement marquée comme active est mise en forme dans le système de fichiers FAT, le système de fichiers FAT32 ou le système de fichiers NTFS, vous pouvez peut-être utiliser la console de récupération Windows pour corriger le comportement.

Pour plus d’informations, consultez Quelles sont les options de récupération système dans Windows ?.

Remarque

La partition système fait référence au volume de disque qui contient les fichiers nécessaires au démarrage de Windows (par exemple, Ntldr, Boot.ini et Ntdetect.com). Sur les ordinateurs Intel x86, la partition système doit être une partition principale marquée active. Sur les ordinateurs Intel x86, il s’agit toujours du lecteur 0, le lecteur que le BIOS du système recherche au démarrage du système d’exploitation.

À l’aide de la console de récupération, copiez le fichier Ntldr du CD-ROM Windows XP dans le répertoire racine de la partition active actuelle. Procédez comme suit :

  1. Démarrez votre ordinateur à l’aide des disquettes d’installation de Windows XP ou du CD-ROM Windows XP.

  2. Dans l’écran Bienvenue dans l’installation , appuyez sur F10 ou sur R pour réparer.

  3. Appuyez sur C pour démarrer la console de récupération.

  4. Copiez le fichier Ntldr à partir du CD-ROM Windows XP à la racine de votre partition système en utilisant les commandes suivantes, en appuyant sur Entrée après chaque commande :

  5. Tapez cd .. pour accéder à la racine du lecteur C.

    Il y a un espace entre le d et les deux points (..).

  6. Tapez la lettre du lecteur de CD-ROM.

  7. Tapez cd i386.

  8. Tapez Copy ntldr c:.

  9. Tapez Copy ntdetect.com c:.

  10. Tapez Bootcfg /add.

  11. Tapez Exit.

Si la partition n’a pas été mise en forme à l’aide de Windows, vous devrez peut-être également exécuter la commande fixboot de la console de récupération pour que la partition active puisse démarrer.

Une fois que vous pouvez démarrer dans Windows, il est recommandé d’utiliser l’outil enfichable Gestion des disques Windows pour réinitialiser la partition système d’origine en tant que partition active, puis redémarrer l’ordinateur.