Comment utiliser la ligne de commande commutateur /convert à convertir base de données que dans le format de fichier Access 2000

IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d’articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d’avoir accès, dans votre propre langue, à l’ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s’exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s’efforce aussi continuellement de faire évoluer son système de traduction automatique.

319253
Cet article a été archivé. Il est proposé « en l'état » et ne sera plus mis à jour.
Modéré : nécessite macro base, codage et compétences de l'interopérabilité.

Cet article s'applique uniquement à une base de données Microsoft Access (.mdb).

Symptômes
La rubrique d'aide Microsoft Access 2002 « options de ligne de commande de démarrage » indique incorrectement suivantes :

Convertit une base de données Access précédente version ou de projet Access au format de fichier par défaut, renomme le nouveau fichier et puis ferme Access. Vous devez spécifier la base de données source avant d'utiliser l'option /Convert . Pour afficher le format de fichier par défaut, cliquez sur Options dans le menu Outils , puis cliquez sur l'onglet Avancé .
Cause
Le commutateur /convert ne peut pas détecter la propriété DefaultDatabaseFormat . Dans Access 2002, le commutateur pouvez convertir la base de données uniquement en format de fichier Access 2000.
Résolution
Si vous souhaitez convertir une version précédente d'une base de données Access au format Access 2002, utilisez une des méthodes suivantes.

Utilisant les menus Access prédéfinis

Dans le menu Outils , pointez sur Utilitaires de base de données , pointez sur Convertir une base de données et puis cliquez sur pour le format de fichier Access 2002 .

Utilisation de la méthode ConvertAccessProject

Le code suivant convertit une version précédente d'une base de données Access au format de fichier Access 2002 :
  1. Créer un module et tapez la ligne suivante dans la section Déclarations si elle n'est pas déjà visible :
    Option Explicit						
  2. Tapez la procédure suivante :
    Function ConvDB2002(SourceDb As String, DestDb As String)   Application.ConvertAccessProject SourceDb, DestDb, acFileFormatAccess2002End Function						
  3. Pour tester cette fonction, tapez la ligne suivante dans la fenêtre Exécution. Veillez à remplacez le chemin d'accès et fichier le nom correct de votre base de données. Ensuite, appuyez sur ENTRÉE :
    ?ConvDB2002("c:\data\MyAcc97.mdb", "c:\data\MyAcc2002.mdb")						
Pour plus d'informations sur la méthode ConvertAccessProject, dans Visual Basic Editor, cliquez sur l'aide de Microsoft Visual Basic dans le menu Aide , tapez méthode ConvertAccessProject dans le Compagnon Office ou l'aide intuitive et puis cliquez sur Rechercher pour afficher la rubrique.

Pour plus d'informations sur la façon de convertir plusieurs bases de données Access, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
304318 ACC2002 : Comment faire pour convertir par programme plusieurs bases de données Access
Statut
Microsoft a confirmé que c'est un problème dans les produits Microsoft répertoriés au début de cet article.
Plus d'informations
Pour définir la propriété DefaultDatabaseFormat , cliquez sur Options dans le menu Outils , puis cliquez sur l'onglet Avancé .
Références
Pour plus d'informations sur les commutateurs de ligne de commande, cliquez sur l'aide de Microsoft Access dans le menu Aide , tapez options de ligne de commande de démarrage dans le Compagnon Office ou l'aide intuitive et puis cliquez sur Rechercher pour afficher la rubrique.
Erreur de documentation erreur en ligne acc2002 pra docerr doc.

Avertissement : Cet article a été traduit de manière automatique

Propriétés

ID d'article : 319253 - Dernière mise à jour : 02/06/2014 09:19:27 - Révision : 4.1

  • Microsoft Access 2002
  • kbnosurvey kbarchive kbmt kbhowto kbdocerr kbdta kbnofix KB319253 KbMtfr
Commentaires