Les liens externes peuvent être calculées lorsque vous ouvrez un classeur qui a été dernier enregistré dans une version antérieure d'Excel

Le support d'Office 2003 a pris fin

Microsoft a mis fin au support d'Office 2003 le 8 avril 2014. Cette modification a affecté vos mises à jour logicielles et options de sécurité. Découvrez les implications de ce changement à votre niveau et la marche à suivre pour rester protégé.

IMPORTANT : Cet article est issu d'une traduction automatique réalisée par un logiciel Microsoft et non par un traducteur professionnel. Cette traduction automatique a pu aussi être révisée par la communauté Microsoft grâce à la technologie Community Translation Framework (CTF). Pour en savoir plus sur cette technologie, veuillez consulter la page http://support.microsoft.com/gp/machine-translation-corrections/fr. Microsoft vous propose en effet des articles traduits par des professionnels, des articles issus de traductions automatiques et des articles issus de traductions automatiques révisées par la communauté Microsoft, de manière à ce que vous ayez accès à tous les articles de notre Base de connaissances dans votre langue. Il est important de noter que les articles issus de la traduction automatique, y compris ceux révisés par la communauté Microsoft, peuvent contenir des erreurs de vocabulaire, de syntaxe ou de grammaire. Microsoft ne pourra être tenu responsable des imprécisions, erreurs, ainsi que de tout dommage résultant d’une traduction incorrecte du contenu ou de son utilisation par les clients.

La version anglaise de cet article est la suivante: 327006
Pour Microsoft Office Excel 2007, Microsoft Excel 2010 ou version de Microsoft Excel 2013 de cet article, reportez-vous à la section. 925893.
Symptômes
Lorsque vous ouvrez un classeur qui contient des liens externes dans Microsoft Excel 2000 ou une version ultérieure, vous êtes invité à mettre à jour les liens. Si vous choisissez de ne pas mettre à jour les liens, vous pouvez rencontrer un ou plusieurs des problèmes suivants :
  • Les liens dans le classeur sont calculées par rapport à la table de liaisons externes dans le classeur et peuvent être différentes de ce qui a été calculé précédemment.
  • Les formules qui incluent ou reportez-vous aux liens externes vers d'autres classeurs qui n'ont pas les valeurs stockées dans la table de liaison externe peuvent afficher la valeur d'une des erreurs suivantes :
    • #REF !
    • #Value !
    • #NAME !
Cause
Ce scénario se produit si le dernier enregistrement du classeur que vous ouvrez dans une version d'Excel antérieure à la version que vous utilisez pour ouvrir le classeur. Ce scénario se produit car Excel impose un recalcul complet de tous les classeurs ouverts qui ont été précédemment enregistrées dans une version antérieure d'Excel, indépendamment de l'état de mise à jour du lien. Pour recalculer entièrement un classeur, Excel Obtient la valeur actuellement stockée de toutes les références externes à partir de la table de liaison externe de classeurs. Ce problème se produit même si vous décidez de ne pas mettre à jour ces liens lorsque vous y êtes invité. Excel met à jour la chaîne de calcul du classeur vers la version actuelle d'Excel. Si les valeurs des sources de liaison externe ne sont pas disponibles dans la table de liaisons externes dans le classeur, Excel ne peut pas calculer correctement. Par conséquent, Excel renvoie #REF! erreurs. Cela est également vrai pour les liaisons DDE ne sont pas disponibles pendant le processus de recalcul. Par défaut, Microsoft Excel enregistre une table cachée des valeurs de lien à des fins de calcul. Dans certains cas les valeurs des liaisons externes pas peuvent être identique à ce que le dernier calcul dans les formules. Il est également possible de désactiver la fonctionnalité pour stocker les valeurs des liaisons externes sur une base individuelle de classeur dans les options Excel.

Pour plus d'informations sur un problème connexe avec des tables de lien externe, consultez
312188 plusieurs classeurs avec des liens vers la même source de mettre à jour les uns des autres
Contournement
Pour contourner ce problème, appliquez l'une des méthodes suivantes.

Assurez-vous que les sources de liaison externe sont disponibles avant d'ouvrir le fichier

Si vous ouvrez le fichier et disposez erreurs dans les formules de lien externe, mais vous n'avez pas encore enregistré le fichier, procédez comme suit :
  1. Fermez le classeur sans l'enregistrer pour conserver le classeur inchangé.
  2. Pour chaque source différentes liaisons externes dans le fichier que vous souhaitez ouvrir, vérifiez que le fichier source est disponible à l'emplacement spécifié dans la formule de liaison. Si toutes les sources de liaison ne sont plus disponibles, vous devez modifier la formule de liaison pour pointer vers une autre source ou supprimer la formule de liaison définitivement pour rompre la liaison. Suivez les étapes décrites dans la section suivante pour modifier ou supprimer des liens.
  3. Après avoir confirmé que toutes les sources de liaison sont disponibles à leurs emplacements définis, ouvrez le fichier lié dans Excel et Excel vous permettent de mettre à jour les liens externes dans le fichier lorsqu'il est invité à.
  4. Lorsque vous ouvrez le fichier lié et confirmé que tous les liens externes ont été mis à jour et que le classeur a été recalculé correctement dans la version actuelle d'Excel, enregistrez le fichier. Le fichier doit maintenant ouvrir et mettre à jour les liens comme prévu dans la version actuelle d'Excel.

Mettre à jour ou supprimer des liens

Si vous avez déjà enregistré le fichier avec des erreurs dans les formules de lien externe, ou si les fichiers de source de liaison ne sont plus disponibles, vous devez localiser les sources liées d 'origine et autres sources, puis restaurer les liens vers ces sources. Pour consulter les sources de liaison externe et pour restaurer ou supprimer des liens rompus, procédez comme suit :
  1. Pour empêcher temporairement le recalcul des fichiers enregistrés dans une version antérieure d'Excel afin de pouvoir mettre à jour ou supprimer des liens externes, définissez l'environnement de calcul manuel. Pour définir temporairement le mode de calcul manuel, procédez comme suit :
    1. Fermez tous les classeurs ouverts.
    2. Créez un nouveau classeur.
    3. Dans le menu Outils , cliquez surOptions.
    4. Cliquez sur l'onglet calcul , puis cliquez surmanuel.
    5. Désactivez la case à cocher Recalcul avant l'enregistrement, puis cliquez sur OK.
    6. Ouvrez votre classeur enregistré.
  2. Dans le menu Edition , cliquez surliens.
  3. Cliquez sur Vérifier l'état de mise à jour de la statusfor de tous les liens dans la liste. Attendez que l'état de tous les liens vers beupdated.
  4. Examiner l'état dans la colonne état et cliquez sur le lien, puis effectuez l'une des actions suivantes :
    • OK. Aucune action n'est requise. La liaison fonctionne et est en cours.
    • Inconnu. Cliquez sur Vérifier l'état pour mettre à jour de l'état de toutes les liaisons dans la liste.
    • Ne s'applique pas. La liaison utilise OLE ou protection continue des données (DDE, Dynamic Data Exchange). Microsoft Excel ne peut pas vérifier l'état de ces types de liens.
    • Erreur : Source introuvable. Cliquez sur Modifier la Sourceet sélectionnez le classeur approprié pour le lien.
    • Erreur : feuille introuvable. Cliquez sur Modifier la Sourceet sélectionnez la feuille de calcul appropriée dans le fichier approprié. La source peut avoir été déplacée ou renommée.
    • Avertissement : valeurs non mises à jour. Cliquez sur mettre à jour les valeurs. Le lien n'a pas été mis à jour lorsque le classeur a été ouvert.
    • Avertissement : Source non recalculée. Cliquez sur Ouvrir la Sourceet appuyez sur F9 pour recalculer le classeur. Le classeur peut être défini sur calcul manuel. Pour définir le calcul automatique, cliquez sur Options dans le menu Outils , puis cliquez sur automatique sous l'onglet calcul .
    • Erreur : nom non défini ou non rectangulaire. Certains noms ne peuvent pas être résolus jusqu'à ce que vous ouvrez le classeur source. Cliquez sur Ouvrir la Source, revenez au classeur de destination, puis cliquez sur Vérifier l'état. Si cela ne résout pas le problème, vérifiez que le nom n'est pas mal orthographié ou manquant. Passez au classeur source, pointez sur nom dans le menu Insertion , cliquez sur définiret puis recherchez le nom.
    • Avertissement : ouvrir la source de mise à jour des valeurs. Cliquez sur Ouvrir la Source. Le lien ne peut pas être mis à jour que lorsque vous ouvrez la source.
    • La source est ouverte. La source est ouverte. Aucune action n'est nécessaire sauf si vous recevez des erreurs de la feuille de calcul.
    • Valeurs mises à jour à partir du nom de fichier. Aucune action n'est requise. Les valeurs ont été mis à jour.
    • Erreur : état indéterminé. Excel ne peut pas déterminer l'état de la liaison. La source ne peut contenir aucune des feuilles de calcul, ou peut-être être enregistrée dans un format de fichier non pris en charge. Cliquez sur mettre à jour les valeurs.
  5. Après avoir résolu que tous les lier les références, rétablir calcul automatique afin que Microsoft Excel peut recalculer entièrement le classeur dans la nouvelle version. Pour ce faire, procédez comme suit :
    1. Dans le menu Outils , cliquez surOptions.
    2. Cliquez sur l'onglet calcul , puis cliquez surautomatique.
    3. Cliquez sur OK.
    Excel doit calculer le fichier à ce stade. Si le calcul est réussi, enregistrez le fichier. Le fichier doit maintenant ouvrir et mettre à jour les liens comme prévu dans la version actuelle d'Excel.
Pour plus d'informations sur la détermination de l'environnement de calcul, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
214395 Description de la façon dont Excel détermine le mode en cours de calcul

Définitivement supprimer la formule de liaison et le remplacer par la valeur

Si vous n'avez pas besoin des formules qui font référence à des liens externes, copiez ces formules et puis coller les valeurs uniquement dans les cellules cibles.

Remarque Lorsque vous remplacez une formule par sa valeur, Excel supprime définitivement la formule.

Pour copier des formules et coller les valeurs, procédez comme suit :
  1. Ouvrez le classeur dans la version de Excel dans lequel il a été enregistré en dernier. Lorsque vous êtes invité à mettre à jour les liaisons, cliquez sur non. Étant donné que le dernier enregistrement du fichier dans cette version, des liens ne sont pas obligés de mettre à jour et calcul peut se produire avec la dernière valeur connue de la liaison.
  2. Avec le bouton droit de la cellule ou la plage de cellules qui contient la formule que refersto un lien externe, puis cliquez sur Copier.
  3. Avec le bouton droit de la même cellule, puis cliquez sur la méthode PasteSpecial.
  4. Sous Coller dans la boîte de dialogue PasteSpecial , cliquez sur valeurs, puis cliquez surOK.
Après avoir supprimé tous les liens indésirables de cette manière, enregistrez le fichier. Vous pouvez ensuite ouvrir le fichier dans la nouvelle version d'Excel sans mettre à jour ces liens, car ils n'existent plus.
Statut
Ce comportement est voulu par la conception.
PRB XL2000 XL2002 XL2003 XL2007 XL2010 mettre à jour les liens XL kbhowto est la liaison de message d'erreur

Avertissement : Cet article a été traduit automatiquement.

Propriétés

ID d'article : 327006 - Dernière mise à jour : 08/16/2015 22:39:00 - Révision : 8.0

Microsoft Excel 2000 Standard, Microsoft Excel 2002, Microsoft Office Excel 2003

  • kbopenfile kbxlslink kberrmsg kbprb kbmt KB327006 KbMtfr
Commentaires