Vous êtes actuellement hors ligne, en attente de reconnexion à Internet.

Impossible d'utiliser les programmes DirectPlay sur Internet après l'installation de Windows XP Service Pack 1

Le support de Windows XP a pris fin

Microsoft a mis fin au support de Windows XP le 8 avril 2014. Cette modification a affecté vos mises à jour logicielles et options de sécurité. Découvrez les implications de ce changement à votre niveau et la marche à suivre pour rester protégé.

Ancien nº de publication de cet article : F327299
Symptômes
Après la mise à niveau d'un ordinateur Windows XP qui utilise le Partage de connexion Internet vers le Service Pack 1 (SP1), les programmes qui utilisent DirectPlay (par exemple Age of Empires ou Midtown Madness 2) peuvent ne pas fonctionner correctement sur l'hôte de Partage de connexion Internet ou l'ordinateur client. Si vous utilisez un ordinateur externe sur Internet, vous pouvez également rencontrer des problèmes liés à l'interaction entre ces programmes et l'hôte de Partage de connexion Internet ou l'ordinateur client Windows XP.

Par exemple, vous pouvez rencontrer l'un des problèmes suivants :
  • Vous ne pouvez pas héberger un jeu Internet qui utilise DirectPlay (par exemple Age of Empires ou Midtown Madness 2) à partir d'un ordinateur client de Partage de connexion Internet.
  • Vous ne pouvez pas rejoindre un jeu Internet qui utilise DirectPlay à partir d'un ordinateur hôte Windows XP SP1 qui exécute le Partage de connexion Internet ou à partir d'un ordinateur client de Partage de connexion Internet.
  • Vous ne pouvez pas rejoindre un jeu Internet qui utilise DirectPlay à partir d'un ordinateur externe sur Internet.
Cause
Ce problème peut se produire lorsque l'une des conditions suivantes est remplie :
  • La fonctionnalité Pare-feu de connexion Internet n'est pas activée dans les propriétés de la carte réseau partagée sur l'ordinateur Windows XP hôte du Partage de connexion Internet.
  • Le paramètre Autoriser d'autres utilisateurs du réseau à contrôler ou désactiver la connexion Internet partagée n'a pas été sélectionné sur l'ordinateur Windows XP hôte du Partage de connexion Internet.
  • L'ordinateur client n'exécute pas Windows XP SP1 ou Microsoft DirectX 9.0.
Résolution
Pour résoudre ce problème, procédez comme suit :
  1. Activez le Partage de connexion Internet pour la carte réseau partagée sur l'ordinateur qui héberge la connexion Internet partagée. Pour plus d'informations sur la façon d'activer le Partage de connexion Internet, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
    283673 Comment faire pour activer ou désactiver le pare-feu dans Windows XP
    Si vous essayez d'héberger un jeu sur un ordinateur Windows XP client de Partage de connexion Internet, vous pouvez être également en mesure de contourner ce problème en hébergeant le jeu sur l'ordinateur hôte du Partage de connexion Internet ou sur l'ordinateur du joueur externe.
  2. Sélectionnez le paramètre Autoriser d'autres utilisateurs du réseau à contrôler ou désactiver la connexion Internet partagée sur l'ordinateur hôte du Partage de connexion Internet. Pour cela, procédez comme suit :
    1. Cliquez sur Démarrer, sur Panneau de configuration, puis double-cliquez sur Connexions réseau.
    2. Cliquez avec le bouton droit sur la carte réseau partagée, puis cliquez sur Propriétés.
    3. Sous l'onglet Avancé, activez la case à cocher Autoriser d'autres utilisateurs du réseau à contrôler ou désactiver la connexion Internet partagée sous Partage de connexion Internet.
  3. Mettez à niveau tous les ordinateurs clients vers DirectX 9.0 ou Windows XP SP1. Pour télécharger le fichier exécutable d'utilisateur final de DirectX, reportez-vous au site Web de Microsoft à l'adresse suivante : Pour plus d'informations sur la façon d'obtenir le dernier Windows XP Service Pack, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
    322389 Comment faire pour obtenir le dernier Service Pack Windows XP
Statut
Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés au début de cet article.
Propriétés

ID d'article : 327299 - Dernière mise à jour : 05/09/2006 10:34:00 - Révision : 4.1

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Édition familiale
  • kbprb KB327299
Commentaires