Vous êtes actuellement hors ligne, en attente de reconnexion à Internet.

XL: Dénombrer les cellules contenant une valeur (ou texte)

Ancien nº de publication de cet article : F00762
Exclusion de responsabilité concernant les contenus obsolètes dans la Base de connaissances
Cet article concerne des produits pour lesquels Microsoft n'offre plus de support. Il est par conséquent fourni « en l'état » et ne sera plus mis à jour.
Symptômes

Je souhaite connaître le nombre de fois qu'une valeur d'une cellule apparaît
dans une plage de cellules. Comment dois-je procéder ?


Résolution

Depuis la version 5.0 de Microsoft Excel, il vous suffit d'utiliser la formule
NB.SI(), comme suit :

=NB.SI(zone;valeur)

Avec la version 4.0 de Microsoft Excel, il vous suffit d'utiliser la formule
SOMME() en technique matricielle (appuyer simultanément sur les 3 touches
CTRL+MAJ+ENTREE), comme suit :

=SOMME(1*(zone=valeur))

où :
- "zone" est la référence ou le nom d'une plage de cellules
- "valeur" est la valeur à dénombrer (nombre ou texte)


EXEMPLE :

Si vous souhaitez connaitre le nombre d'occurrences de la valeur 12 dans la
plage A1:C10, il suffit d'écrire la formule suivant la version de Microsoft
Excel :

=NB.SI(A1:C10;12)

ou

=SOMME(1*(A1:C10=12))


MOTS-CLES :

La liste de(s) mot(s) suivant(s) permet une recherche plus efficace de cette
fiche technique :

identique
Propriétés

ID d'article : 450762 - Dernière mise à jour : 08/23/2005 19:08:33 - Révision : 1.3

Microsoft Excel 4.0 pour Macintosh, Microsoft Excel 5.0 pour Macintosh, Microsoft Excel 5.0a pour Macintosh, Microsoft Excel 95 Standard, Microsoft Excel 5.0 Standard, Microsoft Excel 4.0 Standard, Microsoft Excel 5.0 Standard, Microsoft Excel 5.0c

  • kbhowto KB450762
Commentaires
/html>();