Vous êtes actuellement hors ligne, en attente de reconnexion à Internet.

COMMENT FAIRE : Modifier par programme l’affichage par défaut d’un formulaire Microsoft Office InfoPath 2003

Le support d'Office 2003 a pris fin

Microsoft a mis fin au support d'Office 2003 le 8 avril 2014. Cette modification a affecté vos mises à jour logicielles et options de sécurité. Découvrez les implications de ce changement à votre niveau et la marche à suivre pour rester protégé.

Cet article peut contenir des liens vers des informations en langue anglaise (pas encore traduites).
Résumé
Les formulaires Microsoft Office InfoPath prennent en charge plusieurs vues. Une vue est l'affichage par défaut. Lorsque vous ouvrez un formulaire dans InfoPath, vous l’ouvrez en affichage par défaut. Cet article explique comment modifier par programme l'affichage par défaut d'un formulaire InfoPath.

retour au début

Création d’un nouveau formulaire

  1. Démarrez InfoPath 2003.
  2. Dans le menu Fichier, cliquez sur Créer un formulaire.
  3. Dans le volet Créer un formulaire, cliquez sur Nouveau formulaire vierge.
retour au début

Création de la vue 1

  1. Dans le formulaire vierge, tapez C'est la vue 1 sur la première ligne, puis Cocher pour afficher la vue 2 lorsque le formulaire est ouvert sur la deuxième ligne.
  2. Dans le menu déroulant Volet Office, cliquez sur Contrôles.
  3. Dans le volet Contrôles, cliquez sur Case à cocher.
  4. Modifiez le texte Champ 1 en Vue 2.
retour au début

Création de la vue 2

  1. Dans le menu déroulant Volet Office, cliquez sur Vues.

    Vue 1 est l'affichage par défaut du formulaire.
  2. Dans la section Opérations du volet Office, cliquez sur Ajouter une nouvelle vue.
  3. Tapez Vue 2, puis cliquez sur OK.
  4. Dans le formulaire vierge, tapez C'est la vue 2.
retour au début

Ajout du script

  1. Dans le menu Outils, pointez sur Script, puis cliquez sur Microsoft Script Editor.
  2. Ajoutez le code suivant à la fenêtre Code :
    function XDocument::OnLoad(eventObj){	//Pick the default view based on the value of element DefaultView	var objDefaultView = XDocument.DOM.selectSingleNode("//my:champ1");	if ((objDefaultView != null) && (objDefaultView.text != ""))   	{		switch (objDefaultView.text)      		{         		case "false":				    XDocument.ViewInfos("Vue 1").IsDefault = true;            			break;         		case "true":            			XDocument.ViewInfos("Vue 2").IsDefault = true;            			break;      		}   	}}
  3. Enregistrez le script, puis fermez Microsoft Script Editor.
  4. Enregistrez votre modèle de formulaire en SwitchDefaultView.xsn, puis fermez-le.
retour au début

À essayer

  1. Dans le menu Fichier, cliquez sur Remplir un formulaire.

    Remarque Assurez-vous de remplir le formulaire à cette étape au lieu d’en faire un aperçu. L’aperçu ne reflète pas toutes les modifications par programme de l'affichage par défaut dans l'événement OnLoad. Le mode Aperçu affiche toujours la vue qui est actuellement sélectionnée dans InfoPath Designer.
  2. Dans le volet Office, cliquez sur SwitchDefaultView.

    Le formulaire s’ouvre dans la vue 1 (la vue initiale par défaut).
  3. Cliquez sur la case à cocher Vue 2.
  4. Enregistrez le formulaire en SwitchDefaultViewForm.xml, puis fermez-le.
  5. Dans le menu Fichier, cliquez sur Ouvrir.
  6. Recherchez le fichier SwitchDefaultViewForm.xml, puis cliquez sur Ouvrir.

    Le formulaire s'ouvre dans la vue 2.
retour au début
Propriétés

ID d'article : 826997 - Dernière mise à jour : 12/01/2003 18:18:00 - Révision : 2.0

Microsoft Office InfoPath 2003

  • kbhowto KB826997
Commentaires
&t=">")[0].appendChild(m);