Certains correctifs antérieurs au Service Pack 1 ne migrent pas vers la version SP1 lors de la mise à jour de l'ordinateur vers Windows XP SP1

Le support de Windows XP a pris fin

Microsoft a mis fin au support de Windows XP le 8 avril 2014. Cette modification a affecté vos mises à jour logicielles et options de sécurité. Découvrez les implications de ce changement à votre niveau et la marche à suivre pour rester protégé.

Cet article a été archivé. Il est proposé « en l'état » et ne sera plus mis à jour.
Symptômes
Lorsque vous mettez à jour votre ordinateur Microsoft Windows XP vers Microsoft Windows XP Service Pack 1 (SP1), certains correctifs logiciels antérieurs au Service Pack 1 installés sur votre ordinateur risquent de ne pas migrer correctement de la version d'origine de Windows XP vers Windows XP SP1.

Remarques
  • Lorsque vous installez un correctif logiciel antérieur à Windows XP SP1 sur un ordinateur Windows XP, une version SP1 de ce correctif est également copiée sur l'ordinateur pour être utilisée lors de la mise à jour de l'ordinateur vers Windows XP SP1. Lorsque vous mettez à jour l'ordinateur vers Windows XP SP1, la version SP1 du correctif est installée automatiquement.

    Pour plus d'informations sur ce processus automatique, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
    328848 Description des packages de mise à jour à double mode de Windows XP
  • Pour vérifier si un correctif logiciel a été migré vers Windows XP SP1, examinez le fichier Xpsp1hfm.log dans votre dossier Windows.
  • Ce problème ne se produit pas lors de la mise à jour vers Windows XP Service Pack 2 (SP2) dans l'une des situations suivantes :
    • Vous effectuez la mise à jour de la version commerciale de Windows XP sans correctifs logiciels installés.
    • Vous effectuez la mise à jour de Windows XP SP1 avec des correctifs antérieurs au Service Pack 2 installés.
  • Après la mise à jour de votre ordinateur vers Windows XP SP1, certains correctifs logiciels pré-SP1 ne peuvent pas être installés. Le message d'erreur suivant peut s'afficher :
    L'installation a rencontré une erreur : Les fichiers du package ne sont pas compatibles avec les fichiers présents sur votre système.
    Ce message d'erreur est répertorié dans le fichier journal pour la mise à jour, par exemple KBxxxxxx.log. Le programme Windows Installer retourne également un code d'erreur étendu 0xf0f1.
Cause
Ce problème est provoqué par le fichier Branches.inf. Le fichier Branches.inf aide le programme Windows Installer à identifier quelle version d'un correctif logiciel spécifique doit être installée.

Ce problème se produit si les correctifs suivants sont installés :
841356 MS04-037 : Une vulnérabilité dans le shell Windows risque de permettre l'exécution de code à distance
840987 MS04-032 : Mise à jour de sécurité de Microsoft Windows
824151 MS04-030 : Un problème de sécurité dans le gestionnaire de messages XML WebDAV peut entraîner une attaque de type Refus de service
Résolution
Pour résoudre ce problème, lorsque vous mettez à jour votre ordinateur Windows XP, appliquez l'une des méthodes suivantes :
Statut
Microsoft a confirmé l'existence de ce problème dans les produits Microsoft figurant dans la liste des produits concernés par cet article.
Plus d'informations
Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
824684 Terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft
Propriétés

ID d'article : 887822 - Dernière mise à jour : 01/16/2015 09:00:26 - Révision : 2.0

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Édition familiale
  • kbnosurvey kbarchive kbqfe kbhotfixserver kbwinxppresp3fix kbwinxpsp3fix kbfix kbbug KB887822
Commentaires