Vous êtes actuellement hors ligne, en attente de reconnexion à Internet.

Comment utiliser l'API de la boîte de dialogue communes dans une base de données dans Access 2003 ou Access 2007

Le support d'Office 2003 a pris fin

Microsoft a mis fin au support d'Office 2003 le 8 avril 2014. Cette modification a affecté vos mises à jour logicielles et options de sécurité. Découvrez les implications de ce changement à votre niveau et la marche à suivre pour rester protégé.

IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d’articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d’avoir accès, dans votre propre langue, à l’ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s’exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s’efforce aussi continuellement de faire évoluer son système de traduction automatique.

La version anglaise de cet article est la suivante: 888695
INTRODUCTION
Cet article explique comment utiliser l'API de la boîte de dialogue communes dans Microsoft Office Access 2003 ou Microsoft Office Access 2007 pour remplacer la fonctionnalité de boîte de dialogue commun est inclue uniquement dans Microsoft Office 2000 Developer Edition ou Microsoft Office XP Developer Edition.
Plus d'informations
Microsoft fournit des exemples de programmation pour illustration uniquement, sans garantie explicite ou implicite. Cela inclut, mais n'est pas limité aux garanties implicites de qualité marchande ou d'adéquation à un usage particulier. Cet article suppose que vous êtes familiarisé avec le langage de programmation présenté et les outils qui sont utilisés pour créer et déboguer des procédures. Les techniciens du support technique Microsoft peuvent vous expliquer les fonctionnalités d'une procédure particulière, mais ils ne sont pas modifier les exemples en vue de fournir des fonctionnalités supplémentaires ou de créer des procédures répondant à vos besoins spécifiques.

Procédure pour remplacer la fonctionnalité de boîte de dialogue communes

Microsoft Office Access 2003

  1. Dans Access, ouvrez la base de données exemple Comptoir.mdb nommée.

    note La base de données Comptoir.mdb pour Access 2003 se trouve généralement dans le Office\OFFICE11\Samples Files\Microsoft C:\Program dossier.
  2. Sous objets dans la fenêtre base de données Les Comptoirs, cliquez sur formulaires .
  3. Dans la barre d'outils fenêtre base de données , cliquez sur Nouveau .
  4. Dans la boîte de dialogue Nouveau formulaire , cliquez sur mode Création , puis cliquez sur OK .
  5. Ajouter une zone de texte dans Form1, cliquez avec le bouton droit sur la zone de texte et puis cliquez sur Propriétés .
  6. Cliquez sur l'onglet toutes , cliquez sur le nom , tapez Texte1 et puis fermez la boîte de dialogue Propriétés .
  7. Cliquez avec le bouton droit sur le contrôle étiquette est associé à la zone de texte Texte1 , cliquez sur Propriétés et puis cliquez sur l'onglet toutes .
  8. Cliquez sur légende , tapez Texte1 et puis fermez la boîte de dialogue Propriétés .
  9. Ajouter un bouton de commande à Form1 , cliquez avec le bouton droit sur le bouton de commande, cliquez sur Propriétés , cliquez sur le nom , tapez Command1 , cliquez sur légende et tapez Command1 .
  10. Cliquez sur l'onglet événement , cliquez sur [Procédure événementielle] dans la liste au clic et puis cliquez sur ce bouton pour démarrer Microsoft Visual Basic Editor.
  11. Modifier le code de la procédure Command1_Click à la suivante :
    Private Sub Command1_Click()    Me!Text1 = LaunchCD(Me)End Sub
  12. On the Insert menu, click Module, and then insert the following code into Module1:
    Private Declare Function GetOpenFileName Lib "comdlg32.dll" Alias _"GetOpenFileNameA" (pOpenfilename As OPENFILENAME) As LongPrivate Type OPENFILENAME    lStructSize As Long    hwndOwner As Long    hInstance As Long    lpstrFilter As String    lpstrCustomFilter As String    nMaxCustFilter As Long    nFilterIndex As Long    lpstrFile As String    nMaxFile As Long    lpstrFileTitle As String    nMaxFileTitle As Long    lpstrInitialDir As String    lpstrTitle As String    flags As Long    nFileOffset As Integer    nFileExtension As Integer    lpstrDefExt As String    lCustData As Long    lpfnHook As Long    lpTemplateName As StringEnd TypeFunction LaunchCD(strform As Form) As String    Dim OpenFile As OPENFILENAME    Dim lReturn As Long    Dim sFilter As String    OpenFile.lStructSize = Len(OpenFile)    OpenFile.hwndOwner = strform.hwnd    sFilter = "All Files (*.*)" & Chr(0) & "*.*" & Chr(0) & _      "JPEG Files (*.JPG)" & Chr(0) & "*.JPG" & Chr(0)    OpenFile.lpstrFilter = sFilter    OpenFile.nFilterIndex = 1    OpenFile.lpstrFile = String(257, 0)    OpenFile.nMaxFile = Len(OpenFile.lpstrFile) - 1    OpenFile.lpstrFileTitle = OpenFile.lpstrFile    OpenFile.nMaxFileTitle = OpenFile.nMaxFile    OpenFile.lpstrInitialDir = "C:\"    OpenFile.lpstrTitle = "Select a file using the Common Dialog DLL"    OpenFile.flags = 0    lReturn = GetOpenFileName(OpenFile)        If lReturn = 0 Then            MsgBox "A file was not selected!", vbInformation, _               "Select a file using the Common Dialog DLL"         Else            LaunchCD = Trim(Left(OpenFile.lpstrFile, InStr(1, OpenFile.lpstrFile, vbNullChar) - 1))          End IfEnd Function
  13. Dans le menu Déboguer , cliquez sur Compiler les Comptoirs , puis fermez l'Editeur Visual Basic.
  14. Dans le menu Affichage , cliquez sur formulaire Affichage .
  15. Cliquez sur Command1 , puis cliquez sur un fichier dans la fenêtre qui s'ouvre.

    Le chemin d'accès du fichier s'affiche dans la zone de texte Texte1 .

Microsoft Office Access 2007

  1. Dans Access 2007, ouvrez la base de données exemple qui est nommé Northwind.accdb.
  2. Sous l'onglet Créer , cliquez sur formulaire dans le groupe de formulaires .
  3. Sous l'onglet Format , cliquez sur la flèche vers le bas sous Afficher , puis cliquez sur mode Création .
  4. Ajouter une zone de texte dans Form1, cliquez avec le bouton droit sur la zone de texte et puis cliquez sur Propriétés .
  5. Cliquez sur l'onglet toutes , cliquez sur le nom et tapez Texte1 .
  6. Cliquez avec le bouton droit sur le contrôle étiquette est associé à la zone de texte Texte1 , cliquez sur Propriétés et puis cliquez sur l'onglet toutes .
  7. Cliquez sur légende et tapez Texte1 .
  8. Ajouter un bouton de commande à Form1 , cliquez avec le bouton droit sur le bouton de commande, cliquez sur Propriétés , cliquez sur le nom , tapez Command1 , cliquez sur légende et tapez Command1 .
  9. Cliquez sur l'onglet événement , cliquez sur [Procédure événementielle] dans la liste au clic et puis cliquez sur le bouton points de suspension (... ) pour démarrer Microsoft Visual Basic Editor.
  10. Modifier le code de la procédure Command1_Click pour ressembler à l'exemple de code suivant.
    Private Sub Command1_Click()    Me!Text1 = LaunchCD(Me)End Sub
  11. On the Insert menu, click Module, and then insert code that resembles the following code example into Module1.
    Private Declare Function GetOpenFileName Lib "comdlg32.dll" Alias _"GetOpenFileNameA" (pOpenfilename As OPENFILENAME) As LongPrivate Type OPENFILENAME    lStructSize As Long    hwndOwner As Long    hInstance As Long    lpstrFilter As String    lpstrCustomFilter As String    nMaxCustFilter As Long    nFilterIndex As Long    lpstrFile As String    nMaxFile As Long    lpstrFileTitle As String    nMaxFileTitle As Long    lpstrInitialDir As String    lpstrTitle As String    flags As Long    nFileOffset As Integer    nFileExtension As Integer    lpstrDefExt As String    lCustData As Long    lpfnHook As Long    lpTemplateName As StringEnd TypeFunction LaunchCD(strform As Form) As String    Dim OpenFile As OPENFILENAME    Dim lReturn As Long    Dim sFilter As String    OpenFile.lStructSize = Len(OpenFile)    OpenFile.hwndOwner = strform.hwnd    sFilter = "All Files (*.*)" & Chr(0) & "*.*" & Chr(0) & _      "JPEG Files (*.JPG)" & Chr(0) & "*.JPG" & Chr(0)    OpenFile.lpstrFilter = sFilter    OpenFile.nFilterIndex = 1    OpenFile.lpstrFile = String(257, 0)    OpenFile.nMaxFile = Len(OpenFile.lpstrFile) - 1    OpenFile.lpstrFileTitle = OpenFile.lpstrFile    OpenFile.nMaxFileTitle = OpenFile.nMaxFile    OpenFile.lpstrInitialDir = "C:\"    OpenFile.lpstrTitle = "Select a file using the Common Dialog DLL"    OpenFile.flags = 0    lReturn = GetOpenFileName(OpenFile)        If lReturn = 0 Then            MsgBox "A file was not selected!", vbInformation, _               "Select a file using the Common Dialog DLL"         Else            LaunchCD = Trim(Left(OpenFile.lpstrFile, InStr(1, OpenFile.lpstrFile, vbNullChar) - 1))          End IfEnd Function
  12. Dans le menu Déboguer , cliquez sur Compiler les Comptoirs , puis fermez l'Editeur Visual Basic.
  13. Sous l'onglet Format , cliquez sur la flèche vers le bas sous Afficher , puis cliquez sur mode formulaire .
  14. Cliquez sur Command1 , puis cliquez sur un fichier dans la fenêtre qui s'ouvre.

    Le chemin du fichier apparaît dans la zone Texte1 .
ACC2003 ACC2007

Avertissement : cet article a été traduit automatiquement

Propriétés

ID d'article : 888695 - Dernière mise à jour : 06/04/2007 19:34:07 - Révision : 4.3

Microsoft Office Access 2007, Microsoft Office Access 2003

  • kbmt kbsampledatabase kbprogramming kbautomation kbexpertiseinter kbhowto KB888695 KbMtfr
Commentaires
tsByTagName("head")[0].appendChild(m);