Message d'erreur lors de mise à niveau de Microsoft Dynamics CRM 3.0 vers Microsoft Dynamics CRM 4.0: « Impossible de résoudre l'entité liée pour la mise à niveau rapport »

IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d’articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d’avoir accès, dans votre propre langue, à l’ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s’exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s’efforce aussi continuellement de faire évoluer son système de traduction automatique.

La version anglaise de cet article est la suivante: 946543
Cet article a été archivé. Il est proposé « en l'état » et ne sera plus mis à jour.
Symptômes
Lorsque vous supprimez une entité personnalisée qui comporte un rapport lié dans Microsoft Dynamics CRM 3.0, et mise à puis niveau Microsoft Dynamics CRM 3.0 vers Microsoft Dynamics CRM 4.0, vous recevez le message d'erreur suivant dans le fichier CRM40Setup.log :
Time| Error| Impossible résoudre l'entité liée pour la mise à niveau rapport. L'entité ont été ajoutée puis supprimée sans mettre à jour la référence de rapport.
Nom du rapport : activités dû, nom logique entité : activité
Time| Error| Impossible de mettre à niveau reports.System.NullReferenceException : objet de référence non définie à une instance d'un objet.
à Microsoft.Crm.Setup.Server.Utility.ReportUpgradeUtility.BuildRelatedEntitiesValue (chaîne reportName relatedEntitiesXml de type String, organizationId GUID)
à Microsoft.Crm.Reporting.ReportUpgradeServer.GetReportProperties (chaîne reportName organizationName de type String, organizationId GUID)
à Microsoft.Crm.Setup.Server.Utility.ReportUpgradeUtility.LoadReportProperties (ReportUpgradeServer reportUpgradeServer propertiesByName Hashtable organizationName de type String, GUID organizationId, reportingGroup chaîne)
à Microsoft.Crm.Setup.Server.Utility.ReportUpgradeUtility.LoadReports (ReportUpgradeServer reportUpgradeServer organizationName chaîne GUID organizationId, reportingGroup de type String)
à Microsoft.Crm.Setup.Server.Utility.ReportUpgradeUtility.UpgradeReportsFromVersion3 (organizationUniqueName de type String organizationFriendlyName de type String reportingGroup de type String, Int32 languageCode, InstallInfo installInfo, IProgressEventSource progression)
à Microsoft.Crm.Setup.Server.RSUpgradeAction.Do (paramètres IDictionary)
Cause
Ce problème se produit car un état est lié à une entité qui n'existe pas.
Résolution
Pour résoudre ce problème, téléchargez manuellement l'état de Microsoft Dynamics CRM 3.0 qui provoque le problème après la mise à niveau vers Microsoft Dynamics CRM 4.0. Pour ce faire, procédez comme suit :
  1. Cliquez sur Poste de travail , cliquez sur rapports et puis cliquez sur Nouveau .
  2. Dans la liste Type de rapport , cliquez sur un fichier existant .
  3. Cliquez sur Parcourir .
  4. Cliquez sur le fichier .RDL pour l'état qui provoque le problème, puis cliquez sur Ouvrir .
  5. Renseignez les champs requis, puis cliquez sur Enregistrer et fermer .

Avertissement : Cet article a été traduit automatiquement.

Propriétés

ID d'article : 946543 - Dernière mise à jour : 01/15/2015 08:59:49 - Révision : 2.0

Microsoft Dynamics CRM 4.0

  • kbnosurvey kbarchive kbmt kberrmsg kbexpertiseadvanced kbtshoot kbprb kbexpertisebeginner kbmbsmigrate kbexpertiseinter kbmbsupgrade KB946543 KbMtfr
Commentaires