Calculer la différence entre deux heures

Calculer la différence entre deux heures

Imaginons que vous vouliez savoir combien de temps faut un employé pour terminer une opération d'assemblage ou qu'un ordre de nourriture rapide doit être traitée aux heures de pointe. Il existe plusieurs façons de calculer la différence entre deux heures.

Présenter le résultat au format d'heure standard

Vous pouvez utiliser deux approches pour présenter les résultats au format horaire standard (heures : minutes : secondes). Utilisez l'opérateur de soustraction(-)pour rechercher la différence entre les heures, puis faites l'une des façons suivantes :

Appliquez un code de format personnalisé à la cellule en appliquant la procédure suivante :

  1. Sélectionnez la cellule.

  2. Sous l'onglet Accueil, dans le groupe Nombre, cliquez sur la flèche en face de la zone Général, puis sur Autres formats numériques.

  3. Dans la boîte de dialogue Format de cellule, cliquez sur Personnalisé dans la liste Catégorie, puis sélectionnez un format personnalisé dans la zone Type.

Utilisez la fonction TEXTE pour mettre en forme les heures : Lorsque vous utilisez les codes de format d'heure, les heures ne dépassent jamais 24, les minutes ne dépassent jamais 60 et les secondes ne dépassent jamais 60.

Exemple de tableau 1 — Présenter le résultat au format d'heure standard

Copiez le tableau suivant dans une feuille de calcul vide, puis modifiez-le si nécessaire.

A

B

1

Heure de début

Heure de fin

2

09/06/2007 10:35

09/06/2007 15:30

3

Formule

Description (résultat)

4

=B2-A2

Heures entre deux heures (4). Vous devez appliquer manuellement le format personnalisé « h » à la cellule.

5

=B2-A2

Heures et minutes entre deux heures (4:55). Vous devez appliquer manuellement le format personnalisé « h:mm » à la cellule.

6

=B2-A2

Heures, minutes et secondes entre deux heures (4:55:00). Vous devez appliquer manuellement le format personnalisé « h:mm:ss » à la cellule.

7

=TEXTE(B2-A2;"h »)

Heures entre deux heures avec la cellule au format « h » à l'aide de la fonction TEXTE (4).

8

=TEXTE(B2-A2;"h:mm »)

Heures et minutes entre deux heures avec la cellule au format « h:mm » à l'aide de la fonction TEXTE (4:55).

9

=TEXTE(B2-A2;"h:mm:ss »)

Heures, minutes et secondes entre deux heures avec la cellule mise en forme comme « h:mm:ss » à l'aide de la fonction TEXTE (4:55:00).

Remarque : Si vous utilisez à la fois un format appliqué avec la fonction TEXTE et un format numérique à la cellule, la fonction TEXTE prend le pas sur la mise en forme de la cellule.

Pour plus d'informations sur l'utilisation de ces fonctions, voir Fonction TEXTE et Afficher les nombres sous la mesure de dates ou d'heures.

Exemple de tableau 2 : présenter le résultat sur la base d'une unité de temps unique

Pour ce faire, vous utiliserez la fonction ENT ou les fonctions HEURE,MINUTEet SECONDE, comme illustré dans l'exemple suivant.

Copiez le tableau suivant dans une feuille de calcul vide, puis modifiez le cas échéant.

A

B

1

Heure de début

Heure de fin

2

09/06/2007 10:35

09/06/2007 15:30

3

Formule

Description (résultat)

4

=ENT((B2-A2)*24)

Nombre total d'heures entre deux heures (4)

5

=(B2-A2)*1440

Nombre total de minutes entre deux heures (295)

6

=(B2-A2)*86400

Nombre total de secondes entre deux heures (17 700)

7

=HEURE(B2-A2)

Différence dans l'unité d'heures entre deux heures. Cette valeur ne peut pas dépasser 24 (4).

8

=MINUTE(B2-A2)

Différence dans l'unité de minutes entre deux heures. Cette valeur ne peut pas dépasser 60 (55).

9

=SECONDE(B2-A2)

Différence dans l'unité de seconde entre deux heures. Cette valeur ne peut pas dépasser 60 (0).

Pour plus d'informations sur l'utilisation de ces fonctions, voir ent fonctionENT,fonction HEURE, fonction MINUTEet fonction SECONDE.

Besoin d’aide ?

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×