Comment corriger les erreurs dans les formules dans Excel pour Mac

Qu’est-ce que #VALUE #NAME. ou un problème lié à la fonction RECHERCHEV, les informations suivantes peuvent vous aider à résoudre votre problème.

RECHERCHEV

Si vous rencontrez des erreurs ou des résultats inattendus avec la fonction RECHERCHEV, téléchargez l’Aide-mémoire : conseils de dépannage pour RECHERCHEV.

#VALEUR! erreur

L’origine de ce problème est généralement liée à l’utilisation d’une combinaison de valeurs numériques et de valeurs de texte. Pour plus d’informations, reportez-vous à corriger une erreur #VALUE..

#NOM? erreur

Assurez-vous de taper les noms correctement, entourez le texte entre guillemets ou placez les noms de feuilles entre des guillemets simples ('). Pour obtenir d’autres causes et solutions, consultez la rubrique #NAME ? erreur ..

#NOMBRE! erreur

Cela peut se produire si vous avez tapé des caractères supplémentaires dans une formule. Par exemple, ne tapez pas $1 000 dans une formule. Entrez plutôt 1000. Pour obtenir d’autres causes et solutions, voir corriger une erreur #NUM..

Erreur #N/A

Si une formule ne parvient pas à trouver une valeur référencée, elle renvoie l’erreur #N/A. Pour plus d’informations, voir Corriger une erreur #N/A.

#REF! erreur

Excel affiche cette erreur lorsqu’une formule contient une référence de cellule qui n’est pas valide. Pour plus d’informations, reportez-vous à corriger une erreur #REF..

#DIV/0! erreur

Cela se produit lorsqu’un nombre est divisé par zéro (0) ou lorsqu’une formule fait référence à une cellule qui a la valeur 0 ou qu’elle est vide. Pour plus d’informations, reportez-vous à la rubrique #DIV/0 ! erreur..

Faire référence à d’autres feuilles ou classeurs

Si vous faites référence à une autre feuille de calcul nom, tapez ! après le nom, puis tapez une cellule ou une plage. Si le nom de la feuille comporte des espaces, placez-le entre des guillemets simples ('). Par exemple : =SOMME('Rapport des ventes'!A1:A8).

Lorsque vous faites référence à un autre classeur externe :

  • Placez le nom du classeur entre crochets [ ].

  • Tapez le chemin d’accès complet au fichier.

  • Utilisez des guillemets simples (au début du chemin d’accès et après le nom de la feuille de calcul, avant le point d’exclamation).

    Exemple : =SOMME('/Utilisateurs/votre_nom/Bureau/[Opérations T2.xlsx]Ventes'!A1:A8)

Autres solutions rapides qui peuvent vous aider

  • Précédez chaque formule du signe égal (=). Exemple : =SOMME(A1:A8)

  • Utilisez le symbole * pour multiplier des nombres, et non la lettre X. Exemple : =A1*A8

  • Faites correspondre toutes les parenthèses ouvrantes et fermantes. Cet exemple inclut 2 paires : =SI(40>50;SOMME(G2:G5);0)

  • Tapez tous les arguments requis. Le Concepteur de formule peut vous aider à rédiger les formules. Commencez à taper une formule en saisissant un nom de fonction, puis appuyez sur Ctrl+A pour afficher le Concepteur de formule.

  • Utilisez des guillemets autour du texte dans les formules. Exemple : =SI(A2>B2;"Dépasse le budget";"OK")

  • Modifiez le type de données d’une cellule référencée. Pour ce faire, appuyez sur Cmd +1, puis sélectionnez Nombre.

Besoin d’aide ?

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×