Copier une formule en faisant glisser la poignée de recopie dans Excel pour Mac

Vous pouvez rapidement copier des formules dans des cellules adjacentes à l’aide de la poignée de recopie.

Poignée de recopie
 

Lorsque vous faites glisser la poignée vers d’autres cellules, Excel affiche des résultats différents pour chaque cellule.

Copier une formule en faisant glisser la poignée de recopie

Procédez comme suit :

  1. Sélectionnez la cellule contenant la formule à recopier dans des cellules adjacentes.

  2. Placez le curseur dans le coin inférieur droit jusqu’à ce qu’il se change en signe plus (+), comme ceci :

    Curseur positionné sur la poignée de recopie

  3. Faites glisser la poignée de recopie vers le bas, vers le haut ou sur les cellules que vous souhaitez remplir. Dans cet exemple, la figure ci-dessous montre le glissement de la poignée de re remplissage vers le bas :

    Curseur faisant glisser la poignée de recopie vers le bas

  4. Lorsque vous relâchez votre clic, la formule est appliquée automatiquement aux autres cellules :

    Valeurs qui s’affichent pour les cellules qui ont été remplies

  5. Pour modifier le mode de recopie, cliquez sur le bouton Options de recopie incrémentée Bouton Options de recopie incrémentée qui apparaît une fois la copie terminée, puis sur l’option de votre choix.

Pour plus d’informations sur la copie de formules, voir Copier et coller une formule dans une autre cellule ou feuille de calcul.

Conseils : 

  • Vous pouvez également appuyer sur Ctrl+D pour re remplir la formule vers le bas dans une colonne. Sélectionnez tout d'abord la cellule qui contient la formule que vous voulez remplir, sélectionnez les cellules en dessous, puis appuyez sur Ctrl+D.

  • Vous pouvez également appuyer sur Ctrl+R pour resserrez la formule vers la droite dans une ligne. Sélectionnez tout d'abord la cellule qui contient la formule à resserrer, sélectionnez les cellules à droite de celle-ci, puis appuyez sur Ctrl+R.

Si la recopie ne fonctionne pas

Parfois, la ressaisage fonctionne parfaitement et, parfois, elle ne fonctionne pas comme prévu. C'est pourquoi il est important de vérifier les références de cellule de la première cellule.

Les références de cellule sont simplement des pointeurs vers d’autres cellules. Par exemple, supposons que la première cellule comporte cette formule :


=SOMME(A1;B1)


A1 et B1 sont des références relatives. Cela signifie simplement que lorsque vous recréez la formule vers le bas, les références changeront de manière incrémentielle de A1, B1 à A2, B2, et ainsi de suite, comme ceci :

=SOMME(A1;B1)

=SOMME(A2;B2)

=SOMME(A3;B3)

Dans d'autres cas, il est possible que vous ne vouliez pas que les références à d'autres cellules changent. Par exemple, supposons que vous vouliez que la première référence, A1, reste fixe et B1 change à mesure que vous faites glisser la poignée de re fillon. Si c'est le cas, entrez le signe euro ($) dans la première référence : =SOMME($A$1;B1). Le signe dollar oblige Excel à continuer à pointer sur A1 lorsque vous remplissez d'autres cellules. Voici à quoi ça ressemble :

=SOMME($A$1;B1)

=SOMME($A$1;B2)

=SOMME($A$3;B3)

Les références contenant le symbole du dollar ($) sont appelées références absolues. Lorsque vous faites glisser la poignée de recopie vers le bas, la référence à A1 ne change pas, mais Excel remplace la référence vers B1, par B2, puis B3.

Vous avez des difficultés à voir la poignée de recopie ?

Si vous ne voyez pas la poignée de recopie, il est possible qu’elle soit masquée. Pour l'afficher :

  1. Dans le menu Excel, cliquez sur Préférences.

  2. Cliquez sur Modifier.

  3. Sous Options d’édition, activez la case à cocher Activer la poignée de recopie et le glisser-déplacer des cellules.

Si la fonction de calcul automatique dans le classeur ne fonctionne pas, les formules ne sont pas recalculées lorsque vous re remplissez des cellules.

Voici comment l’activer :

  1. Dans le menu Excel, cliquez sur Préférences.

  2. Cliquez sur Calcul.

  3. Dans les options decalcul, assurez-vous que l'option Automatique est sélectionnée.

Besoin d’aide ?

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×