Correction d’un #REF ! erreur

Correction d’un #REF ! erreur

L’erreur #REF! s’affiche quand une formule fait référence à une cellule non valide. Cela se produit le plus souvent quand des cellules référencées par des formules sont supprimées ou remplacées.

Exemple - Erreur #REF! causée par la suppression d’une colonne

L’exemple suivant utilise la formule =SOMME(B2;C2;D2) dans la colonne E.

Une formule utilisant des références de cellule explicites, telle que =SOMME(B2;C2;D2), peut générer une erreur #REF! en cas de suppression d’une colonne.

Si vous supprimiez la colonne B, C ou D, cela provoquerait un #REF! comme erreur. Dans ce cas, nous allons supprimer la colonne C (Ventes 2007) et la formule est désormais =SOMME(B2,#REF!,C2). Lorsque vous utilisez des références de cellule explicites comme celle-ci (où vous référencez chaque cellule individuellement, séparées par une virgule) et supprimez une ligne ou une colonne référencé(e), Excel ne peut pas résoudre le problème et renvoie le #REF ! comme erreur. Il n’est pas recommandé d’utiliser des références de cellule explicites pour cette raison.

Exemple d’erreur #REF! causée par la suppression d’une colonne.

Solution

  • Si vous avez supprimé par mégarde des lignes ou des colonnes, vous pouvez immédiatement cliquer sur le bouton Annuler dans la barre d’outils Accès rapide (ou appuyer sur CTRL+Z) pour les restaurer.

  • Ajustez la formule de sorte qu’elle utilise une référence de plage plutôt que des cellules individuelles, telle que =SOMME(B2:D2). Vous pouvez maintenant supprimer n’importe quelle colonne dans la plage de somme pour qu’Excel ajuste automatiquement la formule. Vous pouvez également utiliser =SOMME(B2:B5) pour une somme de lignes.

Exemple : RECHERCHEV avec des références de plage incorrectes

Dans l’exemple suivant, =RECHERCHEV(A8;A2:D5;5;FAUX) retourne une #REF! car elle recherche une valeur à renvoyer à partir de la colonne 5, mais la plage de référence A:D ne compte que 4 colonnes.

Exemple de formule RECHERCHEV avec une plage incorrecte.  La formule est =VLOOKU(A8;A2:D5;5;FAUX).  Comme il n’y a pas de cinquième colonne dans la plage rechercheV, 5 provoque un #REF! comme erreur.

Solution

Ajustez la plage pour l’agrandir, ou réduisez la valeur de recherche de colonne pour qu’elle corresponde à la plage de référence. =RECHERCHEV(A8;A2:E5;5;FAUX) serait une plage de référence valide, tout comme =RECHERCHEV(A8;A2:D5;4;FALSE).

Exemple : INDEX avec une référence de ligne ou de colonne incorrecte

Dans cet exemple, la formule =INDEX(B2:E5;5;5) renvoie une erreur #REF! parce que la plage INDEX comprend 4 lignes sur 4 colonnes, alors que la formule demande le renvoi du contenu de la 5ème ligne de la 5ème colonne.

Exemple de formule INDEX avec une référence de plage non valide.  La formule est =INDEX(B2:E5;5;5), mais la plage n’est que de 4 lignes sur 4 colonnes.

Solution

Ajustez les références de ligne ou de colonne afin qu’elles s’inscrivent à l’intérieur de la plage de recherche INDEX. =INDEX(B2:E5;4;4) renvoie un résultat valide.

Exemple : référence à un classeur fermé avec la fonction INDIRECT

Dans l’exemple suivant, une fonction INDIRECT tente de faire référence à un document fermé, ce qui provoque une #REF! comme erreur.

Exemple d’erreur #REF! causée par une fonction INDIRECT faisant référence à un classeur fermé.

Solution

Ouvrez le workbook référencé. Vous rencontrerez la même erreur si vous référencez un document fermé avec une fonction de tableau dynamique.

Problèmes OLE

Si vous avez utilisé un lien OLE (Object Linking and Embedding) qui retourne un #REF! , puis démarrez le programme que le lien appelle.

Remarque : OLE est une technologie permettant de partager des informations entre des programmes.

Problèmes DDE

Si vous avez utilisé une rubrique d’échange dynamique de données (DDE) qui retourne un #REF! , vérifiez tout d’abord que vous faites référence à la rubrique correcte. Si vous recevez toujours un #REF ! , vérifiez les paramètres du Centre de sécurité et sécurité du contenu externe tels qu’ils sont décrits dans bloquer ou débloquer le contenu externe dans les documents Office.

Remarque : DDE (Dynamic Data Exchange)est un protocole établi pour l’échange de données entre des programmes Microsoft Windows.

Problèmes de macro

Si une macro entre dans la feuille de calcul une fonction qui fait référence à une cellule au-dessus de la fonction et que la cellule qui contient la fonction se trouve dans la ligne 1, la fonction renvoie #REF ! car il n’y a pas de cellules au-dessus de la ligne 1. Vérifiez la fonction pour voir si un argument fait référence à une cellule ou plage de cellules non valide. Cela peut nécessiter la modification de la macro dans l Visual Basic de projet (VBE) pour tenir compte de cette situation.

Vous avez besoin d’une aide supplémentaire ?

Vous pouvez toujours consulter un expert de la communauté technique Excel, obtenir une assistance dans la communauté Answers ou suggérer une nouvelle fonctionnalité ou une amélioration sur le forum Excel User Voice.

Voir aussi

Vue d’ensemble des formules dans Excel

Comment éviter les formules incorrectes

Détecter les erreurs dans les formules

Fonctions Excel (par ordre alphabétique)

Fonctions Excel (par catégorie)

Besoin d’aide ?

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×