Correction de l’erreur #VALEUR! dans les fonctions MOYENNE et SOMME

Si moyenne ou somme font référence à des cellules qui contiennent des #VALUE. Erreurs, les formules génèrent un #VALUE. comme erreur.

Erreur #VALEUR! dans la fonction MOYENNE

Pour contourner les valeurs d’erreur, nous allons créer une formule qui ignore les erreurs présentes dans la plage de référence afin de calculer la moyenne avec les valeurs « normales » restantes.

Pour contourner ce problème, nous allons combiner les fonctions MOYENNE, SI et ESTERREUR afin de déterminer s’il existe une erreur dans la plage spécifiée. Pour ce faire, une formule matricielle est nécessaire :

=MOYENNE(SI(ESTERREUR(B2:D2),"",B2:D2))

Il s’agit d’une formule matricielle. Par conséquent, vous devez appuyer sur entrée (si vous utilisez Microsoft 365 ) ou Ctrl + Maj + Entrée dans la formule.

Remarque : Si vous disposez d’une version actuelle de Microsoft 365, vous pouvez simplement entrer la formule dans la cellule de sortie, puis appuyer sur entrée pour confirmer la formule en tant que formule matricielle dynamique. Dans le cas contraire, il est nécessaire d’entrer la formule en tant que formule matricielle héritée en sélectionnant d’abord la cellule de sortie, en entrant la formule dans la cellule de sortie et en appuyant sur Ctrl + Maj + Entrée pour la confirmer. Excel insère des accolades au début et à la fin de la formule. Pour plus d’informations sur les formules de tableau, voir Instructions et exemples de formules de tableau.

Fonction matricielle en moyenne pour résoudre le #VALUE ! erreur

Remarque : La fonction ci-dessus s’applique à #VALEUR! mais aussi à #N/A, #NULL, #DIV/0! et autres.

La fonction SOMME peut également être utilisée de la même façon :

=SOMME(SI(ESTERREUR(B2:D2),"",B2:D2))

Vous avez une question sur une fonction en particulier ?

Posez une question sur le forum de la communauté Excel

Besoin d’aide supplémentaire ?

Vous pouvez toujours consulter un expert de la communauté technique Excel ou obtenir une assistance dans la communauté Answers.

Voir aussi

Corriger une erreur #VALEUR! erreur

MOYENNE

SOMME

Vue d’ensemble des formules dans Excel

Détecter les erreurs dans les formules

Toutes les fonctions Excel (par ordre alphabétique)

Toutes les fonctions Excel (par catégorie)

Besoin d’aide ?

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×