Créer, charger ou modifier une requête dans Excel (Power Query)

Créer, charger ou modifier une requête dans Excel (Power Query)

Power Query offre plusieurs méthodes pour créer et charger des requêtes Power dans votre workbook. Vous pouvez également définir les paramètres de chargement de requête par défaut dans la fenêtre Options de requête.   

Conseil      Pour savoir si les données d’une feuille de calcul sont en forme par Power Query, sélectionnez une cellule de données, et si l’onglet de ruban contextux Requête apparaît, les données ont été chargées à partir de Power Query. 

Sélection d’une cellule dans une requête pour faire apparaître l’onglet Requête

Savoir dans quel environnement vous vous êtes Power Query est bien intégré à l’interface utilisateur d’Excel, en particulier lorsque vous importez des données, travaillez avec des connexions et modifiez des tableaux croisés dynamiques, Excel tables et des plages nommées. Pour éviter toute confusion, il est important de connaître l’environnement dans lequel vous vous trouvez actuellement, Excel Power Query, à tout moment.

Feuille de calcul, Excel ruban et grille familières

Ruban de l’Éditeur Power Query et aperçu des données 

Feuille de calcul Excel feuille de calcul classique Affichage de l’Éditeur Power Query classique

Par exemple, la manipulation de données dans Excel de calcul est fondamentalement différente de Power Query. Par ailleurs, les données connectées que vous voyez dans une feuille de calcul Excel peuvent ou non faire fonctionner Power Query en arrière-plan pour mettre en forme les données. Cela se produit uniquement lorsque vous chargez les données dans une feuille de calcul ou un modèle de données à partir de Power Query.

Renommer les onglets d’une feuille de calcul    Il est utile de renommer les onglets des feuilles de calcul de manière significative, en particulier si vous en avez beaucoup. Il est particulièrement important de clarifier la différence entre une feuille de calcul de données et une feuille de calcul chargée à partir de l’éditeur Power Query. Même si vous n’avez que deux feuilles de calcul, l’une avec une table Excel appelée Feuille1,et l’autre créée en important cette table Excel appelée Table1,il est facile de se confondre. Il est toujours pratique de modifier les noms par défaut des onglets de feuille de calcul par des noms qui vous semblent plus sensaux. Par exemple, renommz Sheet1 en DataTable et Table1 en QueryTable. Désormais, il est clair quel onglet possède les données et quel onglet possède la requête.

Vous pouvez soit créer une requête à partir de données importées, soit créer une requête vide.

Créer une requête à partir de données importées

Il s’agit de la façon la plus courante de créer une requête.

  1. Importez des données. Pour plus d’informations, voir Importer des données à partir de sources de données externes.

  2. Sélectionnez une cellule dans les données, puis sélectionnez Requête et> Modifier.

Créer une requête vide

Vous voudrez peut-être commencer de zéro. Pour ce faire, vous disposez de deux solutions.

  • Sélectionnez Données> obtenir des données >d’autres sources pour > requête vide.

  • Sélectionnez Données> Obtenir des données > lancer l’éditeur Power Query.

À ce stade, vous pouvez ajouter manuellement des étapes et des formules si vous connaissez le langage de formule Power Query M.

Vous pouvez également sélectionner Accueil, puis sélectionner une commande dans le groupe Nouvelle requête. Effectuez l’une des opérations suivantes :

  • Sélectionnez Nouvelle source pour ajouter une source de données. Cette commande est tout comme la commande Données> Obtenir des données dans le Excel ruban.

  • Sélectionnez Sources récentes pour faire votre choix parmi une source de données que vous avez déjà travaillée. Cette commande est tout comme la commande Données> sources récentes du Excel ruban.

  • Sélectionnez Entrer des données pour entrer manuellement des données. Vous pouvez choisir cette commande pour essayer l’Éditeur Power Query indépendamment d’une source de données externe.

En supposant que votre requête est valide et qu’elle ne présente aucune erreur, vous pouvez la charger sur une feuille de calcul ou un modèle de données.

Charger une requête à partir de l’Éditeur Power Query

Dans l’Éditeur Power Query, faites l’une des choses suivantes :

  • Pour charger une feuille de calcul, sélectionnez Accueil > Fermer & chargement > fermer & chargement.

  • Pour charger un modèle de données, sélectionnez Accueil > Fermer & chargement > et & à.

    Dans la boîte de dialogue Importer des données, sélectionnez Ajouter ces données au modèle dedonnées.

Conseil   Parfois, la commande Charger vers est grisée ou désactivée. Cela peut se produire la première fois que vous créez une requête dans un workbook. Si cela se produit, sélectionnez Fermer le chargement & ,dans la nouvelle feuille de calcul, sélectionnez Requêtes > de données & Connections > Queries, cliquez avec le bouton droit sur la requête, puis sélectionnez Charger vers. Dans le ruban de l’Éditeur Power Query, vous pouvez également sélectionner> charger vers.

Charger une requête à partir du volet Requêtes et connexions 

Dans Excel, vous pouvez charger une requête dans une autre feuille de calcul ou un autre modèle de données.

  1. Dans Excel, sélectionnez Données> requêtes & connexions,puis sélectionnez l’onglet Requêtes.

  2. Dans la liste des requêtes, recherchez la requête, cliquez avec le bouton droit sur la requête, puis sélectionnez Charger vers. La boîte de dialogue Importer des données s’affiche.

  3. Choisissez la manière dont vous souhaitez importer les données, puis sélectionnez OK. Pour plus d’informations sur l’utilisation de cette boîte de dialogue, sélectionnez le point d’interrogation (?).

Il existe plusieurs façons de modifier une requête chargée dans une feuille de calcul.

Modifier une requête à partir de données dans Excel calcul

  • Pour modifier une requête, recherchez-en une précédemment chargée à partir de l’Éditeur Power Query, sélectionnez une cellule dans les données, puis sélectionnez Requête >Modifier.

Modifier une requête à partir du volet Requêtes & Connexions

Le volet Requêtes & Connexions est plus pratique à utiliser lorsque vous avez de nombreuses requêtes dans un même workbook et que vous souhaitez en trouver une rapidement.

  1. Dans Excel, sélectionnez Données> requêtes & connexions,puis sélectionnez l’onglet Requêtes.

  2. Dans la liste des requêtes, recherchez la requête, cliquez avec le bouton droit sur la requête, puis sélectionnez Modifier.

Modifier une requête à partir de la boîte de dialogue Propriétés de la requête

  • Dans Excel, sélectionnez Données > Connexions de & >, cliquez avec le bouton droit sur la requête et sélectionnez Propriétés, sélectionnez l’onglet Définition dans la boîte de dialogue Propriétés, puis sélectionnez Modifier la requête.

Conseil    Si vous êtes dans une feuille de calcul avec une requête, sélectionnez Propriétés du> données,sélectionnez l’onglet Définition dans la boîte de dialogue Propriétés, puis sélectionnez Modifier la requête. 

Un modèle de données contient généralement plusieurs tables organisées dans une relation. Vous chargez une requête sur un modèle de données en utilisant la commande Charger vers pour afficher la boîte de dialogue Importer des données, puis en élecrant la case à cocher Ajouter ces données à la case à cocher Modede données l. Pour plus d’informations sur les modèles de données, voir Rechercher quelles sourcesde données sont utilisées dans un modèle de données debookbook, Créer un modèle de données dans Excelet Utiliser plusieurs tables pour créer un tableau croisé dynamique.

  1. Pour ouvrir le modèle de données, sélectionnez Power Pivot >Gérer.

  2. En bas de la fenêtre Power Pivot, sélectionnez l’onglet de feuille de calcul de la table de votre choix.

    Vérifier que la table correcte s’affiche. Un modèle de données peut avoir de nombreuses tables.

  3. Notez le nom du tableau.

  4. Pour fermer la fenêtre Power Pivot, sélectionnez Fichier> Fermer. La récupération de la mémoire peut prendre quelques secondes.

  5. Sélectionnez Données> connexions & propriétés>'onglet Requêtes, cliquez avec le bouton droit sur la requête, puis sélectionnez Modifier.

  6. Lorsque vous avez terminé d’apporter des modifications dans l’Éditeur Power Query, sélectionnez Fichier> fermer & chargement.

Résultat

La requête dans la feuille de calcul et la table du modèle de données sont mises à jour.

Si vous remarquez que le chargement d’une requête dans un modèle de données prend beaucoup plus de temps que le chargement dans une feuille de calcul, vérifiez les étapes de Power Query pour voir si vous filtrez une colonne de texte ou une colonne structurée Liste à l’aide de l’opérateur Contient. Cette action entraîne Excel’une nouvelle fois à l’entier du jeu de données pour chaque ligne. En outre, les Excel ne peuvent pas utiliser l’exécution multithread. Pour contourner ce n’est pas le cas, essayez d’utiliser un autre opérateur, tel que Est égal ou Commence par.

Microsoft est au courant de ce problème et il est en cours d’investigation.

Vous pouvez charger une power query :

  • Dans une feuille de calcul. Dans l’Éditeur Power Query, sélectionnez Accueil et> fermer & chargement > fermer & chargement.

  • À un modèle de données. Dans l’Éditeur Power Query, sélectionnez Accueil > fermer & chargement > sur & Chargervers. 

    Par défaut, Power Query charge les requêtes dans une nouvelle feuille de calcul lors du chargement d’une seule requête, et charge plusieurs requêtes en même temps dans le modèle de données.  Vous pouvez modifier le comportement par défaut pour tous vos workbooks ou uniquement le workbook actuel. Lorsque vous définir ces options, Power Query ne modifie pas les résultats de la requête dans la feuille de calcul ou les données et annotations du modèle de données.

    Vous pouvez également remplacer dynamiquement les paramètres par défaut d’une requête à l’aide de la boîte de dialogue Importer qui s’affiche après avoir sélectionné Fermer & chargervers. 

Paramètres globaux qui s’appliquent à tous vos livres

  1. Dans l’Éditeur Power Query, sélectionnez Fichier> Options et paramètres > Options de requête.

  2. Dans la boîte de dialogue Options de requête, à gauche, sous la section GLOBAL,  sélectionnez Chargement des données.

  3. Sous la section Chargement de la Paramètres de requête par défaut, vous pouvez :

    • Sélectionnez Utiliser les paramètres de chargement standard. 

    • Sélectionnez Spécifier les paramètresde chargement par défaut personnalisés, puis sélectionnez ou effacer Charger dans la feuille de calcul ou   Charger dans le modèle de données.

Conseil    En bas de la boîte de dialogue, vous pouvez sélectionner Restaurer les paramètres par défaut pour rétablir les paramètres par défaut.

Paramètres du groupe de travail qui s’appliquent uniquement au groupe de travail actuel

  1. Dans la boîte de dialogue Options de requête, à gauche, sous la section WORKBOOK ACTUEL, sélectionnez Chargement des données.

  2. Effectuez au moins l’une des opérations suivantes :

    • Sous Détection de type,sélectionnez ou désélecmenter Détecter les types de colonnes et les en-têtes des sources non structurées.

      Le comportement par défaut consiste à les détecter. Si vous préférez mettre en forme les données vous-même, n’indiquez pas cette option.

    • Sous Relations,c’est la première fois que vous ajoutez des relations entre les tables lors de leur ajout au modèle de données.

      Avant de charger dans le modèle de données, le comportement par défaut consiste à rechercher les relations existantes entre les tables, telles que les clés étrangères dans une base de données relationnelle, et à les importer avec les données. Si vous préférez le faire vous-même, vous pouvez effacer cette option.

    • Sous Relations, sélectionnezou désélecmentez les relations de mise à jour lors de l’actualisation des requêtes chargées dans le modèle de données.

      Le comportement par défaut consiste à ne pas mettre à jour les relations. Lors de l’actualisation des requêtes déjà chargées dans le modèle de données, Power Query trouve les relations existantes entre les tables telles que les clés étrangères dans une base de données relationnelle et les met à jour. Cela peut supprimer des relations créées manuellement après l’importation des données ou introduire de nouvelles relations. Toutefois, si vous voulez le faire, sélectionnez l’option.

    • Sous Données d’arrière-plan,sélectionnez ou sélectionnez Autoriser le téléchargement des aperçus de données en arrière-plan.

      Le comportement par défaut consiste à télécharger les aperçus de données en arrière-plan. Si vous souhaitez voir toutes les données immédiatement, n’c’est pas possible.

Voir aussi

Aide Power Query pour Excel

Gérer les requêtes dans Excel

Besoin d’aide ?

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

×