Cet article traite du processus de base de démarrage Access création d’une base de données qui sera utilisée sur des ordinateurs de bureau, et non sur le web. Il explique comment créer une base de données de bureau à l’aide d’un modèle et comment créer une base de données à partir de zéro en créant vos propres tables, formulaires, états et autres objets de base de données. Il explique également certaines techniques que vous pouvez utiliser pour obtenir des données existantes dans votre nouvelle base de données.

Contenu de cet article

Vue d’ensemble

Lorsque vous démarrez Access pour la première fois, ou si vous fermez une base de données sans fermer Access, le Microsoft Office Backstage s’affiche.

Le vue Backstage est un point de départ à partir duquel vous pouvez créer une base de données, ouvrir une base de données existante, afficher le contenu présenté à partir d' Office.com: tout ce que vous pouvez utiliser Access pour le faire dans un fichier de base de données ou en dehors d’une base de données, et non à l’intérieur d’une base de données.

Création d’une base de données

Lorsque vous ouvrez Access, le vue Backstage affiche l’onglet Nouveau. L’onglet Nouveau permet de créer une nouvelle base de données de plusieurs façons :

  • Base de données vide    Vous pouvez commencer à zéro si vous le souhaitez. Il s’agit d’une bonne option si vous avez des exigences de conception très spécifiques ou si vous avez des données existantes que vous devez contenir ou incorporer.

  • Modèle installé avec Access    Songez à utiliser un modèle si vous commencez un nouveau projet et souhaitez commencer par un début de projet. Access ininstalle par défaut plusieurs modèles.

  • Modèle créé à partir de Office.com    En plus des modèles qu’access vous permet d’utiliser, vous pouvez trouver davantage de modèles sur Office.com. Inutile même d’ouvrir un navigateur, les modèles sont disponibles sous l’onglet Nouveau.

Ajout à une base de données

Une fois que vous travaillez dans une base de données, vous pouvez ajouter des champs, des tables ou des composants d’application.

Les composants d’application sont une fonctionnalité qui vous permet d’utiliser plusieurs objets de base de données liés ensemble comme s’ils étaient un seul. Par exemple, un élément d’application peut se composer d’une table et d’un formulaire basé sur la table. Vous pouvez ajouter la table et le formulaire en même temps à l’aide du partie application.

Vous pouvez également créer des requêtes, des formulaires, des états et des macros, c’est-à-dire tous les objets de base de données que vous avez l’habitude d’utiliser.

Créer une base de données à l’aide d’un modèle

Access insérez une série de modèles que vous pouvez utiliser tels que tels ou comme point de départ. Un modèle est une base de données prête à l’emploi qui contient l’ensemble des tables, requêtes, formulaires, macros et états nécessaires pour effectuer une tâche spécifique. Par exemple, vous pouvez utiliser des modèles pour suivre des problèmes, gérer des contacts ou conserver un dossier de dépenses. Certains modèles contiennent quelques exemples d’enregistrements pour en faire une démonstration.

Si l’un de ces modèles répond à vos besoins, il s’agit généralement du moyen le plus rapide pour démarrer une base de données. Toutefois, si vous avez des données d’un autre programme que vous souhaitez importer dans Access, il peut être préférable de créer une base de données sans utiliser de modèle. Les modèles ont une structure de données déjà définie et peuvent nécessiter beaucoup de travail pour adapter vos données existantes à la structure du modèle.

  1. Si vous avez une base de données ouverte, sous l’onglet Fichier, cliquez sur Fermer. Le vue Backstage affiche l’onglet Nouveau.

  2. Plusieurs ensembles de modèles sont disponibles sous l’onglet Nouveau, dont certains sont intégrés à Access. Vous pouvez télécharger d’autres modèles à partir de Office.com. Pour plus d’informations, voir la section suivante de cet article.

  3. Sélectionnez le modèle à utiliser.

  4. Access suggère un nom de fichier pour votre base de données dans la zone Nom de fichier : vous pouvez modifier le nom du fichier si vous le souhaitez. Pour enregistrer la base de données dans un autre dossier à partir de celui qui s’affiche sous la zone du nom de fichier, cliquez sur texte de remplacement, accédez au dossier dans lequel vous voulez l’enregistrer, puis cliquez sur OK. Vous pouvez également créer et lier votre base de données à un site SharePoint.

  5. Cliquez sur Créer.

    Access crée une base de données à partir du modèle que vous avez choisi, puis ouvre la base de données. Pour de nombreux modèles, un formulaire s’affiche et vous pouvez commencer à entrer des données. Si votre modèle contient des exemples de données, vous pouvez supprimer chaque enregistrement en cliquant sur le sélecteur d’enregistrement (zone ou barre ombrée immédiatement à gauche de l’enregistrement), puis en suivant les étapes suivantes :

    Dans l’onglet Accueil, dans le groupe Enregistrements, cliquez sur Supprimer. Image du bouton

  6. Pour commencer à entrer des données, cliquez dans la première cellule vide du formulaire et commencez à taper. Utilisez le Volet de navigation pour rechercher d’autres formulaires ou états que vous pourriez vouloir utiliser. Certains modèles incluent un formulaire de navigation qui vous permet de vous déplacer entre les différents objets de base de données.

Pour plus d’informations sur l’utilisation des modèles, voir l’article Utiliser un modèle pour créer une base de données Access de bureau.

Haut de la page

Créer une base de données sans utiliser de modèle

Si l’utilisation d’un modèle ne vous intéresse pas, vous pouvez créer une base de données en créons vos propres tables, formulaires, états et autres objets de base de données. Dans la plupart des cas, cela implique l’une des situations suivantes, ou les deux :

  • Entrez, pastez ou importez des données dans la table créée lors de la création d’une base de données, puis répétez le processus avec les nouvelles tables que vous créez à l’aide de la commande Table sous l’onglet Créer.

  • Importation de données à partir d’autres sources et création de tables au cours du processus.

Créer une base de données vide

  1. Sous l’onglet Fichier, cliquez surNouveau, puis sur Base de données vide.

  2. Tapez un nom de fichier dans la zone Nom de fichier. Pour modifier l’emplacement du fichier par défaut, cliquez sur Rechercher un emplacement pour placer votre texte de remplacement de base de données (en côté de la zone Nom de fichier), accédez au nouvel emplacement, puis cliquez sur OK.

  3. Cliquez sur Créer.

    Access crée la base de données avec une table vide nommée Table1, puis ouvre Table1 en vue Feuille de données. Le curseur est placé dans la première cellule vide de la colonne Cliquer pour ajouter.

  4. Commencez à taper pour ajouter des données, ou vous pouvez coller des données d’une autre source, comme décrit dans la section Copier les données d’une autre source dans une table Access.

La saisie de données en affichage Feuille de données est semblable à l’affichage d’une feuille de calcul Excel. La structure du tableau est créée lorsque vous entrez des données. Lorsque vous ajoutez une nouvelle colonne à la feuille de données, un nouveau champ est défini dans la table. Access définit automatiquement le type de données de chaque champ, en fonction des données entrées.

Si vous ne voulez pas entrer de données dans Table1 pour le moment, cliquez sur Fermer Image du bouton. Si vous avez apporté des modifications à la table, Access vous invite à enregistrer les modifications. Cliquez sur Oui pour enregistrer vos modifications, sur Non pour les ignorer ou sur Annuler pour laisser la table ouverte.

Conseil :  Access recherche un fichier nommé Blank.accdb dans le dossier situé sur [install drive]:\Program Files\Microsoft Office\Templates\1033\Access\. Si elle existe, Blank.accdb est le modèle de toutes les nouvelles bases de données vides. Tout contenu qu’il contient est hérité par toutes les nouvelles bases de données vides. C’est un bon moyen de distribuer le contenu par défaut, comme des numéros de pièce ou des clauses d’exclusion de responsabilité et de stratégies de la société.

Important : Si vous fermez Table1 sans l’enregistrer au moins une fois, Access supprime la table entière, même si vous y avez entré des données.

Ajouter un tableau

Vous pouvez ajouter de nouvelles tables à une base de données existante à l’aide des commandes du groupe Tables sous l’onglet Créer.

Image du ruban Access

Créer une table en commençant en vue Feuille de données    En affichage Feuille de données, vous pouvez entrer des données immédiatement et laisser Access créer la structure de la table en arrière-plan. Les noms de champs sont attribués numériquement (Champ1, Champ2, etc.) et Access définit automatiquement le type de données de chaque champ, en fonction des données entrées.

  1. Sous l’onglet Création, dans le groupe Tables, cliquez sur Table. Image du bouton

    Access crée la table et sélectionne la première cellule vide dans la colonne Cliquer pour ajouter.

  2. Sous l’onglet Champs, dans le groupe & supprimer, cliquez sur le type de champ à ajouter. Si vous ne voyez pas le type que vous souhaitez, cliquez sur Autres champs Image du bouton.

  3. Access affiche la liste des types de champs fréquemment utilisés. Cliquez sur le type de champ voulu pour qu’Access ajoute le nouveau champ à la feuille de données au point d’insertion.

    Vous pouvez déplacer le champ en le faisant glisser. Lorsque vous faites glisser un champ dans une feuille de données, une barre d’insertion verticale s’affiche à l’endroit où le champ sera placé.

  4. Pour ajouter des données, commencez à taper dans la première cellule vide, ou collez les données d’une autre source, comme décrit dans la section Copier les données d’une autre source dans une table Access.

  5. Pour renommer une colonne (champ), double-cliquez sur son en-tête, puis tapez le nouveau nom.

    Vous devez donner un nom significatif à chaque champ afin de savoir ce qu’il contient lorsque vous le voyez dans le volet Liste de champs.

  6. Pour déplacer une colonne, cliquez sur son titre pour la sélectionner, puis faites-la glisser vers l’emplacement de votre choix. Vous pouvez également sélectionner plusieurs colonnes contiguës et les faire glisser vers un nouvel emplacement à la fois. Pour sélectionner plusieurs colonnes contiguës, cliquez sur l’en-tête de colonne de la première colonne, puis, tout en maintenant la sélection de la colonne en bas, cliquez sur l’en-tête de la dernière colonne.

Créer une table en mode Création    En mode Création, vous devez d’abord créer la structure de la table. Vous passez ensuite en mode Feuille de données pour entrer des données, ou entrer des données à l’aide d’une autre méthode, telle que le fait de les faire passer ou de les importer.

  1. Sous l’onglet Créer, dans le groupe Tables, cliquez sur Création de table. Image du bouton

  2. Pour chaque champ de votre table, tapez un nom dans la colonne Nom du champ, puis sélectionnez un type de données dans la liste Type de données.

  3. Si vous le souhaitez, vous pouvez taper une description pour chaque champ dans la colonne Description. La description est ensuite affichée dans la barre d’état lorsque le curseur se trouve dans ce champ en vue Feuille de données. La description est également utilisée comme texte de barre d’état pour les contrôles dans un formulaire ou état que vous créez en faisant glisser le champ à partir du volet Liste des champs, et pour tous les contrôles créés pour ce champ lorsque vous utilisez l’Assistant Formulaire ou l’Assistant État.

  4. Après avoir ajouté tous vos champs, enregistrez la table :

    • Sous l’onglet Fichier, cliquez sur Enregistrer.

  5. Vous pouvez commencer à taper des données dans la table à tout moment en passant en mode Feuille de données et en cliquant dans la première cellule vide. Vous pouvez également coller des données d’une autre source, comme décrit dans la section Copier les données d’une autre source dans une table Access.

Définir des propriétés de champ en mode Création    Quelle que soit la façon dont vous avez créé votre table, il est bon d’examiner et de définir les propriétés de champ. Bien que certaines propriétés soient disponibles en mode Feuille de données, certaines peuvent uniquement être définies en mode Création. Pour basculer en mode Création, cliquez avec le bouton droit sur la table dans le volet de navigation, puis cliquez sur Mode Création. Pour voir les propriétés d’un champ, cliquez dessus dans la grille de création. Les propriétés sont affichées sous la grille de création, sous Propriétés du champ.

Pour voir une description de chaque propriété de champ, cliquez sur la propriété et lisez la description dans la zone en regard de la liste de propriétés sous Propriétés du champ. Pour obtenir des informations plus détaillées, cliquez sur le bouton Aide.

Le tableau suivant décrit certaines des propriétés de champ fréquemment ajustées.

Propriété

Description

Taille du champ

Pour les champs de texte, cette propriété définit le nombre maximal de caractères qui peuvent être stockés dans le champ. La limite est de 255. Pour les champs Nombre, cette propriété définit le type de nombre qui sera stocké (Total long, Double, et ainsi de suite). Pour un stockage des données le plus efficace, il est recommandé d’allouer la moins d’espace dont vous pensez avoir besoin pour les données. Vous pouvez ajuster la valeur vers le haut ultérieurement si vos besoins changent.

Mise en forme

Cette propriété définit la façon dont les données s’affichent. Elle n’affecte pas les données réelles telles qu’elles sont stockées dans le champ. Vous pouvez sélectionner un format prédéféré ou entrer un format personnalisé.

Masque de saisie

Utilisez cette propriété pour spécifier un modèle pour toutes les données qui seront entrées dans ce champ. Cela permet de s’assurer que toutes les données sont entrées correctement et qu’elles contiennent le nombre de caractères requis. Pour obtenir de l’aide sur la création d’un masque de saisie, Bouton Générateursur le côté droit de la zone de propriété.

Valeur par défaut

Utilisez cette propriété pour spécifier la valeur par défaut qui apparaîtra dans ce champ chaque fois qu’un nouvel enregistrement est ajouté. Par exemple, si vous avez un champ Date/Heure dans lequel vous souhaitez toujours enregistrer la date à laquelle l’enregistrement a été ajouté, vous pouvez entrer « Date() » (sans les guillemets) comme valeur par défaut.

Obligatoire

Cette propriété définit si une valeur est requise dans ce champ. Si vous définissez cette propriété sur Oui,Access ne vous autorise pas à ajouter un nouvel enregistrement, sauf si une valeur est entrée pour ce champ.

Haut de la page

Copier les données d’une autre source dans une table Access

Si vos données sont actuellement stockées dans un autre programme, tel qu’Excel, vous pouvez les copier et les coller dans une table Access. En règle générale, cela fonctionne mieux si vos données sont déjà séparées en colonnes, comme dans une feuille de calcul Excel. Si vos données sont dans un programme de traitement de texte, il est préférable de séparer les colonnes de données à l’aide d’onglets, ou de convertir les données en tableau dans le programme de traitement de texte avant de copier les données. Si vos données ont besoin d’une modification ou d’une manipulation (par exemple, séparant les noms complets en prénoms et noms), vous pouvez le faire avant de copier les données, en particulier si vous n’êtes pas familiarisé avec Access.

Lorsque vous collez des données dans une table vide, Access définit le type de données de chaque champ en fonction du type de données qu’il y trouve. Par exemple, si un champ ne contient que des valeurs de date, Access applique le type de données Date/heure à ce champ. Si le champ ne contient que les mots « oui » et « non », Access applique le type de données Oui/Non au champ.

Access nomme les champs en fonction de ce qu’il trouve dans la première ligne de données passées. Si le type de la première ligne de données est semblable à celui des lignes qui suivent, Access détermine que la première ligne fait partie des données et affecte les noms génériques aux champs (F1, F2, etc.). Si la première ligne de données ne ressemble pas aux lignes qui suivent, Access détermine que la première ligne se compose des noms de champs. Access nomme les champs en conséquence et n’inclut pas la première ligne dans les données.

Si Access affecte des noms de champs génériques, vous devez renommer les champs dès que possible afin d’éviter toute confusion. Procédez comme suit :

  1. Appuyez sur Ctrl+S pour enregistrer la table.

  2. En mode Feuille de données, double-cliquez sur chaque en-tête de colonne, puis tapez un nom de champ descriptif pour chaque colonne.

  3. Enregistrez de nouveau la table.

Remarque : Vous pouvez également renommer les champs en bas de l’affichage Création et en éditant les noms des champs. Pour basculer en mode Création, cliquez avec le bouton droit sur la table dans le volet de navigation, puis cliquez sur Mode Création. Pour revenir en mode Feuille de données, double-cliquez sur la table dans le volet de navigation.

Haut de la page

Importer, importer ou lier des données d’une autre source

Il se peut que vous stockiez des données dans un autre programme et que vous vouliez importer ces données dans une nouvelle table ou les y renvoyer à une table existante dans Access. Vous pouvez également travailler avec des personnes qui conservent leurs données dans d’autres programmes et vous souhaitez les travailler dans Access en faisant un lien vers celles-ci. Dans les deux cas, Access facilite le travail avec les données provenant d’autres sources. Vous pouvez importer des données à partir d’une feuille de calcul Excel, d’une table d’une autre base de données Access, d’une liste SharePoint ou de diverses autres sources. Le processus que vous utilisez diffère légèrement selon la source, mais la procédure suivante vous permettra de commencer.

  1. Dans Access, sous l’onglet Données externes, dans le groupe Importer & Lier, cliquez sur la commande du type de fichier que vous importez.

    Groupe Importer et lier sous l’onglet Données externes

    Par exemple, si vous importez des données à partir d’une feuille de calcul Excel, cliquez sur Excel. Si vous ne voyez pas le type de programme dont vous avez besoin, cliquez sur Plus.

    Remarque : Si vous ne trouvez pas le type de format correct dans le groupe Importer un lien &, vous derez peut-être démarrer le programme dans lequel vous avez initialement créé les données, puis utiliser ce programme pour enregistrer les données dans un format de fichier commun (par exemple, fichier texte délimité ) avant de pouvoir importer ces données dans Access.

  2. Dans la boîte de dialogue Données externes, cliquez sur Parcourir pour rechercher le fichier de données source, ou tapez le chemin d’accès complet du fichier de données sources dans la zone Nom de fichier.

  3. Cliquez sur l’option de votre choix (tous les programmes vous la laissent importer et d’autres vous la définissent pour l’importation ou la liaison) sous Spécifier comment et où stocker les données dans la base de données actuelle. Vous pouvez créer une table qui utilise les données importées ou (avec certains programmes) vous pouvez y associer une table existante ou créer une table liée qui conserve un lien vers les données dans le programme source.

  4. Si un Assistant démarre, suivez les instructions des pages suivantes de l’Assistant. Sur la dernière page de l’Assistant, cliquez sur Terminer.

    Si vous importez des objets ou liez des tables à partir d’une base de données Access, la boîte de dialogue Importer des objets ou Lier des tables s’affiche. Choisissez les éléments de votre choix, puis cliquez sur OK.

    Le processus exact dépend du fait que vous choisissez d’importer, d’y associer des données ou d’y associer des données.

  5. Access vous demande si vous souhaitez enregistrer les détails de l’opération d’importation que vous voulez terminer. Si vous pensez que vous effectuerez à nouveau cette opération d’importation à l’avenir, cliquez sur Enregistrer les étapes d’importation, puis entrez les détails. Vous pouvez ensuite répéter l’opération facilement à l’avenir en cliquant sur importations enregistrées Image du boutondans le groupe Importer & lier sous l’onglet Données externes. Si vous ne voulez pas enregistrer les détails de l’opération, cliquez sur Fermer.

Si vous choisissez d’importer une table, Access importe les données dans une nouvelle table, puis affiche la table sous le groupe Tables dans le volet de navigation. Si vous choisissez d’ajouter des données à une table existante, les données y sont ajoutées. Si vous choisissez de lier des données, Access crée une table liée sous le groupe Tables du volet de navigation.

Haut de la page

Ajouter un élément d’application

Vous pouvez utiliser un élément d’application pour ajouter des fonctionnalités à une base de données existante. Un élément d’application peut être aussi simple qu’une seule table, ou il peut comprendre plusieurs objets associés, tels qu’une table et un formulaire lié.

Par exemple, la partie application Commentaires se compose d’une table avec un champ d’ID NuméroAutau, un champ de date et un champ de mémo. Vous pouvez l’ajouter à n’importe quelle base de données et l’utiliser telle quelle, ou avec une personnalisation minimale.

  1. Ouvrez la base de données à laquelle vous souhaitez ajouter un élément d’application.

  2. Cliquez sur l’onglet Créer.

  3. Dans le groupe Modèles, cliquez sur Composants d’application. La liste des composants disponibles s’ouvre.

  4. Cliquez sur le partie de l’application à ajouter.

Haut de la page

Ouvrir une base de données Access existante

  1. Sous l’onglet Fichier, cliquez sur Ouvrir.

  2. Dans la boîte de dialogue Ouvrir, accédez à la base de données que vous voulez ouvrir.

  3. Effectuez l’une des actions suivantes :

    • Double-cliquez sur la base de données pour l’ouvrir en mode par défaut spécifié dans la boîte de dialogue Options Access ou mode définie par une stratégie d’administration.

    • Cliquez sur Ouvrir pour ouvrir la base de données afin d’y accéder partagée dans un environnement multi-utilisateur, ce qui vous permet, ainsi qu’à d’autres utilisateurs, de lire la base de données et d’y écrire.

    • Cliquez sur la flèche en regard du bouton Ouvrir, puis cliquez sur Ouvrir en lecture seule pour ouvrir la base de données en lecture seule afin de pouvoir l’afficher, mais pas la modifier. D’autres utilisateurs peuvent toujours lire et écrire dans la base de données.

    • Cliquez sur la flèche en bas du bouton Ouvrir, puis cliquez sur Ouvrir en exclusif pour ouvrir la base de données en utilisant un accès exclusif. Lorsque vous avez une base de données ouverte avec un accès exclusif, toute autre personne qui tente d’ouvrir la base de données reçoit un message « Fichier déjà utilisé ».

    • Cliquez sur la flèche en bas du bouton Ouvrir, puis cliquez sur Ouvrir en lecture seule exclusive pour ouvrir la base de données en lecture seule. D’autres utilisateurs peuvent toujours ouvrir la base de données, mais sont limités en mode lecture seule.

Remarque : Vous pouvez ouvrir directement un fichier de données dans un format de fichier externe, tel que dBASE, Microsoft Exchange ou Excel. Vous pouvez également ouvrir directement tout source de données ODBC, comme Microsoft SQL Server. Access crée automatiquement une nouvelle base de données Access dans le même dossier que le fichier de données, et ajoute des liens vers chaque table de la base de données externe.

Conseils

  • Pour ouvrir l’une des dernières bases de données ouvertes, sous l’onglet Fichier, cliquez sur Récent,puis sur le nom du fichier pour cette base de données. Access ouvre la base de données en utilisant les mêmes paramètres d’option que lors de sa dernière ouverture. Si la liste des derniers fichiers utilisés n’est pas affichée, sous l’onglet Fichier, cliquez sur Options. Dans la boîte de dialogue Options Access, cliquez sur Paramètres du client. Sous Affichage,entrez le nombre de documents à afficher dans la liste Documents récents, jusqu’à un maximum de 50.

    Vous pouvez également afficher les bases de données récentes dans la barre de navigation du mode Backstage, pour un accès en deux clics : 1) l’onglet Fichier, 2) la base de données récente que vous voulez ouvrir. Dans la partie inférieure de l’onglet Récents, cochez la case Accéder rapidement à ce nombre de bases de données récentes, puis ajustez le nombre de bases de données à afficher.

  • Si vous ouvrez une base de données en cliquant sur la commande Ouvrir sous l’onglet Fichier, vous pouvez afficher la liste des raccourcis vers les bases de données que vous avez précédemment ouvertes en cliquant sur Mes documents récents dans la boîte de dialogue Ouvrir.

Haut de la page

Besoin d’aide ?

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoindre Microsoft Insider

Ces informations vous ont-elles été utiles ?

Dans quelle mesure êtes-vous satisfait(e) de la qualité de la traduction ?

Qu’est-ce qui a affecté votre expérience ?

Avez-vous d’autres commentaires ? (Facultatif)

Nous vous remercions pour vos commentaires.

×