Importer des données à partir Excel, Access, SharePoint sites externes, SQL Server et d’autres sources externes

Vous pouvez rapidement importer et afficher des données directement sur vos formes dans Visio. La première étape consiste à vous connecter à la source de données et à importer des données dans votre dessin. La deuxième étape consiste à lier les données importées à des formes.

Étape 1 : importer vos données

Dans cette première étape, vous allez utiliser l’Assistant Sélecteur de données pour importer vos données.

Les données qui apparaissent dans la fenêtre Données externes sont un instantané de vos données sources au moment de l’importation. Vous pouvez mettre à jour les données de votre dessin pour qu’elles correspondent aux modifications apportées à vos données sources. En revanche, vous ne pouvez pas actualiser votre source de données en modifiant les données dans votre dessin. Voir Actualiser les données importées.

  1. Sous l’onglet Données, dans le groupe Données externes, cliquez sur Lier des données à des formes.

  2. Dans la première page de l’Assistant Sélecteur de données, choisissez les types de sources de données suivants que vous voulez utiliser :

    • Classeur Microsoft Excel

    • Base de données Microsoft Access

    • Liste Microsoft SharePoint Foundation

    • Base de données Microsoft SQL Server

    • Autre source de données OLEDB ou ODBC

    • Connexion précédemment créée

  3. Terminez le reste de l’Assistant.

    Remarque : Si vous choisissez une option autre qu’un Excel, une base de données Access ou une liste SharePoint sur la première page de l’Assistant, vous pouvez être temporairement redirigé vers l’Assistant Connexion de données au cours de l’exécution de l’Assistant Sélecteur de données.

Après avoir cliqué sur Terminer dans la dernière page de l’Assistant Connexion de données, la fenêtre Données externes apparaît avec vos données importées affichées dans une grille.

Étape 2 : lier des lignes de données à des formes dans votre dessin

Il existe trois méthodes pour lier des lignes de données à des formes dans votre dessin : vous pouvez lier des lignes à des formes existantes une par une, vous pouvez lier les lignes à des formes automatiquement ou vous pouvez créer des formes à partir des données.

Méthode 1 : lier les lignes à des formes existantes une par une

Cette approche est préférable pour des dessins existants avec relativement peu de formes.

  • Faites glisser une ligne de la fenêtre Données externes vers une forme de votre dessin.

    Remarque : Si vous ne voyez pas la fenêtre Données externes, sous l’onglet Données, dans le groupe Afficher/Masquer, cochez la case en regard de La fenêtre Données externes.

    Vos données apparaissent dans la forme et une icône de lien apparaît à gauche de la ligne dans la fenêtre Données externes.

    Faire glisser une ligne sur une forme

    Remarques : 

    • Vous pouvez lier une seule ligne à plusieurs formes, mais vous ne pouvez pas lier plusieurs lignes à une seule forme.

    • Pour modifier ou améliorer l’apparence des formes et des données, voir Améliorer vos données avec des graphiques de données.

    • Pour afficher la fenêtre Données externes, dans le menu Affichage, cliquez sur Fenêtre Données externes.

Méthode 2 : lier automatiquement des lignes à des formes existantes

Cette approche est préférable pour des dessins existants qui comptent un grand nombre de formes. Cela ne fonctionne que si les formes sont déjà insérez des données que vous pouvez faire correspondre aux données de la source de données.

  1. Dans Visio 2016 versions plus récentes : dans le menu Données, cliquez sur Actualiser tout, puis sélectionnez L’application Lien automatique après l’actualisation est cochée, si ce n’est pas déjà fait.

    Dans Visio 2013 versions antérieures : dans le menu Données, cliquez sur Liaison automatique.

  2. Suivez les étapes de l’Assistant Liaison automatique.

    Vos données apparaissent dans vos formes. Pour modifier ou améliorer l’apparence des formes et des données, voir Améliorer vos données avec des graphiques de données.

Méthode 3 : créer des formes à partir de vos données

Cette approche est préférable si votre dessin ne comprend pas déjà des formes et que vous n’avez pas besoin d’utiliser des formes spécifiques.

  1. Cliquez sur une forme dans le volet Formes.

  2. Faites glisser une ligne ou un ensemble de lignes de la fenêtre Données externes vers un espace vide dans votre dessin.

    Une instance de la forme que vous cliquez apparaît pour chaque ligne que vous faites glisser sur le dessin.

Besoin d’aide ?

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×