Importer ou copier la liste de fin automatique sur un autre ordinateur

La liste de complétez automatiquement est une fonctionnalité qui affiche des suggestions de noms et d'adresses de messagerie lorsque vous commencez à les taper. Ces suggestions sont des correspondances possibles provenant d'une liste de noms et d'adresses e-mail provenant des messages électroniques que vous avez envoyés. 

Liste de saisie semi-automatique

La méthode de copie de votre liste decomplet automatique d'un ordinateur à un autre dépend du type de compte de courrier que vous avez ajouté à Outlook. Si vous avez un compteMicrosoft 365, un compte Exchange Server ou un compte IMAP (c'est le type de compte de messagerie le plus courant), la liste de la suppression automatique est stockée en tant que fichier masqué dans votre fichier de données Outlook. Pour obtenir des instructions, voir Copier la liste de la fonction decomplet automatique.

Si vous avez un compte POP3 (moins courant, mais souvent utilisé pour des fournisseurs de messagerie tiers tels que Comcast, Earthlink et Verizon), votre liste de suppressions automatiques est stockée dans un fichier stocké sur votre ordinateur. Voir Copier et importer un fichier .nk2.

Si vous ne savez pas quel type de compte vous avez, sélectionnez Fichier et> paramètres du > du compte. Vous trouverez votre type de compte ici.

Copier la liste de lacomplet automatique

Étape 1 : exporter le message de la boîte aux lettres de la fonction decomplet automatique

  1. Quittez Outlook, puis fermez Outlook Web Access ou Outlook Web App (OWA) sur toutes les stations de travail connectées à votre boîte aux lettres.

  2. Téléchargez et installez MFCMAPI à partir de http://mfcmapi.codeplex.com.

  3. Exécutez mfcmapi.exe.

  4. Dans le menu Session, cliquez sur Ouverture de session.

  5. Si vous êtes invité à choisir un profil, sélectionnez le nom de profil souhaité, puis cliquez sur OK.

  6. Dans le volet supérieur, recherchez la ligne qui correspond à votre boîte aux lettres, puis double-cliquez dessus.

  7. Dans le volet de navigation du côté gauche, développez Conteneurracine, puis développez le haut du magasin d'informations ou du IPM_SUBTREE.

  8. Cliquez avec le bouton droit sur le dossier Boîte de réception, puis cliquez sur Ouvrir la table de contenu associé. Cette action ouvre une nouvelle fenêtre MFCMAPI qui contient différentes propriétés.

  9. Sous la colonne Objet, cliquez avec le bouton droit sur l'élément dont l'objet est IPM.Configl'uration. Autocomplete,and then click Export Message. Cette action ouvre la fenêtre Enregistrer le message dans un fichier.

  10. Dans la liste drop-down, sélectionnez Fichier MSG (UNICODE),puis cliquez sur OK.

  11. Sélectionnez l'emplacement du dossier dans lequel vous voulez enregistrer le message, puis cliquez sur Enregistrer. Notez cet emplacement.

Étape 2 : importer le message de la boîte aux lettres de lacomplet automatique

  1. Quittez Outlook, puis fermez Outlook Web Access ou Outlook Web App (OWA) sur toutes les stations de travail connectées à votre boîte aux lettres.

  2. Téléchargez et installez MFCMAPI à partir de http://mfcmapi.codeplex.com.

  3. Exécutez mfcmapi.exe.

  4. Dans le menu Session, cliquez sur Ouverture de session.

  5. Si vous êtes invité à choisir un profil, sélectionnez le nom de profil souhaité, puis cliquez sur OK.

  6. Dans le volet supérieur, recherchez la ligne qui correspond à votre boîte aux lettres, puis double-cliquez dessus.

  7. Dans le volet de navigation du côté gauche, développez Conteneurracine, puis développez le haut du magasin d'informations ou du IPM_SUBTREE.

  8. Cliquez avec le bouton droit sur le dossier Boîte de réception, puis cliquez sur Ouvrir la table de contenu associé. Cette action ouvre une nouvelle fenêtre MFCMAPI qui contient différentes propriétés.

  9. Pour éviter les entrées en double, vous devez supprimer le message de saisie automatique existant.

    Note : Avant de supprimer l'IPM.Config' uration. Pour ce faire, vous devez exporter le message en suivant les étapes de la section « Exporter le cache de mise à jour automatique ».

    Pour supprimer le message de suppression de lacomplet automatique existant, suivez ces étapes :

    1. Dans la colonne Objet, recherchez l'élément dont l'objet est IPM.Config'uration. Autocomplete.

    2. Cliquez avec le bouton droit sur l'élément, puis cliquez sur Supprimer le message. La fenêtre Supprimer l'élément s'ouvre.

    3. Dans la liste finale, sélectionnez Suppression définitive (suppressionsde la rétention des éléments supprimées si cette suppression est prise en charge), puis cliquez sur OK.

  10. Dans le menu Dossiers, cliquez sur Importer, puis sur À partir de MSG.

  11. Recherchez le fichier .msg que vous avez créé à l'étape 11 du message « Exporter le message de boîte aux lettres de la mise en boîte aux lettres de la fonction de suppression automatique » ci-dessus, puis cliquez sur OK.

  12. Dans la fenêtre Charger MSG qui s'affiche, sélectionnez Charger le message dans le dossier actuel de la liste Des styles de chargement, puis cliquez sur OK.

Les informations de lacomplet automatique sont importées à partir de l'uration IPM.Configautomatique. Autocomplete_<code hexadécimal>.msg, où l'espace réservé<code hexadécimal> représente une longue chaîne de nombres et de lettres.

Copier et importer un fichier .nk2

Étape 1 : copier le fichier de mise à jour automatique de l'ancien ordinateur

  1. Étant donné que le dossier par défaut est masqué, la méthode la plus simple pour l'ouvrir consiste à utiliser la commande %APPDATA%\Microsoft\Outlook dans la zone de recherche de Windows (ou accédez à C:\Utilisateurs \nomd'utilisateur \AppData\Roaming\Microsoft\Outlook).

  2. Dans le dossier Outlook, recherchez votre fichier de liste de recherche automatique (.nk2).

    Remarque : Par défaut, les extensions de fichier sont masquées dans Windows. Pour déterminer si les extensions de fichier sont affichées, dans l'Explorateur de fenêtres du menu Outils (dans Windows 7 ou Windows Vista, appuyez sur la touche Alt pour voir le menu Outils), cliquez sur Optionsdes dossiers. Sous l'onglet Affichage, cochez ou non la case Masquer les extensions des types de fichiers connus.

  3. Copiez le fichier sur le nouvel ordinateur. Le fichier est de petite taille et peut être placé sur un support amovible tel qu'une clé USB.

Étape 2 : copier le fichier de mise à jour automatique sur le nouvel ordinateur

  1. Sur le nouvel ordinateur, dans le Panneau de contrôle, cliquez ou double-cliquez sur Courrier.

    L'affichage Courrier apparaît à différents emplacements du Panneau de gestion selon la version du système d'exploitation Microsoft Windows, l'affichage sélectionné pour le Panneau de gestion et le système d'exploitation 32 ou 64 bits installé ou la version d'Outlook 2010.

    La méthode la plus simple pour localiser l’icône Courrier consiste à ouvrir le Panneau de configuration dans Windows, puis dans la zone Rechercher en haut de la fenêtre, d’entrer Courrier. Dans le Panneau de configuration de Windows XP, entrez Courrier dans le champ Adresse.

    Remarque : L’icône Courrier s’affiche après le premier démarrage d’Outlook.

  2. Cliquez sur Afficher les profils.

  3. Notez le nom du profil. Vous devrez modifier le nom de fichier .nk2 pour qu'il corresponde à celui-ci ultérieurement.

  4. Copiez le fichier .nk2 sur le nouvel ordinateur dans le dossier dans lequel les configurations Outlook sont enregistrées. Étant donné que le dossier par défaut est masqué, la méthode la plus simple pour l'ouvrir consiste à utiliser la commande %APPDATA%\Microsoft\Outlook dans la zone de recherche de Windows (ou accédez à C:\Utilisateurs \nomd'utilisateur \AppData\Roaming\Microsoft\Outlook).

  5. Une fois le fichier copié dans le dossier, cliquez dessus avec le bouton droit, cliquez sur Renommer, puis modifiez le nom pour qu'il corresponde au nom du profil qui apparaît à l'étape 3.

Étape 3 : importer la liste de mise à jour automatique

Vous êtes maintenant prêt à démarrer Outlook et à importer le fichier, mais vous devez le démarrer avec une commande spéciale à une seule heure.

  • Tapez outlook /importnk2 dans la zone de recherche de Windows, puis appuyez sur Entrée.

La liste de saisie complète automatique doit maintenant avoir les entrées de votre autre ordinateur lorsque vous rédigez un message et commencez à taper dans les zones À,Ccou Cci.

Haut de la page

Dans Outlook 2007, vous pouvez copier les noms et adresses de messagerie dans la liste de complétez automatiquement d'un ordinateur à un autre. Par exemple, si vous effectuerez une mise à niveau vers un nouvel ordinateur et que vous ne voulez pas perdre toutes les informations stockées dans la liste de complétation automatique, vous pouvez copier les noms et adresses e-mail de votre ancien ordinateur vers votre nouvel ordinateur.

Important : Vous devez quitter Microsoft Outlook la procédure suivante. Les noms seront inclus dans la liste de complétez automatiquement lorsque vous redémarrez Outlook.

Copier le fichier de complétez automatiquement à partir de l'ancien ordinateur

  1. Sur votre ancien ordinateur, allez sur lecteur:\utilisateur\AppData\Local\Microsoft\Outlook.

    Remarque : Selon les paramètres de votre fichier, ce dossier peut être masqué.

  2. Cliquez avec le bouton droit sur nom du profil.nk2, puis cliquez sur Copier.

    Conseil : Vous pouvez copier le fichier sur un support amovible (par exemple, une clé USB), puis le copier à l'emplacement correct sur votre nouvel ordinateur. Vous pouvez également joindre le fichier à un courrier électronique et vous l'envoyer vous-même. Sur le nouvel ordinateur, ouvrez la pièce jointe dans Outlook, puis enregistrez-la à l'emplacement correct.

  3. Sur l'ordinateur où vous voulez remplir la liste de complétez la liste de complétez automatiquement, cliquez avec le bouton droit n'importe où dans lecteur:\user\AppData\Local\Microsoft\Outlook, puis cliquez sur Coller pour enregistrer le nom du profil.nk2.

  4. Si le nom du profil utilisateur Outlook est différent sur l'ordinateur sur lequel vous déplacer le fichier .nk2, vous devez renommer le fichier avec le nom de profil utilisateur Outlook utilisé sur le nouvel ordinateur, après avoir copié le fichier dans le dossier approprié. Par exemple, si vous déplacez Kim Akers.nk2 de l'ordinateur d'origine avec le nom de profil utilisateur Outlook de Kim Akers et que vous copiez le fichier Kim Akers.nk2 sur le nouvel ordinateur, vous devez renommer le fichier avec le nom de profil Outlook utilisé sur le nouvel ordinateur.

  5. Lorsque vous y est invité à remplacer le fichier existant, cliquez sur Oui.

  6. Ouvrez Outlook pour afficher les modifications apportées à la liste de fin automatique.

Haut de la page

Besoin d’aide ?

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×