Lorsque vous traitez des fonctions de matrice renversées, telles que SEQUENCE,il est possible de référencer la plage de spill entière en plaçant l’opérateur de plage renversé (#) après la plage. Dans l’exemple suivant, nous avons =SEQUENCE(10) dans la cellule A2, qui se répande à A2:A11. Dans la cellule C2, nous avons la formule =SOMME(A2#), qui est l’équivalent de =SOMME(A2:A11), car A2:A11 est la plage de spill de la formule dans A2. Cette valeur renvoie 55, soit la somme de toutes les valeurs de la plage de matrice renversée.

Si la plage de spill augmente ou s’agrandit, par exemple en modifiant la formule dans A2 en =SEQUENCE(20), la formule SOMME reflète automatiquement cela. S’il s’agissait d’une plage normale, entrez =SOMME(A2:A11) et mettez-la à jour manuellement si la plage de débordement change. Souvent, il se peut que vous ne vous rendiez pas compte du changement d’une plage, ce qui peut supprimer beaucoup de travail d’estimation.

Opérateur de plage renversé pour référencer des plages de tableaux entiers renversés avec =SOMME(A2#).

Voici un autre exemple d’utilisation de l’opérateur de plage renversé dans plusieurs formules, dans laquelle nous créons une liste unique à partir d’une liste de noms, trions la liste, puis filtré les noms de plus de 3 caractères. =TRIER(C2#) dans la cellule E2 et =FILTRE(C2#;LEN(C2#)>3) dans la cellule G2.

Opérateur de plage renversé (#) pour référencer une plage de matrice étendue entière avec =FILTRE(C2#;LEN(C2#)>3)

Limitations connues

L’opérateur de plage renversé ne prend pas en charge les références aux livres fermés. Au lieu de cela, il retourne un #REF! valeur d’erreur. L’ouverture du workbook référencé résout le problème.

Vous avez besoin d’une aide supplémentaire ?

Vous pouvez toujours consulter un expert de la communauté technique Excel ou obtenir une assistance dans la communauté Answers.

Voir aussi

Fonction FILTRE

Fonction TABLEAU.ALEAT

Fonction SEQUENCE

Fonction TRI

Fonction TRIERPAR

Fonction UNIQUE

#SPILL ! erreurs dans Excel

Les tableaux dynamiques et le comportement de matrice dispersé

Opérateur d'intersection implicite : @

Besoin d’aide ?

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoindre Microsoft Office insiders

Ces informations vous ont-elles été utiles ?

Dans quelle mesure êtes-vous satisfait(e) de la qualité de la langue ?
Qu’est-ce qui a affecté votre expérience ?

Nous vous remercions de vos commentaires.

×