Prise en main de Obtenir et Transformer dans Excel

Remarque : Cet article a fait son temps et sera bientôt supprimé. Pour éviter les problèmes du type « Page introuvable », nous allons supprimer les liens inutiles. Si vous avez créé des liens vers cette page, nous vous conseillons de les supprimer afin de ne pas désorienter les utilisateurs.

Avec Récupérer & transformer dans Excel, vous pouvez rechercher des sources de données, établir des connexions, puis mettre en forme ces données (par exemple, supprimer une colonne, modifier un type de données ou fusionner des tables) d’une manière qui répond à vos besoins. Lorsque vous aurez mis en forme vos données, vous pourrez partager vos conclusions ou utiliser votre requête pour créer des rapports.

La connexion à des données et leur transformation dans Excel en 4 étapes : 1 - Connecter, 2 - Transformer, 3 - Combiner et 4 - Gérer.

Si nous prenons les étapes dans l’ordre, la séquence est souvent similaire à ce qui suit :

  • Connecter : créez des connexions entre des données stockées dans le cloud, dans un service ou en local.

  • Transformer : mettez en forme les données en fonction de vos besoins ; la source d’origine reste intacte.

  • Combiner : créer un modèle de données à partir de plusieurs sources de données et obtenir une vue unique des données

  • Gérer : une fois votre requête terminée, vous pouvez l’enregistrer, la copier ou l’utiliser pour les rapports

Chaque fois que vous vous connectez à des données, que vous les transformez ou les combinez avec d’autres sources de données, une fonctionnalité de Récupérer & Transformer appelée Éditeur de requête enregistre chaque étape et vous permet de la modifier comme vous le souhaitez. L’Éditeur de requête vous permet également d’annuler, de refaire, de modifier l’ordre ou de modifier une étape... afin de pouvoir modeler l’affichage des données connectées comme vous le souhaitez.

L'& Transformervous permet de créer des requêtes simples ou complexes selon vos besoins. Lorsque vous ajoutez des étapes à une requête, l’Éditeur de requête travaille en arrière-plan pour créer un ensemble d’instructions distinctes qui effectuent vos commandes. Ces instructions sont créées dans la langue M. Les utilisateurs qui profitent de la puissance et de la flexibilité de l’écriture de scripts de données peuvent créer ou modifier manuellement des requêtes en langage M à l’aide de l’Éditeur avancé.L’Éditeur de requête et l’Éditeur avancé sont décrits plus en détail plus loin dans cet article.

Vous pouvez commencer une nouvelle requête à partir de l’onglet Données > obtenir des > une source de données. Si vous ne voyez pas le bouton Obtenir des données, sélectionnez le bouton Nouvelle requête dans l’onglet Données. Voici un exemple d’utilisation d’une source de base de données.

Options Récupérer & transformer à partir d’une base de données

Remarque : Power Query est également disponible pour les versions précédentes d’Excel en tant que add-in,ainsi que pour Power BI. Pour voir Power Query en action dans les versions précédentes d’Excel, voir La mise en place de Power Query.

Connecter

Vous pouvez utiliser une requête pour vous connecter à une seule source de données, telle qu’une base de données Access, ou à plusieurs fichiers, bases de données, flux OData ou sites web. Vous pouvez ensuite rassembler toutes ces sources à l’aide de vos propres combinaisons et découvrir des perspectives que vous n’a pourriez pas autrement vus.

Lorsque vous sélectionnez Obtenir des données à partir de la section Récupérer & transformer sous l’onglet Données (ou Nouvelle requête si vous ne voyez pas le bouton Obtenir des données), vous avez le choix entre de nombreuses sources de données, notamment des fichiers tels que des fichiers Excel tels que des fichiers Excel tels que des fichiers Texte/CSV,des bases de données telles qu’Access,SQL Server,Oracleet MySQL,des services Azure tels que HDInsight ou Blob Storage,et toutes sortes d’autres sources telles que le web,les listes SharePoint,les fichiers Hadoop,Facebook,Salesforce,etc.

Remarque : Vous pouvez en savoir plus sur les sources de données disponibles dans les versions d’Excel ici : Où trouver l'& transformer (Power Query).

Lorsque vous vous connectez à une source de données, Récupérer & Transformer affiche un volet navigateur, qui vous permet de modifier les données de sa source. Lorsque vous sélectionnez Modifier dans la fenêtre navigateur, Récupérer & Transformer lance l’Éditeur de requête,qui est une fenêtre dédiée qui facilite et affiche vos connexions de données et les transformations que vous appliquez. La section suivante, Transformer,fournit des informations supplémentaires sur l’Éditeur de requête.

Transformer

Obtenir & Transformer vous permet de transformer les données à partir de vos sources de données de façon à vous aider à les analyser. Transformer des données signifie les modifier pour répondre à vos besoins, par exemple, via une suppression de colonne, la modification d’un type de données ou la fusion de tables. Lorsque vous transformez des données, ces dernières prennent collectivement la forme dont vous avez besoin pour approfondir votre analyse. Le processus d’application de transformations à un ou plusieurs jeux de données est souvent appelé mise en forme des données.

Excel utilise un Éditeur de requête dédié pour faciliter et afficher les transformations de données. Lorsque vous sélectionnez Données > Obtenir des données,puis sélectionnez la source de données, telle qu’un fichier ou une base de données, la fenêtre du navigateur apparaît pour vous aider à sélectionner la ou les tables à utiliser dans votre requête. Lorsque vous sélectionnez une table, un aperçu de ses données s’affiche dans le volet droit de la fenêtre du Navigateur.

Obtenir & transformer > volet de navigation Power Query

Si vous sélectionnez Charger,la source de données est directement mise en place dans Excel telle qu’elle est. Si vous sélectionnez l’option Transformer les données, l’Éditeur de requête s’lancera.

Volet Éditeur de Power Query

L’Éditeur de requête suit toutes les choses que vous faites avec les données. L’Éditeur de requête enregistre et étiquette chaque transformation (ou étape) que vous appliquez aux données. Que la transformation s’applique à une connexion à une source de données, à la suppression d’une colonne, d’une fusion ou d’une modification de type de données, l’Éditeur de requête suit chaque opération dans la sectionÉtapes appliquées du volet Paramètres d’une requête.

Les transformations que vous appliquez à vos connexions de données forment collectivement votre requête.

Il est important de savoir que les actions que vous définissez dans l’Éditeur de requête ne modifient pas les données sources d’origine. Au lieu de cela, Excel enregistre chaque étape que vous prenez lors de la connexion ou de la transformation des données, et une fois que vous avez terminé de mettre en forme les données, il prend un instantané du jeu de données affiné et l’apporte dans le feuille de calcul.

Vous pouvez appliquer de nombreuses transformations aux données. Vous pouvez également écrire vos propres transformations à l’aide du langage M avec l’Éditeur avancé de l’Éditeur de requête. Vous pouvez ouvrir l’Éditeur avancé à partir des onglets Accueil ou Affichage de l’Éditeur de requête, où vous pouvez modifier les étapes de langage M associées à la requête existante, ou créer la vôtre.

Volet Éditeur avancé de Power Query avec modification de la langue M

Une fois que vous avez créé votre requête, vous pouvez sélectionner Fermer & Charger à partir de l’onglet Accueil. Les résultats de la requête sont chargés dans Excel et disponibles dans un nouvel onglet de fichier.

En savoir plus sur l’étape Transformer :

Gérer

Lorsque vous enregistrez un feuille de calcul Excel contenant une requête, celle-ci est également enregistrée automatiquement. Vous pouvez afficher toutes les requêtes d’un feuille de calcul Excel en sélectionnant Requêtes & Connexions sous l’onglet Données.

Volet Requêtes et connexions Power Query

Si vous cliquez avec le bouton droit sur un nom de requête dans le volet & Connexions, plusieurs options s’offrent à vous. Par exemple, vous pouvez dupliquer une requête, ce qui vous permet de modifier certains ou tous les éléments d’une requête sans modifier la requête d’origine. c’est comme la création d’un modèle de requête que vous pouvez ensuite modifier pour créer des jeux de données personnalisés ( par exemple, un jeu de données pour le commerce au détail, un autre pour la vente en gros et un autre pour l’inventaire), tous basés sur les mêmes connexions de données.

Vous pouvez fusionner ou modifier des requêtes afin de convertir les requêtes en blocs de construction réutilisables.

Options du menu & avec le bouton droit de Connexions

Vous pouvez également publier votre manuel dans Power BI et créer des rapports en ligne qui peuvent être partagés avec votre groupe, actualisés automatiquement et affinés. Pour publier un classez dans Power BI, sélectionnez Fichier > Publier > sur Power BI.

Remarque : Votre workbook doit être enregistré dans OneDrive Entreprise pour être publié dans Power BI.

En savoir plus sur la gestion de vos requêtes :

Vous avez besoin d’une aide supplémentaire ?

Vous pouvez toujours consulter un expert de la communauté technique Excel, obtenir une assistance dans la communauté Answers ou suggérer une nouvelle fonctionnalité ou une amélioration sur le forum Excel User Voice.

Besoin d’aide ?

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×