Tâches de base pour une base de données Access de bureau

Tâches de base pour une base de données Access de bureau

Les bases de données access de bureau peuvent vous aider à stocker et suivre à peu près toutes sortes d’informations, telles que le stock, les contacts ou les processus d’entreprise. Parprenons les chemins d’accès que vous pouvez suivre pour créer une base de données Access de bureau, y ajouter des données, puis découvrir les étapes suivantes pour personnaliser et utiliser votre nouvelle base de données.

Contenu de cet article

Choisir un modèle

Les modèles Access ont des tables, requêtes, formulaires et états intégrés prêts à l’emploi. La première chose que vous remarquerez lors du démarrage d’Access est le choix de modèles. Vous pouvez rechercher d’autres modèles en ligne.

Affichage des modèles sur l’écran de démarrage dans Access

  1. Dans Access, cliquez sur Fichier > Nouveau.

  2. Sélectionnez un modèle de base de données de bureau, puis entrez un nom pour votre base de données sous Nom de fichier.(Si vous ne voyez pas un modèle qui fonctionnerait pour vous,utilisez la zone Rechercher des modèles enligne.)

  3. Vous pouvez utiliser l’emplacement par défaut qu’Access affiche sous la zone Nom de fichier ou cliquer sur l’icône de dossier pour en sélectionner un.

  4. Cliquez sur Créer.

Créer une base de données Access de bureau à partir d’un modèle

Selon le modèle, vous devrez peut-être suivre l’une des déclarations suivantes pour commencer :

  • Si Access affiche une boîte de dialogue Connexion avec une liste vide d’utilisateurs :

    1. Cliquez sur Nouvel utilisateur.

    2. Remplissez le formulaire Détails de l’utilisateur.

    3. Cliquez sur Enregistrer & fermer.

    4. Sélectionnez le nom d’utilisateur que vous ouvrez, puis cliquez sur Connexion.

  • Si Access affiche un message d’avertissement de sécurité dans la barre des messages et que vous faites confiance à la source du modèle, cliquez sur Activer le contenu. Si la base de données nécessite une connexion, connectez-vous à nouveau.

Pour plus d’informations, voir créer une base de données access de bureau à partir d’un modèle.

Créer une base de données entièrement nouvelle

Si aucun des modèles ne correspond à vos besoins, vous pouvez commencer avec une base de données de bureau vide.

  1. Dans Access, cliquez sur Nouveau > de bureau vide.

  2. Tapez un nom pour votre base de données dans la zone Nom de fichier.

  3. Vous pouvez utiliser l’emplacement par défaut qu’Access affiche sous la zone Nom de fichier ou cliquer sur l’icône de dossier pour en sélectionner un.

  4. Cliquez sur Créer.

Ajouter un tableau

Dans une base de données, vos informations sont stockées dans plusieurs tables associées. Pour créer un tableau :

  1. Lorsque vous ouvrez votre base de données pour la première fois, vous voyez une table vide en affichage Feuille de données dans laquelle vous pouvez ajouter des données. Pour ajouter une autre table, cliquez sur l’onglet > Tableau. Vous pouvez commencer à entrer des données dans le champ vide (cellule) ou coller des données d’une autre source telle qu’un feuille de calcul Excel.

  2. Pour renommer une colonne (champ), double-cliquez sur son en-tête, puis tapez le nouveau nom.

Conseil :  Les noms significatifs vous permettent de savoir ce que contient chaque champ sans voir son contenu.

  1. Cliquez sur Fichier > Enregistrer.

  • Pour ajouter d’autres champs, tapez dans la colonne Cliquer pour ajouter.

  • Pour déplacer une colonne, sélectionnez-la en cliquant sur son en-tête de colonne, puis faites-la glisser vers l’endroit voulu. Vous pouvez également sélectionner des colonnes contiguës et les faire glisser toutes vers un nouvel emplacement.

Pour plus d’informations, voir Présentation des tables.

Copier et coller des données

Vous pouvez copier et coller des données d’un autre programme comme Excel ou Word dans une table Access. Cela fonctionne mieux si les données sont séparées en colonnes. Si les données sont dans un programme de traitement de texte, tel que Word, utilisez des balises pour séparer les colonnes ou convertissez-les en format de tableau avant de les copier.

  1. Si les données doivent être modifiées (par exemple, séparer les noms complets en prénoms et noms), faites-le en premier dans le programme source.

  2. Ouvrez la source et copiez (Ctrl+C) les données.

  3. Ouvrez la table Access dans laquelle vous voulez ajouter les données en vue Feuille de données et collez-les (Ctrl+V).

  4. Double-cliquez sur chaque en-tête de colonne et tapez un nom significatif.

  5. Cliquez sur Fichier > enregistrer et donner un nom à votre nouvelle table.

    Remarque :  Access définit le type de données de chaque champ en fonction des informations que vous collez dans la première ligne de chaque colonne. Assurez-vous donc que les informations des lignes suivantes correspondent à la première ligne.

Importer ou lier des données

Vous pouvez importer des données à partir d’autres sources ou lier ces données à partir d’Access sans déplacer les informations à partir de l’endroit où elles sont stockées. La création d’une liaison peut être une bonne option si plusieurs utilisateurs mettent à jour les données et que vous voulez vous assurer que vous voyez la dernière version ou si vous voulez économiser de l’espace de stockage. Vous pouvez choisir de lier ou d’importer des données pour la plupart des formats. Pour plus d’informations, voir Importer ou lier des données d’une autre base de données Access.

Options de l’onglet Données externes dans Access

Le processus diffère légèrement selon la source de données, mais ces instructions vous indiquéront de commencer :

  1. Sous l’onglet Données externes, cliquez sur le format de données à partir de ou vers qui vous souhaitez établir une liaison. Si vous ne voyez pas le format qui vous plaît, cliquez sur Plus.

Remarque :  Si vous ne trouvez toujours pas le format qui vous semble exact, vous devrez peut-être d’abord exporter les données dans un format de fichier qu’Access prend en charge (par exemple, un fichier texte délimité ).

  1. Suivez les instructions de la boîte de dialogue Données externes.

Lorsque vous liez un lien, certains formats sont disponibles en lecture seule. Voici les sources externes à partir des quelles vous pouvez importer des données ou établir une liaison :

Importer

Lier

Microsoft Excel

Oui

Oui
(lecture seule)

Microsoft Access

Oui

Oui

Bases de données ODBC, telles que SQL Server

Oui

Oui

Fichiers texte ou CSV

Oui

Oui
(ajouter de nouveaux enregistrements uniquement)

Liste SharePoint

Oui

Oui

XML

Oui

Services de données

Oui
(lecture seule)

Document HTML

Oui

Oui

Dossier Outlook

Oui

Oui

Pour plus d’informations, voir Importer ou lier des données d’une autre base de données Access.

Organiser des données avec l’Analyseur de table

Vous pouvez utiliser l’Assistant Analyse de table pour identifier rapidement des données redondantes. L’Assistant offre ensuite un moyen simple d’organiser les données au moyen de tables distinctes. Access conserve la table d’origine en tant que sauvegarde.

  1. Ouvrez la base de données Access qui contient la table que vous voulez analyser.

  2. Cliquez sur Outils de base de > pour analyser la table.

    Les deux premières pages de l’Assistant contiennent un bref didacticiel contenant des exemples. Si vous voyez une case à cocher libellée Afficher les pages d’introduction ?Cochez la case, puis cliquez deux fois sur Retour pour afficher l’introduction. Si vous ne voulez plus afficher les pages d’introduction, décochez l’tion Afficher les pages d’introduction ?

Haut de la page

Étapes suivantes

Le reste du processus de création varie en fonction de ce que vous voulez faire, mais vous souhaitez probablement créer des requêtes, formulaires, états et macros. Les articles suivants peuvent vous aider :

Haut de la page

Besoin d’aide ?

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×