Travailler hors connexion sur des tables liées à des listes SharePoint

Vous pouvez utiliser Access pour travailler en mode hors connexion avec des données liées à des listes SharePoint. Cela peut être utile, par exemple, si vous devez vous absenter du bureau ou continuer à travailler quand un serveur n’est pas disponible ou si vous avez perdu des connexions au serveur.

Vue d’ensemble

Avant de travailler en mode hors connexion avec des données d’un site SharePoint, vous devez d’abord créer des liens entre les tables Access et les listes SharePoint. Vous pouvez ensuite mettre les listes hors connexion pour les mettre à jour ou les analyser à l’aide d’Access. Lorsque vous vous reconnectez, vous pouvez synchroniser les données afin que la base de données et les listes soient mises à jour. Si votre base de données contient des requêtes et des états, vous pouvez les utiliser pour analyser les données liées.

Si vous mettez à jour des données lorsque vous êtes en mode hors connexion, vous pouvez synchroniser vos modifications lorsqu’Access se connecte de nouveau au serveur. Si des conflits de données surviennent (par exemple, si quelqu’un met à jour un enregistrement sur le serveur pendant qu’une autre personne met à jour le même enregistrement hors connexion), vous pouvez résoudre le conflit lors de la synchronisation.

Vous pouvez lier des tables Access à des listes à l’aide de plusieurs méthodes. Par exemple, vous pouvez déplacer votre base de données vers un site SharePoint, qui lie également les tables de la base de données aux listes sur le site. Vous pouvez également exporter des données à partir d’une liste en vue Feuille de données sur un site SharePoint vers une table Access. Par exemple, vous pouvez utiliser un état dans Access pour synthétiser les données. Pour plus d’informations sur la liaison de données SharePoint à partir d’Access, voir Importer ou lier des données dans une liste SharePoint.

Travailler en mode hors connexion avec des listes SharePoint dans Access

Depuis Access 2010, travailler hors connexion avec des listes SharePoint liées est davantage un processus automatique mis à jour par Access. Si Access ne peut pas se connecter au site SharePoint où se trouvent vos listes SharePoint liées, peut-être parce que vous avez perdu la connectivité Internet, Access bascule en mode hors connexion. Dans la barre d’état dans le côté inférieur droit de la fenêtre Access, un message s’insérez pour vous dire que toutes les tables SharePoint sont déconnectées. Si vous cliquez sur Fichier > Informations, un message similaire s’affiche indiquant que vous avez déconnecté des tables. Lorsque vous êtes en mode hors connexion, vous pouvez continuer à ajouter, modifier et supprimer des données dans une copie locale mise en cache des données de la liste SharePoint.

Access continue d’essayer de se reconnecter à intervalles réguliers avec les listes liées sur le serveur SharePoint. Une fois qu’Access a rétabli une connexion au site SharePoint, une barre des messages s’dessous du ruban vous demandant si vous voulez synchroniser vos données hors connexion avec le serveur.

Cliquez sur Synchroniser pour vous reconnecter au serveur SharePoint.

Cliquez sur Synchroniser et Access se reconnecte aux listes SharePoint liées, puis tente de fusionner les modifications apportées aux données.

Résolution des modifications conflictuelles des données

Un conflit survient lorsque deux utilisateurs modifient la même partie des données ou structures d’une liste. L’utilisateur qui envoie une modification en premier réussit à soumettre ses modifications, mais le second utilisateur est informé d’un conflit.

Par exemple, l’utilisateur A modifie la colonne City de la troisième ligne de Dallas à Seattle, et en même temps, vous changez la cellule de Dallas en Houston. Les modifications de l’utilisateur A sont d’abord soumises au serveur, suivies de vos modifications. Le serveur vous informe d’un conflit et vous permet de le résoudre.

Remarque : Un conflit se produira même lorsque les utilisateurs modifient différentes cellules dans la même ligne.

Vous ne pourrez pas apporter de modifications à un enregistrement qui présente un conflit tant que le conflit n’a pas été résolu.

Si Access détecte des conflits de données lors de la synchronisation de vos modifications hors connexion avec le serveur SharePoint, la boîte de dialogue Résoudre les conflits apparaît.

Utilisez les options disponibles dans la boîte de dialogue Résoudre les conflits pour résoudre les conflits de données.

Effectuez l’une des opérations suivantes :

  • Pour résoudre le conflit ou l’erreur affiché en ignorant les modifications que vous avez apportées à l’enregistrement, cliquez sur Ignorer mes modifications. Vos modifications seront perdues.

  • Pour résoudre tous les conflits et erreurs en attente en ignorant toutes les modifications apportées à la liste, cliquez sur Ignorer toutes mes modifications.

  • Pour résoudre le conflit ou l’erreur affiché(s) en réappliquant sur vos modifications, cliquez sur Réessayer mes modifications. En cas de conflit, si l’autre utilisateur et vous modifiez la même colonne, vos modifications complètent les modifications apportées par l’autre utilisateur. Si vous modifiez des colonnes différentes, vos modifications seront fusionnées avec les modifications de l’autre utilisateur.

  • Pour résoudre tous les conflits et erreurs en attente en réappliquant vos modifications, cliquez sur Réessayer toutes mes modifications.

  • Pour afficher les détails du conflit ou de l’erreur suivant(s), cliquez sur Suivant dans le coin supérieur droit de la boîte de dialogue.

  • Pour afficher les détails de l’erreur ou du conflit précédent, cliquez sur Précédent dans le coin supérieur droit de la boîte de dialogue.

  • Pour résoudre les conflits et erreurs ultérieurement, cliquez sur Fermer dans la barre de titre de la boîte de dialogue.

Remarques

  • La grille de détails affiche toutes les colonnes dans votre affichage actuel. Si les colonnes ne sont pas visibles, utilisez la barre de défilement horizontale pour faire défiler la page ou faites glisser le bord droit de la boîte de dialogue pour augmenter la largeur de la grille de détails.

    Pour effectuer un zoom sur le contenu d’une colonne, cliquez sur la colonne dans la grille de détails. Vos modifications et les modifications de l’autre utilisateur s’afficheront dans la boîte de dialogue Détails du champ. La boîte de dialogue est également utile pour afficher les modifications apportées à la mise en forme du texte enrichi.

  • La grille Détailsaffiche la ligne supprimée, au lieu d’une ligne de données, si vous ou l’autre utilisateur supprimez une ligne. Si l’autre utilisateur supprime la ligne, la boîte de dialogue n’affiche pas le nom de l’utilisateur, ni la date et l’heure de la suppression. Par ailleurs, vous ne pourrez pas réessayer de modifier vos modifications.

Définition de l’option Mise en cache des tables SharePoint et du service web

Le paramètre par défaut pour les nouvelles bases de données dans Access 2010 et les versions ultérieures consiste à mettre en cache le service web et les tables liées SharePoint. Si vous voulez modifier ce comportement et utiliser le comportement qui existe dans Access 2007, cliquez sur Fichier > Options pour ouvrir la boîte de dialogue Options Access. Cliquez sur Base de données actuelle pour voir les paramètres répertoriés sous les tables Caching Web Service et SharePoint.

  • Utiliser le format de cache compatible avec Microsoft Access 2010 et ultérieur Activez cette option pour qu’Access mette en cache une copie locale des données liées. Ce paramètre peut améliorer les performances dans le cadre de l’utilisation des données liées. Le chargement et l’affichage des données liées seront plus rapides en utilisant cette option. Désactivez cette option si vous voulez utiliser le comportement de mise en cache qui existait dans Access 2007.

  • Vider le cache lors de la fermeture Activez cette option pour qu’Access efface les données mises en cache locales de la mémoire lorsque vous fermez votre base de données.

  • Ne jamais mettre en cache Activez cette option pour qu’Access ne mette pas en cache une copie locale des données dans le cadre de l’utilisation de vos sources de données SharePoint liées.

    Remarque : Les options Vider le cache lors de la fermeture et Ne jamais mettre en cache ne sont pas disponibles si vous désactivez le paramètre Utiliser le format de cache compatible avec Microsoft Access 2010 et ultérieur.

Puis-je travailler manuellement en mode hors connexion dans Access 2010 ou une édition supérieure ?

Pour contrôler manuellement le travail en mode hors connexion avec des données SharePoint liées dans Access 2010 et version ultérieure, vous devez effacer le format de cache compatible avec Microsoft Access 2010 et version ultérieure pour la base de données actuelle trouvée dans la boîte de dialogue Options Access. Consultez la section précédente pour savoir comment trouver et définir cette option.

Remarque : Vous pouvez être invité à fermer et à ré-ouvrir votre base de données après avoir changé le paramètre.

Une fois que vous avez effacé le format de cache compatible avec les paramètres Microsoft Access 2010 et ultérieurs, un groupe de commandes Listes liées au web apparaît sous l’onglet Données externes.

Dans ce groupe, vous verrez des commandes telles que Travailler en mode hors connexion,Synchroniser,Dissocier des listes et d’autres. Il s’commandes de la même manière que dans Access 2007, dans le groupe Listes SharePoint, sous l’onglet Données externes.

Pour travailler en mode hors connexion avec les données de votre liste SharePoint dans ce mode, cliquez sur Travailler en mode hors connexion.

Pour synchroniser vos listes hors connexion avec les données du serveur, cliquez sur Synchroniser.

Pour reconnecter les tables liées après avoir travaillé en mode hors connexion, cliquez sur Work Online.

Haut de page

Vous utilisez Access 2007 ?

Pour effectuer cette procédure, vous devez d’abord lier vos tables Access à des listes SharePoint.

Remarque : Si vous avez une base de données déjà publiée sur un site SharePoint, vous devez d’abord enregistrer une copie locale de la base de données, puis prendre les listes en mode hors connexion.

  1. Ouvrez la base de données liée à des listes SharePoint.

  2. Sous l’onglet Données externes, dans le groupe Listes SharePoint, cliquez sur Travailler en mode hors connexion.

Remarque : Si le bouton Travailler en mode hors connexion n’est pas disponible, vos tables ne sont pas liées à des listes SharePoint ou vous avez déjà pris les données de la liste en mode hors connexion.

  1. Ouvrez la base de données liée à vos listes SharePoint.

  2. Sous l’onglet Données externes, dans le groupe Listes SharePoint, cliquez sur Synchroniser.

Si un conflit se produit à la suite d’une modification que vous avez en mode hors connexion et d’une modification qu’une personne a apporté sur le serveur, la boîte de dialogue Résoudre les conflits s’affiche.

La boîte de dialogue affiche des informations sur le conflit, telles que la raison pour laquelle l’erreur s’est produite, et vous propose des options pour essayer de remettre les données à nouveau ou d’ignorer vos modifications. En cas d’erreur multiple, vous pouvez afficher les détails de chaque erreur en cliquant sur les boutons Précédent et Suivant dans la boîte de dialogue. Certaines erreurs ne peuvent être résolues qu’en ignorer les modifications.

La grille de détails de la boîte de dialogue Résoudre les erreurs affiche toutes les colonnes dans votre affichage actuel. Pour la ligne concernée, la grille de détails affiche les changements apportés. Vous ne pouvez pas modifier les valeurs, mais vous pouvez cliquer sur chaque colonne pour voir plus de détails.

  • Dans la boîte de dialogue Résoudre les erreurs, faites l’une des procédures suivantes :

    • Si vous souhaitez conserver les modifications apportées sur le serveur à un élément sélectionné, cliquez sur Ignorer mes modifications.

    • Si vous voulez réessayer d’envoyer vos modifications à un élément sélectionné, cliquez sur Réessayer mes modifications.

      Selon le cas, vous devrez peut-être patienter jusqu’à la résolution du problème. Par exemple, si vous ne pouvez pas synchroniser vos modifications en raison d’un problème de connectivité réseau, attendez que vous vous connectiez de nouveau.

    • Si vous souhaitez conserver les modifications apportées sur le serveur à tous les éléments, cliquez sur Ignorer toutes mes modifications.

    • Si vous voulez réessayer d’envoyer vos modifications à tous les éléments, cliquez sur Réessayer toutes mes modifications.

      Selon le cas, vous devrez peut-être patienter jusqu’à la résolution du problème. Par exemple, si vous ne pouvez pas synchroniser vos modifications en raison d’un problème de connectivité réseau, attendez que vous vous connectiez de nouveau.

      Remarques : 

      • Si l’erreur ne peut être résolue qu’en rejetant vos modifications, il est possible que les boutons pour réessayer d’apporter vos modifications ne soient pas disponibles.

      • Vous pouvez fermer la boîte de dialogue sans effectuer d’action, mais vous ne pourrez pas quitter ou mettre à jour la liste ou apporter des modifications à une colonne calculée jusqu’à ce que vous résoudiez l’erreur.

Une fois que vous avez reconnecté les tables liées, les modifications apportées aux données ou objets sont synchronisées.

  1. Ouvrez la base de données liée aux listes SharePoint.

  2. Sous l’onglet Données externes, dans le groupe Listes SharePoint, cliquez sur Travailler en ligne.

    Remarque : Si vous voulez ignorer les modifications que vous avez apportées hors connexion, cliquez sur Ignorer les modifications dans le groupe Listes SharePoint.

Haut de page

Besoin d’aide ?

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×