Utilisation de la fonction SI pour vérifier si une cellule est vide

Vous devez parfois vérifier si une cellule est vide, généralement pour éviter qu’une formule n’affiche un résultat sans saisie préalable.

La formule dans la cellule E2 est =SI(D2=1;"Oui";SI(D2=2;"Non";"Peut-être"))

En pareil cas, vous pouvez utiliser la fonction SI avec la fonction ESTVIDE :

  • =SI(ESTVIDE(D2);"Vide";"Non vide")

La formule a la signification suivante : SI(D2 est vide, renvoyer « Vide », sinon renvoyer « Non vide »). Vous pouvez aussi utiliser votre propre formule pour la condition « Non vide ». Dans l’exemple suivant, nous utilisons des guillemets ("") au lieu de la fonction ESTVIDE. Ceux-ci signifient qu’il n’y a « rien ».

Vérifier si une cellule est vide - La formule dans la cellule E2 est =SI(ESTVIDE(D2),"Vide","Non vide")

=SI(D3="";"Vide";"Non vide")

Cette formule a la signification suivante : SI(D3 ne contient aucun élément, renvoyer « Vide », sinon renvoyer « Non vide »). Voici un exemple d’une méthode courante d’utilisation des guillemets ("") pour empêcher le calcul d’une formule si une cellule dépendante est vide :

  • =SI(D3="";"";VotreFormule())

    SI(D3 ne contient aucun élément, ne rien renvoyer, sinon calculer la formule).

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×