Filtrer des tâches ou des ressources

S’applique à
Client de bureau Project Online Project Standard 2024 Project Professionnel 2021 Project Standard 2021 Project Professionnel 2019 Project Standard 2019 Project Professionnel 2016 Project Standard 2016

Project vous permet de filtrer l’affichage de manière à ne voir que les tâches critiques, les jalons et les autres informations les plus importantes pour vous. Il existe trois façons de filtrer les tâches ou les ressources de votre projet fournit des filtres prédéfinis pour afficher des aspects spécifiques des tâches et des ressources. Si aucun de ces filtres ne répond à vos besoins, vous pouvez créer un filtre ou modifier un filtre existant.

  • Filtres prédéfinis Il s’agit de filtres fournis avec Project. Ils sont utilisés pour filtrer rapidement les tâches ou les ressources, telles que les tâches incomplètes ou les ressources qui sont surallouées.
  • Filtres personnalisés Il s’agit de filtres que vous concevez pour les besoins de votre propre projet.
  • Filtres automatiques Lorsqu’elles sont activées, elles apparaissent sous forme de flèches en haut de chaque colonne dans un affichage Feuille. Utilisez-les pour filtrer rapidement les éléments d’une colonne.

Contenu de cet article

Filtrer des tâches ou des ressources

Il peut arriver que vous souhaitiez afficher uniquement un type particulier d’informations dans votre projet. Par exemple, vous pouvez afficher uniquement les jalons de votre projet ou afficher les tâches qui n’ont pas commencé. Si votre projet comporte de nombreuses tâches et implique de nombreuses ressources, les filtres peuvent être très utiles pour afficher une plage spécifique d’informations. Les filtres vous permettent d’afficher uniquement les informations qui vous intéressent et de masquer le reste.

Vous pouvez filtrer les données de tâche ou de ressource à l’aide des filtres de projet prédéfinis. Si aucun des filtres ne répond à vos besoins, vous pouvez créer un filtre ou modifier un filtre existant.

Appliquer ou supprimer un filtre

  1. Sous l’onglet Affichage , dans le groupe Données , choisissez un filtre dans la liste des filtres.

    Commande Filtrer
    Pour appliquer un filtre qui ne figure pas dans la liste, sélectionnez Autres filtres, puis effectuez l’une des opérations suivantes :

    • Pour sélectionner un filtre de tâche, choisissez Tâche, choisissez un nom de filtre dans la liste Filtres , puis choisissez Appliquer.

    • Pour sélectionner un filtre de ressource, choisissez Ressource, choisissez un nom de filtre dans la liste Filtres , puis choisissez Appliquer.

      Remarque

      Vous ne pouvez pas appliquer de filtres de tâches aux vues de ressources ni de filtres de ressources aux vues de tâches.

  2. Si vous appliquez un filtre interactif, tapez les valeurs demandées, puis choisissez OK.

  3. Pour désactiver un filtre, choisissez Aucun filtre dans la liste des filtres.

Appliquer une couleur aux tâches filtrées à l’aide d’une surbrillance

Lorsque vous filtrez des tâches ou des ressources, vous pouvez appliquer un surlignage. Les tâches ou ressources en surbrillance apparaissent avec des tâches non filtrées, mais avec une couleur différente.

  1. Sous l’onglet Affichage , dans le groupe Données , sélectionnez un filtre dans la liste de filtres, puis choisissez Autres filtres.
  2. Sélectionnez un filtre dans la liste de filtres, puis sélectionnez Mettre en surbrillance.

Conseil

Pour appliquer une autre couleur aux tâches en surbrillance, utilisez un autre style de texte. Choisissez l’onglet Format , puis Styles de texte. Dans la liste Élément à modifier , sélectionnez Tâches en surbrillance, puis sélectionnez Options de mise en forme.

Créer un filtre personnalisé

  1. Sous l’onglet Affichage , dans le groupe Données , choisissez la flèche en regard de Filtrer, puis choisissez Autres filtres.
    Le ruban Project, montrant comment créer un filtre personnalisé.
  2. Sélectionnez Tâche ou Ressource (selon le type de filtre que vous voulez créer), puis choisissez Nouveau.
  3. Tapez un nom pour votre nouveau filtre. Sélectionnez Afficher dans le menu si vous souhaitez inclure ce filtre dans la liste des groupes de données .
  4. Dans la colonne Et/Ou , choisissez Et pour afficher les résultats qui répondent à plusieurs de vos critères de filtre. Choisissez Ou pour afficher les lignes qui se rencontrent.
    Choisissez Et ou Ou, selon le type de résultats que vous voulez obtenir de votre filtre.
  5. Dans la colonne Nom du champ , choisissez le champ à filtrer.
  6. Dans la colonne Test , décidez comment vous souhaitez faire correspondre ce que vous avez choisi pour la colonne Nom du champ à la colonne Valeur(s) à l’étape suivante.
  7. Dans la colonne Valeur(s), choisissez la valeur souhaitée ou tapez-en une nouvelle.
    Si vous avez choisi Est égal à ou Est différent dans la colonne Test , vous pouvez taper un caractère générique dans la colonne Valeurs (au lieu de choisir une option dans la liste). Par exemple, si vous tapez un point d’interrogation ( ?), vous trouverez des caractères uniques. Un astérisque (*) permet de rechercher n’importe quel nombre de caractères. Si vous utilisez des caractères génériques, assurez-vous que votre choix pour la colonne Nom du champ implique du texte (comme Nom) et non des nombres (comme Durée).
  8. Pour ajouter une autre ligne à votre filtre (et choisir un autre nom de champ sur lequel filtrer), choisissez Insérer une ligne. Vous pouvez regrouper des lignes en ajoutant une ligne vide. Ajoutez un And ou Or dans la ligne vide pour filtrer un groupe par rapport à un autre.
  9. Lorsque vous avez terminé, choisissez Enregistrer.

Conseil

Pour supprimer rapidement tous vos filtres, utilisez la touche F3. N’oubliez pas que les filtres de tâches fonctionnent uniquement avec les affichages des tâches et que les filtres de ressources fonctionnent uniquement avec les affichages de ressources.

Modifier un filtre existant

  1. Sous l’onglet Affichage , dans le groupe Données , sélectionnez la liste de filtres, puis choisissez Autres filtres.

  2. Effectuez l’une des opérations suivantes :

    • Pour modifier un filtre de tâche, choisissez Tâche, choisissez le filtre que vous souhaitez modifier, puis choisissez Modifier.
    • Pour modifier un filtre de ressources, choisissez Ressource, choisissez le filtre que vous souhaitez modifier, puis choisissez Modifier.
  3. Modifiez les paramètres du filtre à l’aide des commandes de la boîte de dialogue Définition du filtre .

Utiliser les filtres automatiques

Vous pouvez appliquer un filtre automatique aux champs de n’importe quel affichage de feuille. En plus des filtres standard, Project fournit des filtres automatiques, visibles en haut de chaque colonne dans les vues de feuille.

Appliquer et supprimer des filtres automatiques

  1. Sous l’onglet Affichage , dans le groupe Données , choisissez la flèche en regard de la liste de filtres, puis sélectionnez Afficher le filtre automatique.
    Commande Filtrer

  2. Choisissez la flèche Filtre automatique en regard de l’en-tête de colonne qui contient les informations que vous souhaitez afficher, puis choisissez une valeur pour filtrer la table.
    La flèche Filtre automatique et l’en-tête du champ deviennent bleus.

  3. Pour appliquer une condition supplémentaire basée sur une valeur d’une autre colonne, répétez l’étape 2 pour l’autre colonne.

  4. Pour supprimer le filtrage sur une ligne spécifique, choisissez Clear All Filters (Effacer tous les filtres ) dans la liste Filtre automatique pour ce champ.

  5. Pour désactiver les filtres automatiques, choisissez de nouveau Afficher le filtre automatique .

    Remarque

    Si les informations changent dans l’une des lignes de votre vue, vous pouvez actualiser vos paramètres de filtre automatique en choisissant la flèche et en sélectionnant à nouveau les valeurs de filtrage.

Créer un filtre automatique personnalisé

  1. Afficher les filtres automatiques.

  2. Choisissez une flèche Filtre automatique, pointez sur Filtrer, puis choisissez Personnalisé.

  3. Choisissez l’opérateur à utiliser dans la première zone, puis tapez ou sélectionnez la valeur que vous souhaitez faire correspondre dans la deuxième zone.
    Par exemple, pour faire correspondre une date spécifique dans un champ de date, choisissez l’opérateur égal dans la première zone, puis sélectionnez la date souhaitée dans la seconde zone.

  4. Pour appliquer deux conditions au filtre automatique, effectuez l’une des opérations suivantes :

    • Pour afficher les lignes de votre affichage qui remplissent les deux conditions, choisissez l’opérateur et la valeur souhaités dans la deuxième rangée de cases, puis choisissez ET.
    • Pour afficher les lignes de votre affichage qui remplissent une condition ou une autre, choisissez l’opérateur et la valeur souhaités dans la deuxième rangée de cases, puis sélectionnez Ou.
  5. Pour enregistrer vos paramètres de filtre automatique, choisissez Enregistrer.
    Si un filtre prédéfini est déjà appliqué à votre affichage, les conditions que vous avez définies pour le filtre automatique sont incluses en tant que conditions supplémentaires au filtre actuel. Lorsque vous enregistrez un paramètre de filtre automatique, le filtre est enregistré avec les autres filtres de votre fichier et n’est disponible que dans la boîte de dialogue Autres filtres .

Activer automatiquement les filtres automatiques pour les nouveaux projets

  1. Dans l’onglet Fichier , choisissez Options.
  2. Sélectionnez Avancé, puis, dans la section Général, activez la case à cocher Définir le filtre automatique pour les nouveaux projets en case activée.

Haut de la page