Message d’erreur « Échec de la définition du paramètre AX_CompanyName » lorsque vous affichez un aperçu du rapport SalesVsTargetRC dans le projet smmSalesReports pour Microsoft Dynamics AX 2012 dans Microsoft Visual Studio 2010

Cet article s’applique à Microsoft Dynamics AX pour toutes les régions.

Symptômes

Supposons que vous traitez un projet smmSalesReports pour Microsoft Dynamics AX 2012 dans Microsoft Visual Studio 2010. Lorsque vous affichez un aperçu du rapport SalesVsTargetRC dans le projet, vous recevez le message d’erreur suivant dans Microsoft Visual Studio 2010 :

Remarque

Échec de la définition du paramètre AX_CompanyName.

Cause

Ce problème se produit parce que la méthode ReportRuntimeBacking.ExecuteDataSet n’atteint pas l’objet ParameterDescription correspondant à l’aide d’un objet ParameterDefinition associé.

Résolution

Informations sur le correctif logiciel

Un correctif logiciel pris en charge est disponible auprès de Microsoft. Une section « Téléchargement de correctif logiciel est disponible » en haut de cet article de la Base de connaissances. Si vous rencontrez un problème de téléchargement, d’installation de ce correctif ou si vous avez d’autres questions de support technique, contactez votre partenaire ou, si vous êtes inscrit à un plan de support directement auprès de Microsoft, vous pouvez contacter le support technique de Microsoft Dynamics et créer une demande de support. Pour ce faire, reportez-vous au site Web Microsoft à l'adresse suivante :

https://mbs.microsoft.com/support/newstart.aspx Vous pouvez également contacter le support technique de Microsoft Dynamics par téléphone à l’aide de ces liens pour les numéros de téléphone spécifiques au pays. Pour ce faire, visitez l’un des sites web Microsoft suivants :

Partenaires

https://mbs.microsoft.com/partnersource/support/ Clients

https://mbs.microsoft.com/customersource/support/information/SupportInformation/global_support_contacts_eng.htm Dans des cas particuliers, les frais habituellement engagés pour les appels de support peuvent être annulés si un professionnel du support technique pour Microsoft Dynamics et les produits associés détermine qu’une mise à jour spécifique résout votre problème. Les coûts de support habituels s’appliquent à toutes les questions et problèmes de support supplémentaires qui ne sont pas éligibles pour la mise à jour spécifique en question.

Informations sur l’installation

Si vous avez des personnalisations pour une ou plusieurs méthodes ou tables affectées par ce correctif, vous devez effectuer les étapes suivantes :

  1. Passez en revue les modifications documentées dans le fichier .xpo.
  2. Appliquez ces modifications dans un environnement de test avant d’appliquer le correctif logiciel dans un environnement de production.

                
 Pour plus d’informations sur l’installation de ce correctif logiciel, cliquez sur le numéro d’article suivant pour afficher l’article dans la Base de connaissances Microsoft :

893082 Comment installer un correctif logiciel Microsoft Dynamics AX

Configuration requise

Microsoft Dynamics AX 2012 doit être installé pour appliquer ce correctif logiciel.

Nécessité de redémarrer

Vous devez redémarrer le service AOS (Application Object Server) après avoir appliqué le correctif logiciel.

Informations de fichier

La version globale de ce correctif logiciel contient les attributs de fichier (ou les attributs de fichier ultérieurs) répertoriés dans le tableau suivant. Les date et heure de création de ces fichiers sont exprimées en temps universel coordonné (UTC). Lorsque vous affichez les informations des fichiers, les données sont converties en heure locale. Pour connaître le décalage entre l’heure UTC et l’heure locale, utilisez l’onglet Fuseau horaire dans l’élément Date et heure du Panneau de configuration.

Nom de fichier Version du fichier Taille du fichier Date Heure Plateforme
Aximpactanalysis.exe Non applicable 60,280 03-avr-2012 1,256 x86
Axupdate.exe Non applicable 60,264 03-avr-2012 1,256 x86
Clientoba32.msp Non applicable 16,424,960 08-avr-2012 2,157 Non applicable
Clientoba64.msp Non applicable 16,613,376 08-avr-2012 2,157 Non applicable
Components32.msp Non applicable 14,929,920 08-avr-2012 2,157 Non applicable
Components64.msp Non applicable 28,770,304 08-avr-2012 2,158 Non applicable
Helpserver64.msp Non applicable 774,144 08-avr-2012 2,157 Non applicable
Objectserver32.msp Non applicable 5,660,672 08-avr-2012 2,158 Non applicable
Objectserver64.msp Non applicable 7,213,056 08-avr-2012 2,158 Non applicable
Retailheadquarters32.msp Non applicable 466,944 08-avr-2012 2,157 Non applicable
Retailheadquarters64.msp Non applicable 466,944 08-avr-2012 2,157 Non applicable
Retailpos.msp Non applicable 712,704 08-avr-2012 2,157 Non applicable
Setupsupport32.msp Non applicable 7,843,840 08-avr-2012 2,158 Non applicable
Setupsupport64.msp Non applicable 13,774,848 08-avr-2012 2,157 Non applicable
Traceparser.msp Non applicable 249,856 08-avr-2012 2,157 Non applicable
Axsetupsp.exe 6.0.947.853 1,361,768 03-avr-2012 1,256 x86
Axutillib.dll 6.0.947.0 817,512 03-avr-2012 1,256 x86
Microsoft.dynamics.servicing.operations.dll 6.0.888.436 35,752 03-avr-2012 1,256 x86
Axsetupsp.resources.dll 6.0.947.491 382,848 03-avr-2012 1,256 x86
Axsetupsp.resources.dll 6.0.947.491 370,560 03-avr-2012 1,256 x86
Axsetupsp.resources.dll 6.0.947.491 374,656 03-avr-2012 1,256 x86
Axsetupsp.resources.dll 6.0.947.491 374,656 03-avr-2012 1,256 x86
Axsetupsp.resources.dll 6.0.947.491 370,560 03-avr-2012 1,256 x86
Axsetupsp.resources.dll 6.0.947.491 378,752 03-avr-2012 1,256 x86
Axsetupsp.resources.dll 6.0.947.491 370,560 03-avr-2012 1,256 x86
Axsetupsp.resources.dll 6.0.947.491 374,656 03-avr-2012 1,256 x86
Axsetupsp.resources.dll 6.0.947.491 370,560 03-avr-2012 1,256 x86
Axsetupsp.resources.dll 6.0.947.491 374,656 03-avr-2012 1,256 x86
Axsetupsp.resources.dll 6.0.947.491 370,560 03-avr-2012 1,256 x86
Axsetupsp.resources.dll 6.0.947.491 407,424 03-avr-2012 1,256 x86

État

Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».

Remarque Il s’agit d'un article de « dernière minute » créé directement à partir de l’organisation de support technique Microsoft. Les informations présentées ici sont fournies telles quelles en réponse à des problèmes nouveaux. En raison de la rapidité de leur mise à disposition, les documents peuvent contenir des erreurs typographiques et être modifiés à tout moment sans préavis. Consultez les Conditions d’utilisation pour d’autres considérations.