Symptômes
Vous essayez d’utiliser Deployment Manager pour importer un organization dans Microsoft Dynamics CRM 4.0. Toutefois, l’Importation de l’Assistant Organisation prend beaucoup de temps pour importer le organization.
Cause
Ce problème se produit car de nombreuses références utilisateur système doivent être mises à jour.
Résolution
Important : cette section, méthode ou tâche contient des étapes vous indiquant comment modifier le Registre. Faites attention, car des problèmes sérieux peuvent survenir si vous le modifiez de façon incorrecte. Nous ne saurions trop vous conseiller de suivre ces étapes scrupuleusement. Dans tous les cas, n’oubliez pas de sauvegarder le Registre avant de le modifier. Vous serez alors en mesure de le restaurer en cas de problème. Pour plus d'informations sur la procédure de sauvegarde et de restauration du Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
322756 Comment sauvegarder et restaurer le Registre dans WindowsCe problème est résolu dans le dernier correctif cumulatif cumulatif pour Microsoft Dynamics CRM 4.0.
Pour plus d’informations, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :
mises à jour et correctifs logiciels 949256 Microsoft Dynamics CRM 4.0
Après avoir installé ce correctif logiciel, pour que nous ajoutions l’entrée de Registre OptimizeOrgImport REG_DWORD pour vous, accédez à la section « Corriger pour moi ». Si vous préférez ajouter vous-même l’entrée de registre OptimizeOrgImport REG_DWORD, accédez à la section « Permettez-moi de résoudre le problème moi-même ».
Résolution automatique
Pour ajouter automatiquement l’entrée de Registre OptimizeOrgImport REG_DWORD, cliquez sur le bouton ou le lien Corriger . Cliquez ensuite sur Exécuter dans la boîte de dialogue Téléchargement de fichier, puis suivez la procédure indiquée par l’Assistant Résolution.
Notes
- Il se peut que cet Assistant ne soit disponible qu’en anglais. Toutefois, la résolution automatique fonctionne aussi pour d'autres versions linguistiques de Windows.
- Si vous n’utilisez pas l’ordinateur concerné, vous pouvez enregistrer la solution sur un lecteur flash ou sur un CD-ROM et ensuite l’exécuter sur l’ordinateur concerné par le problème.
Consultez ensuite la section « Le problème est-il résolu ? ».
Je résous le problème moi-même
Après avoir installé ce correctif, vous devez ajouter l’entrée de Registre OptimizeOrgImport REG_DWORD sur le serveur Microsoft Dynamics CRM 4.0. Pour ce faire, procédez comme suit :
Cliquez sur Démarrer, puis sur Exécuter, tapez regedit, puis cliquez sur OK.
Recherchez la sous-clé de Registre suivante, puis cliquez dessus :
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRMCliquez avec le bouton droit sur MSCRM, pointez sur
Nouveau, puis cliquez sur DWORD Value.Nommez cette valeur DWORD par « OptimizeOrgImport »
Cliquez avec le bouton droit sur OptimizeOrgImport, puis cliquez sur Modifier.
Dans la zone Données de la valeur, tapez
1, puis cliquez sur OK.Dans le menu Fichier, cliquez sur
Quitter.
Remarque Si vous souhaitez désactiver ce correctif logiciel, définissez la valeur de l’entrée de Registre OptimizeOrgImport sur 0.
Le problème est-il résolu ?
- Vérifiez si le problème est résolu. Si c'est le cas, vous n'avez plus besoin de cette section. Sinon, vous pouvez contacter le support technique.
- Vos commentaires sont les bienvenus. Pour nous faire part de vos commentaires ou d’un problème concernant cette solution, écrivez-nous sur le blog « Fix it for me » ou envoyez-nous un courrier électronique.
Informations supplémentaires
Lorsque vous utilisez l’entrée de Registre OptimizeOrgImport et que la valeur de cette entrée est définie sur 1, vous ne pouvez pas importer la même base de données organization plusieurs fois. Si vous souhaitez importer la même base de données organization plusieurs fois, vous devez effectuer l’une des opérations suivantes :
- Définissez OptimizeOrgImport = 0 et utilisez le processus d’importation normal.
- Supprimez le organization, puis réimportez le organization.
État
Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».