Deux caractères spéciaux sont ajoutés à la fin de la valeur lorsque vous copiez une valeur de cellule d’une feuille de calcul Excel vers Microsoft Dynamics NAV 5.0 Service Pack 1

S’applique à
Microsoft Dynamics NAV 5.0

Cet article s’applique à Microsoft Dynamics NAV pour tous les pays et tous les paramètres régionaux de langue.

Symptômes

Lorsque vous copiez une valeur de cellule d’une feuille de calcul Excel vers Microsoft Dynamics NAV 5.0 Service Pack 1 (SP1), deux caractères spéciaux sont ajoutés à la fin de la valeur. Ces caractères spéciaux sont des signes rectangles sous forme de caractères de saut de ligne.

Remarque Si vous exécutez Microsoft Dynamics NAV et Microsoft Excel sur un ordinateur Windows 7, ces deux caractères ne sont pas visibles. Si vous exécutez Microsoft Dynamics NAV et Microsoft Excel sur un ordinateur Windows Server 2003, les caractères sont visibles.

Ces caractères sont ajoutés aux champs dans Microsoft Dynamics NAV. Par conséquent, vous devez supprimer les caractères spéciaux manuellement.

Cause

Ce problème se produit parce que le caractère de retour chariot (CR) (ASCII 13) ou le caractère de saut de ligne (LF) (ASCII 10) est ajouté lorsqu’une valeur de cellule est copiée d’une feuille de calcul Excel vers une application. Le client RoleTailored (RTC) utilise le contrôle de texte, basé sur le contrôle de texte .NET standard. Si la propriété multiligne du contrôle de texte .NET est définie sur « Non », lorsque vous collez un texte de contrôle qui contient le caractère CR ou le caractère LF, seul le texte avant les caractères est copié. Si la propriété multiligne du contrôle de texte est définie sur « True », le caractère « nouvelle ligne » peut être utilisé. Pour plus d'informations, visitez le site Web Microsoft suivant :
TextBoxBase.Multiline, propriété
Dans un client classique, Microsoft Dynamics NAV doit implémenter un traitement spécial pour la méthode Paste des contrôles d’édition de texte. Les caractères « nouvelle ligne » doivent être supprimés de la fin de la ligne.

Résolution

Informations sur le correctif logiciel

Un correctif logiciel pris en charge est disponible auprès de Microsoft. Une section « Téléchargement de correctif logiciel est disponible » en haut de cet article de la Base de connaissances. Si vous rencontrez un problème de téléchargement, d’installation de ce correctif ou si vous avez d’autres questions de support technique, contactez votre partenaire ou, si vous êtes inscrit à un plan de support directement auprès de Microsoft, vous pouvez contacter le support technique de Microsoft Dynamics et créer une demande de support. Pour ce faire, reportez-vous au site Web Microsoft à l'adresse suivante :

https://mbs.microsoft.com/support/newst art.aspx Vous pouvez également contacter le support technique de Microsoft Dynamics par téléphone à l’aide de ces liens pour les numéros de téléphone spécifiques au pays. Pour ce faire, visitez l’un des sites web Microsoft suivants :

Partenaires

https://mbs.microsoft.com/partnersource/resources/support/supportinformation/Global +Support+Contacts Clients

formation/global_support_contacts_eng.htmhttps://mbs.microsoft.com/customersource/support/information/SupportIn Dans des cas particuliers, les frais habituellement engagés pour les appels de support peuvent être annulés si un professionnel du support technique pour Microsoft Dynamics et les produits associés détermine qu’une mise à jour spécifique résout votre problème. Les coûts de support habituels s’appliquent à toutes les questions et problèmes de support supplémentaires qui ne sont pas éligibles pour la mise à jour spécifique en question.

            
          

Comment obtenir le correctif logiciel ou les fichiers de mise à jour microsoft Dynamics NAV

Une fois que vous avez demandé un correctif logiciel Microsoft Dynamics NAV, un lien hypertexte vous est envoyé dans un e-mail.

L’e-mail contient un lien hypertexte et un mot de passe. Vous pouvez utiliser le lien hypertexte pour télécharger le correctif logiciel Microsoft Dynamics NAV ou les fichiers de mise à jour. Lorsque vous cliquez sur le lien hypertexte, la boîte de dialogue Téléchargement de fichier - Avertissement de sécurité s’ouvre. Ensuite, vous êtes invité à exécuter, à enregistrer ou à annuler le téléchargement.

Si vous cliquez sur Exécuter, les fichiers démarrent le téléchargement et le processus d’extraction. Vous devez spécifier un dossier pour les nouveaux fichiers, puis fournir le mot de passe.

Si vous cliquez sur Enregistrer, vous devez spécifier un chemin d’accès pour enregistrer le fichier compressé. Lorsque vous ouvrez le fichier que vous avez enregistré, vous êtes invité à spécifier un chemin d’accès pour les fichiers. Ensuite, vous devez fournir le mot de passe fourni dans l’e-mail.

Si vous cliquez sur Annuler, le processus de téléchargement s’arrête.

Comment installer un correctif logiciel Microsoft Dynamics NAV ou un fichier de mise à jour

Les correctifs et mises à jour de la plateforme Microsoft Dynamics NAV sont disponibles sous forme de fichiers uniques. Pour installer un correctif logiciel microsoft Dynamics NAV ou une mise à jour, vous devez remplacer les fichiers d’installation microsoft Dynamics NAV existants par le correctif logiciel ou les fichiers de mise à jour. Pour cela, procédez comme suit :

Étape 1 : Remplacer le fichier d’installation du client Microsoft Dynamics NAV

Dans l’installation du client Microsoft Dynamics NAV, remplacez les fichiers suivants à l’aide du correctif logiciel ou du fichier de mise à jour.

Nom de fichier Version du fichier Taille du fichier Date Heure Plateforme
Dbm.dll 5.0.32009.0 434 176 09-Déc.-2010 19:53 x86
Fin.exe 5.0.32009.0 10,747,904 09-Déc.-2010 1,931 x86
Finhlink.exe 5.0.32009.0 339,968 09-Déc.-2010 1,944 x86
Finsql.exe 5.0.32009.0 10,809,344 09-Déc.-2010 20:17 x86
Nc_netb.dll 5.0.32009.0 102,400 09-Déc.-2010 19:54 x86
Nc_tcp.dll 5.0.32009.0 102,400 09-Déc.-2010 19:54 x86
Nc_tcps.dll 5.0.32009.0 147,456 09-Déc.-2010 19 : 55 x86
Ndbcs.dll 5.0.32009.0 1,286,144 09-Déc.-2010 20:20 x86
Slave.exe 5.0.32009.0 151,552 09-Déc.-2010 1,944 x86

Pour remplacer les fichiers Microsoft Dynamics NAV existants, procédez comme suit :

  1. Fermez Microsoft Dynamics NAV.
  2. Recherchez le répertoire d’installation du client Microsoft Dynamics NAV. Le client Microsoft Dynamics NAV est généralement installé dans le répertoire suivant :
    C :\Program Files\Microsoft Dynamics NAV\CSIDE Client\
  3. Copiez les fichiers que vous avez téléchargés.
  4. Collez les fichiers que vous avez téléchargés dans le répertoire d’installation du client Microsoft Dynamics NAV.
  5. Lorsque vous y êtes invité, cliquez sur Oui pour remplacer les fichiers dans le répertoire d’installation.

Étape 2 : Remplacer le fichier d’installation de Microsoft Dynamics NAV Application Server

Si Microsoft Dynamics NAV Application Server est installé, dans l’installation de Microsoft Dynamics NAV Application Server, remplacez les fichiers suivants à l’aide du correctif logiciel ou du fichier de mise à jour.

Nom de fichier Version du fichier Taille du fichier Date Heure Plateforme
Dbm.dll 5.0.32009.0 434 176 09-Déc.-2010 19:53 x86
Nas.exe 5.0.32009.0 1,859,584 09-Déc.-2010 19:41 x86
Nassql.exe 5.0.32009.0 1,916,928 09-Déc.-2010 2,019 x86
Ndbcs.dll 5.0.32009.0 1,286,144 09-Déc.-2010 20:20 x86
Slave.exe 5.0.32009.0 151,552 09-Déc.-2010 1,944 x86

Pour remplacer les fichiers, procédez comme suit.

  1. Arrêtez le serveur d’applications Microsoft Dynamics NAV.
  2. Recherchez le répertoire d’installation de Microsoft Dynamics NAV Application Server. Microsoft Dynamics NAV Application Server est généralement installé dans le répertoire suivant :
    C :\Program Files\Microsoft Dynamics NAV\Application Server\
  3. Copiez les fichiers que vous avez téléchargés.
  4. Collez les fichiers que vous avez téléchargés dans le répertoire d’installation de Microsoft Dynamics NAV Application Server.
  5. Lorsque vous y êtes invité, cliquez sur Oui pour remplacer les fichiers dans le répertoire d’installation.
  6. Démarrez le serveur d’applications Microsoft Dynamics NAV.

Étape 3 : Remplacer le fichier d’installation du pilote ODBC Microsoft Dynamics NAV

Si le pilote ODBC Microsoft Dynamics NAV est installé, remplacez les fichiers suivants dans l’installation du pilote ODBC Microsoft Dynamics NAV.

Nom de fichier Version du fichier Taille du fichier Date Heure Plateforme
Cfront.dll 5.0.32009.0 1,294,336 09-Déc.-2010 19 : 55 x86
Dbm.dll 5.0.32009.0 434 176 09-Déc.-2010 19:53 x86
Nc_netb.dll 5.0.32009.0 102,400 09-Déc.-2010 19:54 x86
Nc_tcp.dll 5.0.32009.0 102,400 09-Déc.-2010 19:54 x86
Nc_tcps.dll 5.0.32009.0 147,456 09-Déc.-2010 19 : 55 x86
Nodbc.dll 5.0.32009.0 2,650,112 09-Déc.-2010 1,935 x86
Nodbc.xml Non applicable 1,209 07-avr-2008 01:09 Non applicable
Nodbccfg.cfg 5.0.32009.0 614,400 09-Déc.-2010 1,936 Non applicable
Nodbccfg.xml Non applicable 2,472 07-avr-2008 01:09 Non applicable
Slave.exe 5.0.32009.0 151,552 09-Déc.-2010 1,944 x86

Pour remplacer les fichiers, procédez comme suit.

  1. Recherchez le répertoire d’installation du pilote ODBC Microsoft Dynamics NAV. Le pilote ODBC Microsoft Dynamics NAV est généralement installé dans le répertoire suivant :
    C :\Program Files\Common Files\Dynamics NAV\NODBC\
  2. Copiez les fichiers que vous avez téléchargés.
  3. Collez les fichiers que vous avez téléchargés dans le répertoire d’installation du pilote ODBC Microsoft Dynamics NAV.
  4. Lorsque vous y êtes invité, cliquez sur Oui pour remplacer les fichiers dans le répertoire d’installation.

Configuration requise

Microsoft Dynamics NAV 5.0 Service Pack 1 doit être installé pour appliquer ce correctif.

Solution de contournement

Pour contourner ce problème, modifiez la cellule et marquez-la comme « Texte uniquement ».

État

Microsoft a confirmé qu’il s’agit d’un bogue dans les produits Microsoft répertoriés dans la section « S’applique à ».

Informations supplémentaires

Pour plus d’informations, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

824684 Terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft

Remarque Il s’agit d'un article de « dernière minute » créé directement à partir de l’organisation de support technique Microsoft. Les informations présentées ici sont fournies telles quelles en réponse à des problèmes nouveaux. En raison de la rapidité de leur mise à disposition, les documents peuvent contenir des erreurs typographiques et être modifiés à tout moment sans préavis. Consultez les Conditions d’utilisation pour d’autres considérations.