Message d’erreur « Impossible d’utiliser le fichier C :\Users[User]\AppData\Roaming\fin.zup, car il est déjà utilisé » lorsque vous imprimez plusieurs rapports classiques à partir du client RoleTailored dans Microsoft Dynamics NAV 2009 Service Pack 1

S’applique à
Dynamics NAV 2009

Cet article s’applique à Microsoft Dynamics NAV pour tous les pays et tous les paramètres régionaux de langue.

Symptômes

Lorsque vous imprimez plusieurs rapports classiques à partir du client RoleTailored (RTC) dans Microsoft Dynamics NAV 2009 Service Pack 1 (SP1), vous recevez le message d’erreur suivant :

Remarque

Vous ne pouvez pas utiliser le fichier C :\Users\User\AppData\Roaming\fin.zup, car il est déjà utilisé.

Ce problème se produit lorsque les conditions suivantes sont remplies :

  • Aucune disposition n’est définie pour les rapports. Par conséquent, les rapports sont exécutés sous le moteur de rapport classique à partir du RTC.
  • Au moins deux rapports sont imprimés rapidement.

Cause

Ce problème se produit parce que le RTC démarre le moteur de rapport classique pour exécuter un rapport. Lorsqu’un rapport est imprimé, le moteur classique tente d’enregistrer le fichier .zup. Si plusieurs rapports sont démarrés rapidement, plusieurs moteurs classiques remplacent les autres fichiers .zup.

Résolution

Informations sur le correctif logiciel

Un correctif logiciel pris en charge est disponible auprès de Microsoft. Une section « Téléchargement de correctif logiciel est disponible » en haut de cet article de la Base de connaissances. Si vous rencontrez un problème de téléchargement, d’installation de ce correctif ou si vous avez d’autres questions de support technique, contactez votre partenaire ou, si vous êtes inscrit à un plan de support directement auprès de Microsoft, vous pouvez contacter le support technique de Microsoft Dynamics et créer une demande de support. Pour cela, accédez au site web de Microsoft à l’adresse suivante :

https://mbs.microsoft.com/support/newstart.aspx Vous pouvez également contacter le support technique de Microsoft Dynamics par téléphone à l’aide de ces liens pour les numéros de téléphone spécifiques au pays. Pour ce faire, visitez l’un des sites Web Microsoft suivants :

Partenaires

https://mbs.microsoft.com/partnersource/resources/support/supportinformation/Global+Support+Contacts Clients

https://mbs.microsoft.com/customersource/support/information/SupportInformation/global_support_contacts_eng.htm Dans des cas particuliers, les frais habituellement engagés pour les appels de support peuvent être annulés si un professionnel du support technique pour Microsoft Dynamics et les produits associés détermine qu’une mise à jour spécifique résout votre problème. Les coûts de support habituels s’appliquent à toutes les questions et problèmes de support supplémentaires qui ne sont pas éligibles pour la mise à jour spécifique en question.

            
          

Comment obtenir le correctif logiciel ou les fichiers de mise à jour microsoft Dynamics NAV

Une fois que vous avez demandé un correctif logiciel Microsoft Dynamics NAV, un lien hypertexte vous est envoyé dans un e-mail.

L’e-mail contient un lien hypertexte et un mot de passe. Vous pouvez utiliser le lien hypertexte pour télécharger le correctif logiciel Microsoft Dynamics NAV ou les fichiers de mise à jour. Lorsque vous cliquez sur le lien hypertexte, la boîte de dialogue Téléchargement de fichier - Avertissement de sécurité s’ouvre. Ensuite, vous êtes invité à exécuter, à enregistrer ou à annuler le téléchargement.

Si vous cliquez sur Exécuter, les fichiers démarrent le téléchargement et le processus d’extraction. Vous devez spécifier un dossier pour les nouveaux fichiers, puis fournir le mot de passe.

Si vous cliquez sur Enregistrer, vous devez spécifier un chemin d’accès pour enregistrer le fichier compressé. Lorsque vous ouvrez le fichier que vous avez enregistré, vous êtes invité à spécifier un chemin d’accès pour les fichiers. Ensuite, vous devez fournir le mot de passe fourni dans l’e-mail.

Si vous cliquez sur Annuler, le processus de téléchargement s’arrête.

Comment installer un correctif logiciel Microsoft Dynamics NAV ou un fichier de mise à jour

Les correctifs et mises à jour de la plateforme Microsoft Dynamics NAV sont disponibles sous forme de fichiers uniques. Pour installer un correctif logiciel microsoft Dynamics NAV ou une mise à jour, vous devez remplacer les fichiers d’installation microsoft Dynamics NAV existants par le correctif logiciel ou les fichiers de mise à jour. Pour cela, procédez comme suit :

Étape 1 : Remplacer les fichiers dans l’installation de Microsoft Dynamics NAV Classic Client

Dans l’installation de Microsoft Dynamics NAV Classic Client, remplacez les fichiers suivants à l’aide du correctif logiciel ou du fichier de mise à jour.

Nom de fichier Version du fichier Taille du fichier Date Heure Plateforme
Dbm.dll 6.0.31587.0 427,848 30-août-2010 1,628 x86
Fin.exe 6.0.31587.0 12,632,904 30-août-2010 1,628 x86
Finhlink.exe 6.0.31587.0 452,432 30-août-2010 1,628 x86
Finsql.exe 6.0.31587.0 12,754,768 30-août-2010 1,628 x86
Nc_netb.dll 6.0.31587.0 96,592 30-août-2010 1,628 x86
Nc_tcp.dll 6.0.31587.0 98,640 30-août-2010 1,628 x86
Nc_tcps.dll 6.0.31587.0 141,136 30-août-2010 1,628 x86
Ndbcs.dll 6.0.31587.0 1,350,480 30-août-2010 1,628 x86
Slave.exe 6.0.31587.0 152,400 30-août-2010 1,628 x86

Pour remplacer les fichiers Microsoft Dynamics NAV existants, procédez comme suit :

  1. Fermez microsoft Dynamics NAV Classic Client.

  2. Recherchez le répertoire d’installation de Microsoft Dynamics NAV Classic Client. Microsoft Dynamics NAV Classic Client est généralement installé dans le répertoire suivant :

    C :\Program Files\Microsoft Dynamics NAV\60\Classic

  3. Copiez les fichiers que vous avez téléchargés.

  4. Collez les fichiers que vous avez téléchargés dans le répertoire d’installation de Microsoft Dynamics NAV Classic Client.

  5. Cliquez sur Oui pour remplacer les fichiers du répertoire.

Étape 2 : Remplacer les fichiers dans l’installation du client Microsoft Dynamics NAV RoleTailored

Dans l’installation du client Microsoft Dynamics NAV RoleTailored, remplacez les fichiers suivants à l’aide du correctif logiciel ou du fichier de mise à jour.

Nom de fichier Version du fichier Taille du fichier Date Heure Plateforme
Microsoft.dynamics.framework.patterns.dll 1.3.10803.301 71,656 23-août-2010 06:30 x86
Microsoft.dynamics.framework.ui.dll 1.3.10803.301 698,328 23-août-2010 06:30 x86
Microsoft.dynamics.framework.ui.mapping.dll 1.3.10803.301 104,424 23-août-2010 06:30 x86
Microsoft.dynamics.framework.ui.navigation.dll 1.3.10803.301 34,800 23-août-2010 06:30 x86
Microsoft.dynamics.framework.ui.ux2006.dll 1.3.10803.301 88,040 23-août-2010 06:30 x86
Microsoft.dynamics.framework.ui.ux2006.winforms.dll 1.3.10803.301 63,480 23-août-2010 06:30 x86
Microsoft.dynamics.framework.ui.windows.dll 1.3.10803.301 83,944 23-août-2010 06:30 x86
Microsoft.dynamics.framework.ui.winforms.controls.dll 1.3.10803.301 2,115,584 23-août-2010 06:30 x86
Microsoft.dynamics.framework.ui.winforms.dll 1.3.10803.301 694,248 23-août-2010 06:30 x86
Microsoft.dynamics.nav.client.builder.dll 6.0.31587.0 198,544 30-août-2010 16:10 x86
Microsoft.dynamics.nav.client.exe 6.0.31587.0 149,376 30-août-2010 16:10 x86
Microsoft.dynamics.nav.client.interop.communicator.dll 1.0.559.183 75,688 30-août-2010 16:10 x86
Microsoft.dynamics.nav.client.serviceconnection.dll 6.0.31587.0 104,352 30-août-2010 16:10 x86
Microsoft.dynamics.nav.client.ui.dll 6.0.31587.0 509,824 30-août-2010 16:10 x86
Microsoft.dynamics.nav.client.winforms.dll 6.0.31587.0 341,904 30-août-2010 16:10 x86
Microsoft.dynamics.nav.client.winforms.tlb Non applicable 2,680 30-août-2010 1,211 Non applicable
Microsoft.dynamics.nav.language.dll 6.0.31587.0 2,000,768 30-août-2010 16:10 x86
Microsoft.dynamics.nav.types.dll 6.0.31587.0 567,160 30-août-2010 16:10 x86
Microsoft.dynamics.nav.watson.dll 6.0.31587.0 42,880 30-août-2010 16:10 x86
Microsoft.office.interop.outlook.dll 10.0.4504.0 395,136 30-août-2010 1,628 x86

Pour remplacer ces fichiers, procédez comme suit :

  1. Fermez le client Microsoft Dynamics NAV RoleTailored.

  2. Recherchez le répertoire d’installation du client Microsoft Dynamics NAV RoleTailored. Le client Microsoft Dynamics NAV RoleTailored est généralement installé dans le répertoire suivant :

    C :\Program Files\Microsoft Dynamics NAV\60\RoleTailored Client

  3. Copiez les fichiers que vous avez téléchargés.

  4. Collez les fichiers que vous avez téléchargés dans le répertoire d’installation du client Microsoft Dynamics NAV RoleTailored.

  5. Cliquez sur Oui pour remplacer les fichiers du répertoire.

Étape 3 : Remplacer les fichiers dans l’installation de Microsoft Dynamics NAV Server

Dans l’installation de Microsoft Dynamics NAV Server, remplacez les fichiers suivants à l’aide du correctif logiciel ou du fichier de mise à jour.

Nom de fichier Version du fichier Taille du fichier Date Heure Plateforme
Httpcfg.exe 5.2.3790.0 22,352 30-août-2010 1,628 x86
Microsoft.dynamics.nav.language.dll 6.0.31587.0 2,000,768 30-août-2010 16:10 x86
Microsoft.dynamics.nav.ncl.dll 6.0.31587.0 608,120 30-août-2010 16:10 x86
Microsoft.dynamics.nav.server.exe 6.0.31587.0 141,184 30-août-2010 16:10 x86
Microsoft.dynamics.nav.service.dll 6.0.31587.0 145,280 30-août-2010 16:10 x86
Microsoft.dynamics.nav.service.runtime.dll 6.0.31587.0 75,664 30-août-2010 16:10 x86
Microsoft.dynamics.nav.service.webservices.dll 6.0.31587.0 145,304 30-août-2010 16:10 x86
Microsoft.dynamics.nav.types.dll 6.0.31587.0 567,160 30-août-2010 16:10 x86
Microsoft.dynamics.nav.watson.dll 6.0.31587.0 42,880 30-août-2010 16:10 x86
Nclcsrt.etx Non applicable 89,525 30-août-2010 08:31 Non applicable
Nclcsrt.stx Non applicable 91,724 30-août-2010 08:31 Non applicable
Nclcsrts.dll 6.0.31587.0 1,485,648 30-août-2010 16:27 x86
Ndbcs.dll 6.0.31587.0 1,350,480 30-août-2010 16:27 x86

Pour remplacer ces fichiers, procédez comme suit :

  1. Arrêtez microsoft Dynamics NAV Server.

  2. Recherchez le répertoire d’installation de Microsoft Dynamics NAV Server. Microsoft Dynamics NAV Server est généralement installé dans le répertoire suivant :

    C :\Program Files\Microsoft Dynamics NAV\60\Service

  3. Copiez les fichiers que vous avez téléchargés.

  4. Collez les fichiers que vous avez téléchargés dans le répertoire d’installation de Microsoft Dynamics NAV Server.

  5. Cliquez sur Oui pour remplacer les fichiers du répertoire.

  6. Démarrez microsoft Dynamics NAV Server.

Étape 4 : Remplacer les fichiers dans l’installation de Microsoft Dynamics NAV Application Server

Si Microsoft Dynamics NAV Application Server est installé, remplacez les fichiers suivants dans l’installation de Microsoft Dynamics NAV Application Server à l’aide du correctif logiciel ou des fichiers de mise à jour.

Nom de fichier Version du fichier Taille du fichier Date Heure Plateforme
Dbm.dll 6.0.31587.0 427,848 30-août-2010 1,628 x86
Nas.exe 6.0.31587.0 2,271,560 30-août-2010 1,628 x86
Nassql.exe 6.0.31587.0 2,370,384 30-août-2010 1,628 x86
Ndbcs.dll 6.0.31587.0 1,350,480 30-août-2010 1,628 x86
Slave.exe 6.0.31587.0 152,400 30-août-2010 1,628 x86

Pour remplacer les fichiers, procédez comme suit.

  1. Arrêtez le serveur d’applications Microsoft Dynamics NAV.

  2. Recherchez le répertoire d’installation de Microsoft Dynamics NAV Application Server. Microsoft Dynamics NAV Application Server est généralement installé dans le répertoire suivant :

    C :\Program Files\Microsoft Dynamics NAV\60\Application Server

  3. Copiez les fichiers que vous avez téléchargés.

  4. Collez les fichiers que vous avez téléchargés dans le répertoire d’installation de Microsoft Dynamics NAV Application Server.

  5. Cliquez sur Oui pour remplacer les fichiers du répertoire.

  6. Démarrez le serveur d’applications Microsoft Dynamics NAV.

Étape 5 : Remplacer les fichiers dans l’installation du Kit de développement logiciel (SDK) Microsoft Dynamics NAV

Si vous avez installé le Kit de développement logiciel (SDK) Microsoft Dynamics NAV, remplacez les fichiers suivants.

Nom de fichier Version du fichier Taille du fichier Date Heure Plateforme
Cf.h Non applicable 57,736 30-août-2010 1,211 Non applicable
Cfront.dll 6.0.31587.0 1,577,808 30-août-2010 1,628 x86
Cfront.ocx 6.0.31587.0 111,952 30-août-2010 1,628 x86
Cfrontsql.dll 6.0.31587.0 1,787,736 30-août-2010 1,628 x86
Libload.c Non applicable 31,718 30-août-2010 06:51 Non applicable
Microsoft.dynamics.nav.cfront.cfrontdotnet.dll 6.0.31587.0 182,168 30-août-2010 16:10 x86
Microsoft.dynamics.nav.cfront.cfrontdotnet.xml Non applicable 442,447 30-août-2010 07:12 Non applicable
Sample.c Non applicable 28,718 30-août-2010 06:51 Non applicable
Sample.exe 6.0.31587.0 152,400 30-août-2010 1,628 x86

Pour remplacer les fichiers, procédez comme suit.

  1. Recherchez les répertoires d’installation du Kit de développement logiciel (SDK) Microsoft Dynamics NAV. Le Kit de développement logiciel (SDK) Microsoft Dynamics NAV est généralement installé dans les répertoires suivants :

    C :\Program Files\Microsoft Dynamics NAV\60\SDK\CFRONT
    C :\Program Files\Microsoft Dynamics NAV\60\SDK\Communication Components
    C :\Program Files\Common Files\Microsoft Dynamics NAV\Communication Component

  2. Choisissez le Kit de développement logiciel (SDK) à mettre à jour, C/Front ou Composants de communication.

  3. Copiez les fichiers que vous avez téléchargés.

  4. Collez les fichiers que vous avez téléchargés dans le répertoire d’installation approprié du Kit de développement logiciel (SDK) Microsoft Dynamics NAV.

  5. Cliquez sur Oui pour remplacer les fichiers du répertoire.

Remarque Si vous avez téléchargé un correctif logiciel ou une mise à jour pour les composants de communication, vous devez inscrire les fichiers .dll individuellement.

Étape 6 : Remplacer les fichiers dans l’installation du pilote ODBC Microsoft Dynamics NAV

Si le pilote ODBC Microsoft Dynamics NAV est installé, remplacez les fichiers suivants dans l’installation du pilote ODBC Microsoft Dynamics NAV.

Nom de fichier Version du fichier Taille du fichier Date Heure Plateforme
Cfront.dll 6.0.31587.0 1,577,808 30-août-2010 1,628 x86
Dbm.dll 6.0.31587.0 427,848 30-août-2010 1,628 x86
Nc_netb.dll 6.0.31587.0 96,592 30-août-2010 1,628 x86
Nc_tcp.dll 6.0.31587.0 98,640 30-août-2010 1,628 x86
Nc_tcps.dll 6.0.31587.0 141,136 30-août-2010 1,628 x86
Nodbc.dll 6.0.31587.0 2,141,008 30-août-2010 1,628 x86
Nodbc.xml Non applicable 1,209 25-août-2009 16:43 Non applicable
Nodbccfg.cfg 6.0.31587.0 724,480 30-août-2010 08:05 Non applicable
Nodbccfg.xml Non applicable 2,472 25-août-2009 16:43 Non applicable
Slave.exe 6.0.31587.0 152,400 30-août-2010 1,628 x86

Pour remplacer les fichiers, procédez comme suit.

  1. Recherchez le répertoire d’installation du pilote ODBC Microsoft Dynamics NAV. Le pilote ODBC Microsoft Dynamics NAV est généralement installé dans le répertoire suivant :

    C :\Program Files\Microsoft Dynamics NAV\60\ODBC

  2. Copiez les fichiers que vous avez téléchargés.

  3. Collez les fichiers que vous avez téléchargés dans le répertoire d’installation du pilote ODBC Microsoft Dynamics NAV.

  4. Cliquez sur Oui pour remplacer les fichiers du répertoire.

Configuration requise

Microsoft Dynamics NAV 2009 Service Pack 1 doit être installé pour appliquer ce correctif.

Solution de contournement

Pour contourner ce problème, définissez une disposition pour les rapports exécutés rapidement à partir du RTC. Si la disposition du rapport est définie, le RTC exécute le rapport à l’aide de son propre moteur de rapport. Par conséquent, le RTC ne démarre pas plusieurs sessions du moteur de rapport classique.

État

Microsoft a confirmé qu’il s’agit d’un bogue dans les produits Microsoft répertoriés dans la section « S’applique à ».

Informations supplémentaires

Pour plus d’informations, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

824684 Terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft

Remarque Il s’agit d'un article de « dernière minute » créé directement à partir de l’organisation de support technique Microsoft. Les informations présentées ici sont fournies telles quelles en réponse à des problèmes nouveaux. En raison de la rapidité de leur mise à disposition, les documents peuvent contenir des erreurs typographiques et être modifiés à tout moment sans préavis. Consultez les Conditions d’utilisation pour d’autres considérations.