Message d’erreur « Vous ne pouvez pas utiliser le fichier zup, car il est déjà utilisé » lorsque vous imprimez des rapports classiques à partir du client RoleTailored dans Microsoft Dynamics NAV 2009 Service Pack 1

S’applique à
Dynamics NAV 2009

LES ARTICLES DE PUBLICATION RAPIDE FOURNISSENT DES INFORMATIONS DIRECTEMENT AU SEIN DE L’ORGANISATION DE SUPPORT MICROSOFT. LES INFORMATIONS CONTENUES DANS LES PRÉSENTES SONT CRÉÉES EN RÉPONSE À DES SUJETS ÉMERGENTS OU UNIQUES, OU SONT DESTINÉES À COMPLÉTER D’AUTRES INFORMATIONS DE LA BASE DE CONNAISSANCES.

Cet article s’applique à Microsoft Dynamics NAV pour tous les pays et tous les paramètres régionaux de langue.

Symptômes

Lorsque vous imprimez rapidement des rapports classiques à partir du client RoleTailored (RTC) dans Microsoft Dynamics NAV 2009 Service Pack 1, vous recevez le message d’erreur suivant :

Remarque

Vous ne pouvez pas utiliser le fichier zup, car il est déjà utilisé.

Remarque Les rapports sont toujours imprimés.

Cause

Ce problème se produit parce que les rapports classiques n’ont pas de disposition Visual Studio. Microsoft Dynamics NAV utilise le moteur de rapport du client classique pour imprimer ces rapports. Ce problème se produit lorsque Microsoft Dynamics NAV s’ouvre, puis ferme le moteur de rapport classique de manière rapide. Lorsque Microsoft Dynamics NAV ferme le client classique, le fichier .zup est mis à jour. Par conséquent, si un moteur de rapport classique tente de se fermer avant que le moteur de rapport précédent ne soit terminé, ce problème se produit.

Résolution

Informations sur le correctif logiciel

Un correctif logiciel pris en charge est disponible auprès de Microsoft. Une section « Téléchargement de correctif logiciel est disponible » en haut de cet article de la Base de connaissances. Si vous rencontrez un problème de téléchargement, d’installation de ce correctif ou si vous avez d’autres questions de support technique, contactez votre partenaire ou, si vous êtes inscrit à un plan de support directement auprès de Microsoft, vous pouvez contacter le support technique de Microsoft Dynamics et créer une demande de support. Pour cela, accédez au site web de Microsoft à l’adresse suivante :

https://mbs.microsoft.com/support/newstart.aspx Vous pouvez également contacter le support technique de Microsoft Dynamics par téléphone à l’aide de ces liens pour les numéros de téléphone spécifiques au pays. Pour ce faire, visitez l’un des sites Web Microsoft suivants :

Partenaires

https://mbs.microsoft.com/partnersource/resources/support/supportinformation/Global+Support+Contacts Clients

https://mbs.microsoft.com/customersource/support/information/SupportInformation/global_support_contacts_eng.htm Dans des cas particuliers, les frais habituellement engagés pour les appels de support peuvent être annulés si un professionnel du support technique pour Microsoft Dynamics et les produits associés détermine qu’une mise à jour spécifique résout votre problème. Les coûts de support habituels s’appliquent à toutes les questions et problèmes de support supplémentaires qui ne sont pas éligibles pour la mise à jour spécifique en question.

            
          

Comment obtenir le correctif logiciel ou les fichiers de mise à jour microsoft Dynamics NAV

Une fois que vous avez demandé un correctif logiciel Microsoft Dynamics NAV, un lien hypertexte vous est envoyé dans un e-mail.

L’e-mail contient un lien hypertexte et un mot de passe. Vous pouvez utiliser le lien hypertexte pour télécharger le correctif logiciel Microsoft Dynamics NAV ou les fichiers de mise à jour. Lorsque vous cliquez sur le lien hypertexte, la boîte de dialogue Téléchargement de fichier - Avertissement de sécurité s’ouvre. Ensuite, vous êtes invité à exécuter, à enregistrer ou à annuler le téléchargement.

Si vous cliquez sur Exécuter, les fichiers démarrent le téléchargement et le processus d’extraction. Vous devez spécifier un dossier pour les nouveaux fichiers, puis fournir le mot de passe.

Si vous cliquez sur Enregistrer, vous devez spécifier un chemin d’accès pour enregistrer le fichier compressé. Lorsque vous ouvrez le fichier que vous avez enregistré, vous êtes invité à spécifier un chemin d’accès pour les fichiers. Ensuite, vous devez fournir le mot de passe fourni dans l’e-mail.

Si vous cliquez sur Annuler, le processus de téléchargement s’arrête.

Comment installer un correctif logiciel Microsoft Dynamics NAV ou un fichier de mise à jour

Les correctifs et mises à jour de la plateforme Microsoft Dynamics NAV sont disponibles sous forme de fichiers uniques. Pour installer un correctif logiciel microsoft Dynamics NAV ou une mise à jour, vous devez remplacer les fichiers d’installation microsoft Dynamics NAV existants par le correctif logiciel ou les fichiers de mise à jour. Pour cela, procédez comme suit :

Étape 1 : Remplacer les fichiers dans l’installation de Microsoft Dynamics NAV Classic Client

Dans l’installation de Microsoft Dynamics NAV Classic Client, remplacez les fichiers suivants à l’aide du correctif logiciel ou du fichier de mise à jour.

Nom de fichier Version du fichier Taille du fichier Date Heure Plateforme
Dbm.dll 6.0.30677.0 427,848 24-Fév-2010 16:15 x86
Fin.exe 6.0.30677.0 12,597,064 24-Fév-2010 15 : 17 x86
Finhlink.exe 6.0.30677.0 452,432 24-Fév-2010 15 : 17 x86
Finsql.exe 6.0.30677.0 12,718,928 24-Fév-2010 15 : 17 x86
Nc_netb.dll 6.0.30677.0 96,592 24-Fév-2010 16:15 x86
Nc_tcp.dll 6.0.30677.0 98,640 24-Fév-2010 16:15 x86
Nc_tcps.dll 6.0.30677.0 141,136 24-Fév-2010 16:15 x86
Ndbcs.dll 6.0.30677.0 1,348,944 24-Fév-2010 16:15 x86
Slave.exe 6.0.30677.0 152,400 24-Fév-2010 16:15 x86

Pour remplacer les fichiers Microsoft Dynamics NAV existants, procédez comme suit :

  1. Fermez microsoft Dynamics NAV Classic Client.

  2. Recherchez le répertoire d’installation de Microsoft Dynamics NAV Classic Client. Microsoft Dynamics NAV Classic Client est généralement installé dans le répertoire suivant :

    C :\Program Files\Microsoft Dynamics NAV\60\Classic

  3. Copiez les fichiers que vous avez téléchargés.

  4. Collez les fichiers que vous avez téléchargés dans le répertoire d’installation de Microsoft Dynamics NAV Classic Client.

  5. Cliquez sur Oui pour remplacer les fichiers du répertoire.

Étape 2 : Remplacer les fichiers dans l’installation du client Microsoft Dynamics NAV RoleTailored

Dans l’installation du client Microsoft Dynamics NAV RoleTailored, remplacez les fichiers suivants à l’aide du correctif logiciel ou du fichier de mise à jour.

Nom de fichier Version du fichier Taille du fichier Date Heure Plateforme
Microsoft.dynamics.framework.patterns.dll 1.3.10803.137 71,656 24-Fév-2010 06:30 x86
Microsoft.dynamics.framework.ui.dll 1.3.10803.137 698,328 24-Fév-2010 06:30 x86
Microsoft.dynamics.framework.ui.mapping.dll 1.3.10803.137 104,424 24-Fév-2010 06:30 x86
Microsoft.dynamics.framework.ui.navigation.dll 1.3.10803.137 34,800 24-Fév-2010 06:30 x86
Microsoft.dynamics.framework.ui.ux2006.dll 1.3.10803.137 88,040 24-Fév-2010 06:30 x86
Microsoft.dynamics.framework.ui.ux2006.winforms.dll 1.3.10803.137 63,480 24-Fév-2010 06:30 x86
Microsoft.dynamics.framework.ui.windows.dll 1.3.10803.137 83,944 24-Fév-2010 06:30 x86
Microsoft.dynamics.framework.ui.winforms.controls.dll 1.3.10803.137 2,111,488 24-Fév-2010 06:30 x86
Microsoft.dynamics.framework.ui.winforms.dll 1.3.10803.137 690,152 24-Fév-2010 06:30 x86
Microsoft.dynamics.nav.client.builder.dll 6.0.30677.0 198,544 24-Fév-2010 15:05 x86
Microsoft.dynamics.nav.client.exe 6.0.30677.0 149,376 24-Fév-2010 15:05 x86
Microsoft.dynamics.nav.client.interop.communicator.dll 1.0.559.183 75,688 24-Fév-2010 15:05 x86
Microsoft.dynamics.nav.client.serviceconnection.dll 6.0.30677.0 104,352 24-Fév-2010 15:05 x86
Microsoft.dynamics.nav.client.ui.dll 6.0.30677.0 505,728 24-Fév-2010 15:05 x86
Microsoft.dynamics.nav.client.winforms.dll 6.0.30677.0 337,808 24-Fév-2010 15:05 x86
Microsoft.dynamics.nav.client.winforms.tlb Non applicable 2,644 24-Fév-2010 1,205 Non applicable
Microsoft.dynamics.nav.language.dll 6.0.30677.0 1,992,576 24-Fév-2010 15:05 x86
Microsoft.dynamics.nav.types.dll 6.0.30677.0 567,160 24-Fév-2010 15:06 x86
Microsoft.office.interop.outlook.dll 10.0.4504.0 395,136 24-Fév-2010 15 : 17 x86

Pour remplacer ces fichiers, procédez comme suit :

  1. Fermez le client Microsoft Dynamics NAV RoleTailored.

  2. Recherchez le répertoire d’installation du client Microsoft Dynamics NAV RoleTailored. Le client Microsoft Dynamics NAV RoleTailored est généralement installé dans le répertoire suivant :

    C :\Program Files\Microsoft Dynamics NAV\60\RoleTailored Client

  3. Copiez les fichiers que vous avez téléchargés.

  4. Collez les fichiers que vous avez téléchargés dans le répertoire d’installation du client Microsoft Dynamics NAV RoleTailored.

  5. Cliquez sur Oui pour remplacer les fichiers du répertoire.

Étape 3 : Remplacer les fichiers dans l’installation de Microsoft Dynamics NAV Server

Dans l’installation de Microsoft Dynamics NAV Server, remplacez les fichiers suivants à l’aide du correctif logiciel ou du fichier de mise à jour.

Nom de fichier Version du fichier Taille du fichier Date Heure Plateforme
Httpcfg.exe 5.2.3790.0 22,352 24-Fév-2010 15 : 17 x86
Microsoft.dynamics.nav.language.dll 6.0.30677.0 1,992,576 24-Fév-2010 15:06 x86
Microsoft.dynamics.nav.ncl.dll 6.0.30677.0 608,120 24-Fév-2010 15:06 x86
Microsoft.dynamics.nav.server.exe 6.0.30677.0 141,184 24-Fév-2010 15:05 x86
Microsoft.dynamics.nav.service.dll 6.0.30677.0 145,280 24-Fév-2010 15:05 x86
Microsoft.dynamics.nav.service.runtime.dll 6.0.30677.0 75,664 24-Fév-2010 15:05 x86
Microsoft.dynamics.nav.service.webservices.dll 6.0.30677.0 145,304 24-Fév-2010 15:05 x86
Microsoft.dynamics.nav.types.dll 6.0.30677.0 567,160 24-Fév-2010 15:06 x86
Microsoft.dynamics.nav.watson.dll 6.0.30677.0 42,880 24-Fév-2010 15:05 x86
Nclcsrt.etx Non applicable 89,525 24-Fév-2010 08:28 Non applicable
Nclcsrt.stx Non applicable 91,724 24-Fév-2010 08:28 Non applicable
Nclcsrts.dll 6.0.30677.0 1,473,872 24-Fév-2010 15 : 17 x86
Ndbcs.dll 6.0.30677.0 1,348,944 24-Fév-2010 15 : 17 x86

Pour remplacer ces fichiers, procédez comme suit :

  1. Arrêtez microsoft Dynamics NAV Server.

  2. Recherchez le répertoire d’installation de Microsoft Dynamics NAV Server. Microsoft Dynamics NAV Server est généralement installé dans le répertoire suivant :

    C :\Program Files\Microsoft Dynamics NAV\60\Service

  3. Copiez les fichiers que vous avez téléchargés.

  4. Collez les fichiers que vous avez téléchargés dans le répertoire d’installation de Microsoft Dynamics NAV Server.

  5. Cliquez sur Oui pour remplacer les fichiers du répertoire.

  6. Démarrez microsoft Dynamics NAV Server.

Étape 4 : Remplacer les fichiers dans l’installation de Microsoft Dynamics NAV Application Server

Si Microsoft Dynamics NAV Application Server est installé, remplacez les fichiers suivants dans l’installation de Microsoft Dynamics NAV Application Server à l’aide du correctif logiciel ou des fichiers de mise à jour.

Nom de fichier Version du fichier Taille du fichier Date Heure Plateforme
Dbm.dll 6.0.30677.0 427,848 24-Fév-2010 16:15 x86
Nas.exe 6.0.30677.0 2,259,784 24-Fév-2010 15 : 17 x86
Nassql.exe 6.0.30677.0 2,358,096 24-Fév-2010 15 : 17 x86
Ndbcs.dll 6.0.30677.0 1,348,944 24-Fév-2010 16:15 x86
Slave.exe 6.0.30677.0 152,400 24-Fév-2010 16:15 x86

Pour remplacer les fichiers, procédez comme suit.

  1. Arrêtez le serveur d’applications Microsoft Dynamics NAV.

  2. Recherchez le répertoire d’installation de Microsoft Dynamics NAV Application Server. Microsoft Dynamics NAV Application Server est généralement installé dans le répertoire suivant :

    C :\Program Files\Microsoft Dynamics NAV\60\Application Server

  3. Copiez les fichiers que vous avez téléchargés.

  4. Collez les fichiers que vous avez téléchargés dans le répertoire d’installation de Microsoft Dynamics NAV Application Server.

  5. Cliquez sur Oui pour remplacer les fichiers du répertoire.

  6. Démarrez le serveur d’applications Microsoft Dynamics NAV.

Après avoir appliqué ce correctif, le RTC tente d’abord de fermer le moteur de rapport. Si le moteur de rapport ne peut pas être fermé, le RTC attend une seconde, puis réessaye jusqu’à 30 fois.

Configuration requise

Microsoft Dynamics NAV 2009 Service Pack 1 doit être installé pour appliquer ce correctif.

État

Microsoft a confirmé qu’il s’agit d’un bogue dans les produits Microsoft répertoriés dans la section « S’applique à ».

Informations supplémentaires

Pour plus d’informations, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

824684 Terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft

MICROSOFT ET/OU SES FOURNISSEURS NE FONT AUCUNE DÉCLARATION OU GARANTIE QUANT À LA PERTINENCE, À LA FIABILITÉ OU À L’EXACTITUDE DES INFORMATIONS CONTENUES DANS LES DOCUMENTS ET LES GRAPHIQUES ASSOCIÉS PUBLIÉS SUR CE SITE WEB (LES « SUPPORTS ») À QUELQUE FIN QUE CE SOIT.

LES DOCUMENTS PEUVENT INCLURE DES IMPRÉCISIONS TECHNIQUES OU DES ERREURS TYPOGRAPHIQUES ET PEUVENT ÊTRE MODIFIÉS À TOUT MOMENT SANS PRÉAVIS. DANS LA MESURE MAXIMALE AUTORISÉE PAR LA LOI EN VIGUEUR, MICROSOFT ET/OU SES FOURNISSEURS REJETTENT ET EXCLUENT TOUTES LES REPRÉSENTATIONS, GARANTIES ET CONDITIONS EXPRESSES, IMPLICITES OU LÉGALES, Y COMPRIS, MAIS SANS S’Y LIMITER, LES REPRÉSENTATIONS, GARANTIES OU CONDITIONS DE TITRE, L’ABSENCE DE CONTREFAÇON, LA CONDITION SATISFAISANTE OU LA QUALITÉ, LA QUALITÉ MARCHANDE ET L’ADÉQUATION À UN USAGE PARTICULIER, EN CE QUI CONCERNE LE MATÉRIEL.