Cet article s’applique à Microsoft Dynamics NAV pour tous les pays et tous les paramètres régionaux de langue.
Symptômes
Lorsque le processus de synchronisation Outlook est exécuté à partir de Microsoft Office Outlook pour se synchroniser avec Microsoft Dynamics NAV 5.0 avec Service Pack 1 (SP1), avec Microsoft Dynamics NAV 2009 ou avec Microsoft Dynamics NAV 2009 avec SP1, Microsoft Dynamics NAV Application Server (NAS) génère le message d’erreur suivant :
Remarque
La réponse de Microsoft Dynamics NAV n’a pas été reçue en raison du délai d’expiration de la connexion. Veuillez case activée si le serveur Microsoft Dynamics NAV est en cours d’exécution et réessayez ultérieurement. Si le problème persiste, augmentez la valeur du délai d’expiration dans le fichier de configuration.
Ce problème se produit si la table Entrée du journal des modifications (405) contient un grand nombre d’enregistrements.
Cause
Ce problème se produit pour l’une des raisons suivantes :
- La dernière tentative de synchronisation n’a pas réussi.
- Si le processus de synchronisation n’a pas été exécuté récemment, une analyse complète de la table est effectuée pour vérifier les modifications dans la table Entrée du journal des modifications (405). Cela provoque une erreur de délai d’attente lorsque la table Entrée du journal des modifications contient un grand nombre d’enregistrements.
Résolution
Informations sur le correctif logiciel
Un correctif logiciel pris en charge est désormais disponible auprès de Microsoft. Toutefois, il est uniquement destiné à corriger le problème décrit dans cet article. Appliquez-la uniquement aux systèmes qui rencontrent ce problème spécifique. Ce correctif logiciel peut recevoir des tests supplémentaires. Par conséquent, si vous n’êtes pas gravement affecté par ce problème, nous vous recommandons d’attendre le prochain Service Pack Microsoft Dynamics NAV ou la prochaine version qui contient ce correctif logiciel.
Remarque Dans des cas particuliers, les frais habituellement engagés pour les appels de support peuvent être annulés si un professionnel du support technique pour Microsoft Dynamics et les produits associés détermine qu’une mise à jour spécifique permettra de résoudre votre problème. Les coûts habituels du support technique s’appliqueront aux autres questions et problèmes non directement liés à la mise à jour en question.
Informations sur l’installation
Microsoft fournit des exemples de programmation à des fins d’illustration uniquement, sans garantie exprimée ou implicite. Cela inclut, sans s’y limiter, les garanties implicites de qualité commerciale ou d’adéquation à un usage particulier. Cet article part du principe que vous êtes familiarisé avec le langage de programmation présenté et avec les outils utilisés pour créer et déboguer des procédures. Les techniciens du Support technique Microsoft peuvent vous expliquer les fonctionnalités d'une procédure particulière, mais ils ne peuvent pas modifier les exemples en vue de vous fournir des fonctionnalités supplémentaires ou de créer des procédures répondant à vos besoins spécifiques.
Remarque Avant d’installer ce correctif logiciel, vérifiez que tous les utilisateurs du client Microsoft Navision sont déconnectés du système. Cela inclut les utilisateurs du client Nas (Microsoft Navision Application Services). Vous devez être le seul utilisateur client connecté lorsque vous implémentez ce correctif logiciel.
Pour implémenter ce correctif logiciel, vous devez disposer d’une licence de développeur.
Nous vous recommandons d’attribuer au compte d’utilisateur dans la fenêtre Connexions Windows ou dans la fenêtre Connexions de base de données l’ID de rôle « SUPER ». Si l’ID de rôle « SUPER » ne peut pas être attribué au compte d’utilisateur, vous devez vérifier que le compte d’utilisateur dispose des autorisations suivantes :
- Autorisation Modifier pour l’objet que vous allez modifier.
- Autorisation Exécuter pour l’objet ID d’objet système 5210 et pour l’objet ID d’objet système 9015.
Remarque Vous n’avez pas besoin de disposer de droits sur les magasins de données, sauf si vous devez effectuer une réparation des données.
Modifications du code
Remarque Toujours tester les correctifs de code dans un environnement contrôlé avant d’appliquer les correctifs à vos ordinateurs de production.
Pour installer ce correctif logiciel, modifiez le code dans la fonction RemoveChangeLogDuplicates de la synchronisation Outlook. NAV Mgt codeunit (5301) comme suit :
Code existant
...
ChangeLogEntry.SETCURRENTKEY("Table No.","Date and Time");
TempChangeLogEntry.RESET;
TempChangeLogEntry.DELETEALL;
IF ChangeLogEntry.FIND('+') THEN
REPEAT
IF ChangeLogEntry."Primary Key" <>TempChangeLogEntry."Primary Key" THEN BEGIN
TempChangeLogEntry.SETRANGE("Primary Key",ChangeLogEntry."Primary Key");
IF NOT TempChangeLogEntry.FIND('-') THEN BEGIN
TempChangeLogEntry.INIT;
TempChangeLogEntry := ChangeLogEntry;
TempChangeLogEntry.INSERT;
END;
END;
UNTIL ChangeLogEntry.NEXT(-1) = 0;
TempChangeLogEntry.RESET;
...
Code de remplacement
...
ChangeLogEntry.SETCURRENTKEY("Table No.","Date and Time");
ChangeLogEntry.SETFILTER("Date and Time" , '>=%1', OSynchUserSetup."Last Synch. Time"); // Add this line.
TempChangeLogEntry.RESET;
TempChangeLogEntry.DELETEALL;
IF ChangeLogEntry.FIND('+') THEN
REPEAT
IF ChangeLogEntry."Primary Key" <>TempChangeLogEntry."Primary Key" THEN BEGIN
TempChangeLogEntry.SETRANGE("Primary Key",ChangeLogEntry."Primary Key");
IF NOT TempChangeLogEntry.FIND('-') THEN BEGIN
TempChangeLogEntry.INIT;
TempChangeLogEntry := ChangeLogEntry;
TempChangeLogEntry.INSERT;
END;
END;
UNTIL ChangeLogEntry.NEXT(-1) = 0;
TempChangeLogEntry.RESET;
...
Configuration requise
L’un des produits suivants doit être installé pour appliquer ce correctif :
- Microsoft Dynamics NAV 2009 SP1
- Microsoft Dynamics NAV 2009
- Microsoft Dynamics NAV 5.0 SP1
Informations sur la suppression
Vous ne pouvez pas supprimer ce correctif logiciel.
État
Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».
Remarque Il s’agit d'un article de « dernière minute » créé directement à partir de l’organisation de support technique Microsoft. Les informations présentées ici sont fournies telles quelles en réponse à des problèmes nouveaux. En raison de la rapidité de leur mise à disposition, les documents peuvent contenir des erreurs typographiques et être modifiés à tout moment sans préavis. Consultez les Conditions d’utilisation pour d’autres considérations.