CORRECTIF : SQLCODE -379 retourné pour l’instruction CALL du serveur lié en quatre parties par rapport à la procédure stockée DB2 pour iSeries

S’applique à
Host Integration Server 2013 Host Integration Server 2016

Symptômes

Lorsque vous exécutez une instruction CALL de serveur lié Microsoft SQL Server Distributed Query Processor sur DB2 pour i, SQL Server retourne un message d’erreur semblable au suivant :

Remarque

  • Le fournisseur OLE DB « DB2OLEDB » pour le serveur lié «< nom >du serveur lié » a retourné le message « Une erreur de bibliothèque réseau interne s’est produite. Une erreur de syntaxe au niveau du réseau s’est produite. SQLSTATE : HY000, SQLCODE : -379".
  • Msg 7212, Niveau 17, État 1, Ligne 1 Impossible d’exécuter la procédure «<procedure_name> » sur le serveur distant «< nom >du serveur distant ». "

 

Résolution

Le correctif qui résout ce problème est inclus dans les mises à jour cumulatives suivantes pour Host Integration Server :

Mise à jour cumulative 2 pour Host Integration Server 2016

Mise à jour cumulative 4 pour Host Integration Server 2013

État

Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».

Références

Découvrez la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.