KB2896903 - CORRECTIF : vous ne pouvez pas effectuer d’actions d’administrateur sur les bases de données quand un modèle de données est endommagé dans SSAS 2012 ou SSAS 2014

S’applique à
SQL Server 2012 Analysis Services

Ce correctif logiciel s’applique également à Microsoft SQL Server 2014 Analysis Services (SSAS 2014).

Symptômes

Supposons qu’une base de données soit endommagée dans Microsoft SQL Server 2012 Analysis Services (SSAS 2012) ou SQL Server 2014 Analysis Services (SSAS 2014). Il peut être difficile de déterminer quelle base de données est endommagée et vous ne pouvez effectuer aucune action d’administrateur sur la base de données endommagée. En outre, un message d’erreur semblable au suivant peut s’afficher :

Remarque

Erreurs dans le gestionnaire de métadonnées. Une erreur s’est produite lorsque .... , à partir du fichier .....

Par exemple, lorsque vous supprimez la dimension source d’une dimension liée dans SSAS 2012 ou SSAS 2014, vous recevez un message d’erreur et vous ne pouvez pas retraiter la dimension liée. C’est le comportement attendu, car la dimension source est supprimée. Toutefois, après avoir redémarré l’instance SSAS, vous ne pouvez pas supprimer ou détacher la base de données émise. En outre, vous ne pouvez pas effectuer d’actions d’administrateur sur l’ensemble de l’instance SSAS. Même si sur des bases de données non liées, vous ne pouvez rien modifier.

Après l’application de ce correctif logiciel, la chaîne « - SUSPECT » des bases de données endommagées est ajoutée à leur nom dans Microsoft SQL Server Management Studio (SSMS). Un administrateur pourra également supprimer les bases de données suspectes et effectuer des actions d’administrateur sur d’autres bases de données normales. Pour les bases de données suspectes, un administrateur peut obtenir l’erreur de corruption réelle en cliquant avec le bouton droit sur les bases de données et en affichant leurs propriétés.

Remarque Ce problème se produit également dans SSAS 2008 et SSAS 2008 R2. Les correctifs logiciels correspondants seront bientôt publiés.

Résolution

La possibilité d’isoler une base de données suspecte d’être endommagée est publiée dans la mise à jour cumulative suivante de SQL Server.

Mise à jour cumulative 1 pour SQL Server 2014 /en-us/help/2931693

Mise à jour cumulative 8 pour SQL Server 2012 SP1 /en-us/help/2917531

À propos des mises à jour cumulatives pour SQL Server

Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :

      

État

Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».