KB4578011 - CORRECTIF : impossible de restaurer SQL Server base de données à partir de versions antérieures sur un appareil NVMe partitionné en taille de bloc 4K

S’applique à
SQL Server 2019 on Linux SQL Server 2017 on Linux

Symptômes

Lorsque vous essayez de restaurer une base de données à partir de versions antérieures vers SQL Server 2019 ou 2017 sur Linux sur un appareil NVMe (Non-Volatile Memory Express) partitionné en taille de bloc 4K, la commande de restauration peut échouer avec le message d’erreur suivant.

Msg 3203, Niveau 16, État 1, Ligne LineNumber

Échec de la lecture de « FilePath\FileName » : LineNumber (le paramètre est incorrect.)

Msg 3013, Niveau 16, État 1, Ligne LineNumber

La base de données de restauration se termine anormalement.

État

Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».

Résolution

Ce problème est résolu dans les mises à jour cumulatives suivantes pour SQL Server :

À propos des mises à jour cumulatives pour SQL Server :

Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :

Références

En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.