KB2960237 - CORRECTIF : erreur lors de l’exécution d’une procédure stockée DQS [internal_core]. [RestoreDQDatabases] dans SQL Server

S’applique à
SQL Server 2012 Developer SQL Server 2012 Enterprise SQL Server 2012 Standard SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use)

Symptômes

Prenons le scénario suivant :

  • Vous utilisez Microsoft SQL Server 2012 ou SQL Server 2014.

  • Vous disposez d’une base de données DQS_MAIN existante ou récemment restaurée sur votre serveur Data Quality Services (DQS).

  • Vous exécutez la requête suivante :

    EXECUTE [internal_core].[RestoreDQDatabases] '<PASSWORD>'
    

Dans ce scénario, l’erreur suivante s’affiche :

Remarque

Le mot de passe de la clé master est incorrect. Donnez le mot de passe de la clé master qui a été donné lors de l’installation

Remarque Le PASSWORD est défini sur le mot de passe> de la clé master de base de données que vous avez fournie lors de l’installation du serveur DQS et il est correct.<

Résolution

Le problème a été résolu pour la première fois dans la mise à jour cumulative suivante de SQL Server.

Mise à jour cumulative 1 pour SQL Server 2012 SP2 /en-us/help/2976982

Mise à jour cumulative 2 pour SQL Server 2014 /en-us/help/2967546

Mise à jour cumulative 10 pour SQL Server 2012 SP1 /en-us/help/2954099

À propos des mises à jour cumulatives pour SQL Server

Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :

      

État

Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».