KB3208276 - Mise à jour améliore la gestion des documents trop volumineux pour l’indexation de la recherche Full-Text dans SQL Server

S’applique à
SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Enterprise Core - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use) SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use) SQL Server 2016 Service Pack 1

Résumé

En SQL Server 2012, 2014 ou 2016, lorsque les documents sont trop volumineux pour l’indexation de la recherche Full-Text, une exception semblable à la suivante est consignée dans le journal des erreurs SQL Server et un fichier d’image mémoire est généré. En outre, les requêtes en texte intégral peuvent renvoyer des résultats incorrects.

Remarque

ex_raise2 : Exception soulevée, majeure = 300, mineure = 45, état = 53, gravité = 17

Remarque La prise en charge de l’indexation par recherche Full-Text sur les documents volumineux qui dépassent les valeurs de position des mots supérieures à 4 294 966 016 n’est pas ajoutée dans cette mise à jour.

Une fois que vous avez installé cette mise à jour et SQL Server indexé les documents trop volumineux pour l’indexation Full-Text la recherche, les documents sont ignorés et SQL Server génère un message d’erreur semblable au suivant dans le journal des erreurs de recherche Full-Text au lieu de lever des exceptions et de générer des vidages de fichiers. 

Remarque

Erreur « 0x8004fd0a : Dépassement du compteur d’occurrences, le document n’est pas indexé. » s’est produit pendant le remplissage de l’index en texte intégral pour la table ou la vue indexée object_name (ID de table ou de vue indexée object_id, ID de base de données database_id), la valeur de clé en texte intégral text_key_value. Échec de l’indexation de la ligne.

Résolution

Ce problème est résolu dans les mises à jour cumulatives suivantes pour SQL Server :

Mise à jour cumulative 5 pour SQL Server 2016 RTM

Mise à jour cumulative 2 pour SQL Server 2016 SP1

Mise à jour cumulative 5 pour SQL Server 2014 SP2

Mise à jour cumulative 11 pour SQL Server 2014 Service Pack 1

Mise à jour cumulative 8 pour SQL Server 2012 SP3

À propos des mises à jour cumulatives pour SQL Server

Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :

Dernière mise à jour cumulative pour SQL Server 2016

Dernière mise à jour cumulative pour SQL Server 2014

Dernière mise à jour cumulative pour SQL Server 2012

Références

Découvrez la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.