KB3213703 – CORRECTIF : Un réplica secondaire Always On passe à un état de déconnexion

S’applique à
SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2014 Service Pack 2 - duplicate (do not use) SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Enterprise Core - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use) SQL Server 2012 Developer SQL Server 2012 Enterprise SQL Server 2012 Enterprise Core SQL Server 2012 Standard

Symptômes

Lorsque vous utilisez SQL Server Always On groupes de disponibilité, le réplica secondaire Always On peut se déconnecter. En outre, le message d’erreur suivant est consigné dans le journal des erreurs de SQL Server :

Remarque

Un délai d’attente de connexion s’est produit lors de la tentative d’établissement d’une connexion au réplica de disponibilité availability_replica_name avec l’ID availability_replica_id. Soit un problème de réseau ou de pare-feu existe, soit l’adresse du point de terminaison est fournie pour le réplica.

Quand vous essayez de rétablir la connexion, le message d’erreur ci-dessous peut s’afficher :

Remarque

Cette réplica secondaire n’est pas connectée au réplica principal. L’état connecté est DÉCONNECTÉ.

Dans ce cas, le problème n’est résolu qu’au redémarrage de SQL Server Services sur le réplica secondaire. Dans de rares cas, vous devrez peut-être redémarrer SQL Server Services sur le réplica principal pour reprendre Always On déplacement des données.

Remarque Ce problème peut se produire uniquement sur des ordinateurs très puissants et lorsque SQL Server est très occupé. Par exemple, dans un scénario, ce problème s’est produit sur un système très occupé avec 24 cœurs.

Cause

Le problème se produit en raison d’une condition de concurrence interne.

Résolution

Ce problème a été résolu dans les mises à jour cumulatives suivantes de SQL Server.

À propos des mises à jour cumulatives pour SQL Server

Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :

Dernière mise à jour cumulative pour SQL Server 2016

Dernière mise à jour cumulative pour SQL Server 2014

Dernière mise à jour cumulative pour SQL Server 2012 SP3

État

Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».

Références

Découvrez la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.