Symptômes
Lorsque vous reconstruisez un index pour une table dans Microsoft SQL Server 2012 ou SQL Server 2014, la mémoire cache SQL peut diminuer et l’utilisation du processeur augmenter. En outre, SQL Server peut rencontrer des erreurs de mémoire insuffisante.
Ce problème se produit car une grande quantité de mémoire est utilisée par le commis à la mémoire MEMORYCLERK_SQLLOGPOOL qui est utilisé en interne pour les activités du journal des transactions.
Remarque Ce problème se produit uniquement lorsque vous utilisez des groupes de disponibilité AlwaysOn dans SQL Server 2012 ou SQL Server 2014.
Résolution
Le problème a été résolu pour la première fois dans la mise à jour cumulative suivante de SQL Server.
Mise à jour cumulative 2 pour SQL Server 2012 SP2 /en-us/help/2983175
Mise à jour cumulative 1 pour SQL Server 2014 /en-us/help/2931693
À propos des mises à jour cumulatives pour SQL Server
Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :
- Dernière mise à jour cumulative pour SQL Server 2012 SP2
- Dernière mise à jour cumulative pour SQL Server 2014
État
Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».
Informations supplémentaires
Pour plus d’informations sur le problème similaire décrit dans le correctif 2821783, cliquez sur le numéro suivant pour afficher l’article correspondant dans la Base de connaissances Microsoft.
2821783 CORRECTIF : erreurs de mémoire insuffisante liées à un commis à la mémoire dans SQL Server 2012