Symptômes
Lorsque vous essayez de mettre à niveau votre installation Microsoft SQL Server vers SQL Server 2012 ou SQL Server 2014, le message d’erreur suivant peut s’afficher :
Remarque
L’erreur suivante s’est produite : Le dossier « C :\Program Files\Microsoft SQL Server\MSSQL10_50.INSTANCEID\MSSQL\JOBS » n’existe pas. Le dossier est censé exister pour définir une autorisation sur celui-ci. Examinez pourquoi le dossier n’existe pas et recréez-le.
Cause
Ce problème se produit si le dossier JOBS a été supprimé de son répertoire par défaut. Pendant la mise à niveau, le processus de mise à niveau tente de définir les autorisations requises sur le dossier JOBS. Toutefois, si le dossier a disparu, les autorisations ne peuvent pas être appliquées et la mise à niveau échoue.
Résolution
Le problème a été résolu pour la première fois dans la mise à jour cumulative suivante de SQL Server.
Mise à jour cumulative 8 pour SQL Server 2014 /en-us/help/3067836
Mise à jour cumulative 6 pour SQL Server 2012 SP2 /en-us/help/3052468
À propos des mises à jour cumulatives pour SQL Server
Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :
- Dernière mise à jour cumulative pour SQL Server 2014
- Dernière mise à jour cumulative pour SQL Server 2012 SP2
Pour résoudre ce problème, recréez le dossier JOBS, désinstallez la mise à niveau ayant échoué, puis réexécutez la mise à niveau. Pour ce faire, procédez comme suit :
En utilisant le fichier Summary.txt comme référence, recherchez le chemin d’accès au dossier JOBS requis par le processus d’installation, puis recréez le dossier. Par exemple, le Summary.txt peut contenir les éléments suivants :
Remarque
Description de l’erreur : le dossier « C :\Program Files\Microsoft SQL Server\MSSQL11. ProdSQL\MSSQL\JOBS' n’existe pas. Le dossier est censé exister pour définir une autorisation sur celui-ci. Examinez pourquoi le dossier n’existe pas et recréez-le.
À l’aide du même fichier Summary.txt que celui référencé à l’étape 1, recherchez la commande de désinstallation. Par exemple, le fichier Summary.txt peut contenir les éléments suivants :
Étape suivante pour SQLEngine : Le processus de mise à niveau pour SQL Server a échoué. Pour continuer le processus de mise à niveau, utilisez les informations suivantes pour résoudre l’erreur. Désinstallez ensuite SQL Server à l’aide de la ligne de commande suivante : setup /q /action=uninstall /instanceid=ProdSQL /features=SQLENGINE,FULLTEXT,REPLICATION
Ensuite, exécutez à nouveau le programme d’installation de SQL Server.Ouvrez une invite de commandes, puis recherchez le répertoire qui contient le support d’installation de la mise à niveau. Par exemple, si vous effectuez une mise à niveau de SQL Server 2012 vers SQL Server 2014, utilisez le support d’installation de SQL Server 2014.
Copiez et exécutez la commande de l’étape 2 à une invite de commandes afin de supprimer l’installation partielle. Par exemple, pour désinstaller un instance qui contient un ID instance de « ProdSQL » dont la mise à niveau a échoué, exécutez la commande suivante :
setup /q /action=uninstall /instanceid=ProdSQL /features=SQLENGINE,FULLTEXT,REPLICATION
Remarque : lorsque vous exécutez la commande de désinstallation, celle-ci ne supprime pas l’instance d’origine que vous essayez de mettre à niveau. Elle supprime uniquement l’installation inactive/partielle de la nouvelle version.
Réexécutez le processus de mise à niveau.
Informations supplémentaires
Pour plus d’informations, reportez-vous à la section Mise à niveau vers SQL Server 2014.