KB3051243 - CORRECTIF : L’erreur 2601 se produit lorsque vous ajoutez de nouveaux articles avec des filtres de jointure à des publications de fusion existantes

S’applique à
SQL Server 2012 Developer SQL Server 2012 Enterprise SQL Server 2012 Standard SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use)

Symptômes

Supposons que vous utilisez la réplication de fusion dans Microsoft SQL Server 2012 ou SQL Server 2014 et que vous ajoutez de nouveaux articles avec des filtres de jointure aux publications existantes. Lorsque les abonnés existants commencent à synchroniser (immédiatement après avoir ajouté de nouveaux articles) et que la synchronisation est interrompue, la synchronisation suivante peut échouer avec une erreur de clé en double sur dbo.sysmergesubsetfilters jusqu’à ce que vous réinitialisiez les abonnés affectés. Le message d’erreur peut se présenter comme suit :

Remarque

Source : Fournisseur de réplication de fusion
Nombre : -2147201001
Message : Le processus de fusion n’a pas pu fournir l’instantané à l’Abonné. Si vous avez utilisé la synchronisation web, le processus de fusion n’a peut-être pas pu créer ou écrire dans le fichier de message. Lors de la résolution du problème, redémarrez la synchronisation avec la journalisation de l’historique détaillé et spécifiez un fichier de sortie dans lequel écrire.
Source : Microsoft SQL Server Native Client 11.0
Numéro : 2601
Message : impossible d’insérer une ligne de clé en double dans l’objet 'dbo.sysmergesubsetfilters' avec l’index unique 'uc2sysmergesubsetfilters'. Valeur de clé dupliquée (<valeur >de clé, <nom de la> table).

Résolution

Ce problème a été résolu dans la mise à jour cumulative de SQL Server suivante :

Recommandation : Installer la dernière mise à jour cumulative pour SQL Server

Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Nous vous recommandons de télécharger et d’installer les dernières mises à jour cumulatives pour SQL Server :

      

État

Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».