Symptômes
Supposons que vous exécutez une requête distante telle qu’une sp_batch_params dans une procédure stockée dans Microsoft SQL Server 2012, 2014 ou 2016. Si le nom d’utilisateur n’est pas valide et ne peut pas se connecter au serveur distant, votre instance de SQL Server se bloque et vous recevez un message d’erreur générique.
Résolution
Après l’application de ce correctif logiciel, l’instance de SQL Server ne se bloque pas et le message d’erreur suivant s’affiche lorsque vous exécutez la requête décrite dans la section « Symptômes » :
Remarque
Msg 18487, Niveau 14, État 1,
Échec de la connexion pour le nom> d’utilisateur de l’utilisateur<. Raison : Le mot de passe du compte a expiré.
Msg 18456, Niveau 14, État 1,
Échec de la connexion pour le nom> d’utilisateur de l’utilisateur<.
Le problème a été résolu pour la première fois dans les mises à jour cumulatives suivantes de SQL Server :
- Mise à jour cumulative 2 pour SQL Server 2016
- Mise à jour cumulative 1 pour SQL Server 2014 SP2
- Mise à jour cumulative 4 pour SQL Server 2014 SP1
- Mise à jour cumulative 10 pour SQL Server 2014
- Mise à jour cumulative 4 pour SQL Server 2012 Service Pack 3
Recommandation : Installer la dernière mise à jour cumulative pour SQL Server
Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Nous vous recommandons de télécharger et d’installer les dernières mises à jour cumulatives pour SQL Server :
- Dernière mise à jour cumulative pour SQL Server 2016
- Dernière mise à jour cumulative pour SQL Server 2014 (SP1/SP2)
- Dernière mise à jour cumulative pour SQL Server 2014
- Dernière mise à jour cumulative pour SQL Server 2012 SP3
État
Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».