Symptômes
Si vous définissez le paramètre de la stratégie de groupe Activer l’exécution de script sur Autoriser tous les scripts, l’utilitaire sqlps ne parvient pas à s’exécuter et le message d’erreur suivant s’affiche :
Remarque
Microsoft (R) SQL Server (R) PowerShell
Version 11.0.5058.0
Copyright (c) 2012 Microsoft. Tous droits réservés.
set-executionpolicy : Windows PowerShell a mis à jour votre stratégie d’exécution avec succès, mais le paramètre est remplacé par une stratégie définie à une portée plus spécifique. En raison de la substitution, votre interpréteur de commandes conserve sa stratégie d’exécution effective actuelle « Sans restriction ». Tapez « Get-ExecutionPolicy -List » pour afficher vos paramètres de stratégie d’exécution. Pour plus d’informations, consultez « Get-Help Set-ExecutionPolicy ».
At line :1 char :20
+ set-executionpolicy <<<< RemoteSigned -scope process -Force
+ CategoryInfo : PermissionDenied : (:) [Set-ExecutionPolicy], SecurityException
+ FullyQualifiedErrorId : ExecutionPolicyOverride,Microsoft.PowerShell.Commands.SetExecutionPolicyCommand
En outre, le travail syspolicy_purge_history échoue.
Remarque Le paramètre Activer l’exécution de script de la stratégie de groupe peut être configuré à l’emplacement suivant dans la console de gestion de la stratégie de groupe :
Modèles administratifs\Modèles d’administration classiques\Composants Windows\Windows PowerShell
Résolution
Ce problème est résolu dans les mises à jour cumulatives de SQL Server suivantes :
Mise à jour cumulative 3 pour SQL Server 2016 SP1
Mise à jour cumulative 9 pour SQL Server 2014 SP1
Mise à jour cumulative 3 pour SQL Server 2014 SP2
Mise à jour cumulative 4 pour SQL Server 2012 Service Pack 3
Recommandation : Installer la dernière mise à jour cumulative pour SQL Server
Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :
Dernière mise à jour cumulative pour SQL Server 2016
Dernière mise à jour cumulative pour SQL Server 2012 SP3
Dernière mise à jour cumulative pour SQL Server 2014 SP1/SP2
État
Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».
Références
En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.